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     Chapter1
Congratulations on purchasing TurboFLOORPLAN! 

TurboFLOORPLAN (TFP) is for anyone who wants to design, 
renovate, decorate or landscape a home. This high-quality, 
multi-functional tool is easy to use and delivers the results you 
want — completely and accurately. TFP’s automated features 
give you the freedom to be creative and bring your ideas to 
life, without much work at all. 

Whether you are just playing around with different design 
ideas, or preparing drawings for a building or landscaping 
professional, TFP makes it fun and easy.

Depending on the TFP product you have, possible uses 
include:

• Home design • 3D visualization/animation

• Floor plans • Photorealistic rendering

• Interior design • Landscaping

• Exterior design • Budget and materials list

• Remodeling • Working drawings

Welcome
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About this Guide
The TurboFLOORPLAN User’s Guide covers basics concepts 
and procedures for the following products:

• TurboFLOORPLAN Home & Landscape Pro
• TurboFLOORPLAN Home Designer
• TurboFLOORPLAN Landscape & Deck

The guide does not cover every possible topic. However, you 
can find detailed information on just about anything in the 
online help (press F1, or select Help > Program Help). 

Since the guide is designed for use with a number of TFP 
products, some topics may not apply to your particular 
product. In the case where a topic applies to a specific product 
only, it will be clearly noted with the topic.

Take a few minutes now to familiarize yourself with the 
guide’s content and layout so that you can find the 
information you need when you are working on your project.

Installing the Program
For installation instructions, please refer to the Quick Start 
Guide attached to the inside cover of the DVD case. 

Where Do I Start?
Not sure how to get started? We highly recommend going 
through the Quick Start Guide attached to the inside cover of 
the DVD case. It contains a tutorial and valuable information 
that will get you up and running very quickly.

Starting a New Project
If you are using TFP Home & Landscape Pro or TFP Home 
Designer, the House Builder Wizard launches every time you 
start the program or start a new project. The House Builder 
Wizard can help you build a home automatically (see page 43). 
If you would prefer to draw from scratch, just click Cancel in 
the House Builder Wizard.

If the program is already running, you can start a new project 
by selecting File > New. 
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Viewing Sample Projects
To give you an idea of the things you can do with TFP, you 
may want to view some sample projects. These projects are 
located in the program’s Samples directory.

To view sample projects:

1. Select File > Open Samples.

2. In the Open dialog, select the project you would like to 
view, then click Open.

Adjusting Your Display Settings
You can control program performance by ensuring your 
Windows® display settings are set correctly.

To adjust your display settings:

1. From the Windows Start menu, select Settings > Control 
Panel.

2. In the Control Panel window, double-click Display.

3. In the Display Properties dialog, select the Settings tab.

4. From the Color drop box, select True Color (32 bit).

Note: If 32-bit is unavailable, select 24-bit.

5. In the Screen area section, move the slider to display at 
least 1024 x 768 pixels.

6. Click OK.

Online Help
TFP includes a comprehensive online help system that 
includes all of the information found in this User’s Guide, 
plus much more. You can browse through all help topics, or 
get help for a specific element, tool or dialog while you are 
designing. 

To access the online help file:

• Select Help > Program Help, or
• Press F1, or
• Click the Program Help button on the Standard 

toolbar
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To get help for a specific part of your drawing:

1. Select the element you want help with.

2. Right-click and select the Tool Help option for that 
element (e.g. Walls Help). Help for the element is 
displayed. 

You can also access the Tool Help from the Edit > Modify 
Elements menu. 

To get help in a dialog:

1. Click the Dialog Help button in the dialog. A window is 
displayed that describes the content of the dialog.

Tool Help

Dialog
Help
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Glossary of Terms
You can instantly access a glossary of technical and 
construction terms from the Help menu.

To view the Glossary of Terms:

1. Select Help > Glossary of Terms.

Getting the Answers You Need

Searchable Help 

Select Program Help from the program’s Help menu. If you 
have questions about a particular topic and you can not find it 
in User’s Guide, you can search for it in the onscreen help.

FREE Installation Assistance

FREE installation assistance is available by calling 
(505) 248-9999.

Technical Support

Free Support on Demand is available online at 
http://www.turbofloorplan.com/support. 

It includes FAQ‘s, Product Updates and a searchable 
Knowledge Base.

Email Support on Demand

$4.95 per incident and requires completion of the form at 
http://www.turbofloorplan.com/support/
support_email.html.

An incident is defined as one question and one solution, 
regardless of how long it may take to resolve the issue. All 
major credit cards accepted.

Phone Support on Demand

$9.95 per incident at (505) 248-9999.  An incident is defined as 
one question and one solution, regardless of how long it may 
take to resolve the issue. All major credit cards accepted.
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Customer Service and Sales

For all non-technical, pre-sales and upgrade information visit 
us online at http://www.turbofloorplan.com or contact a 
sales associate at 1+800 833-8082.
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     Chapter2
When you insert a building element in your drawing, such as 
a wall, door or window, it is inserted on the current building 
location. It is important to define your building locations 
before inserting building elements, since locations are the key 
to organizing elements and inserting them at the correct 
height in your model. 

If you are drawing from scratch, the program’s default 
drawing templates have three pre-defined building locations: 
Foundation, Ground Floor, and Second Floor. You can change 
the settings for existing building locations as well as add and 
delete locations. 

If you use the House Builder Wizard to start your project, your 
main building locations are set up for you when you run the 
House Builder Wizard. 

This chapter describes how to define your building locations, 
and identify the current building location when adding 
building elements to your design.

Note: Most landscaping elements are inserted on the terrain 
and not on a building location. The exceptions are decks, and 
exterior furnishings and accessories inserted with the "Insert 
on Location" option.

Building Locations
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Defining Building Locations
When you define building locations, you are basically doing 
two things:

• setting the wall height for each floor (level) in your model 

• specifying where each floor is positioned relative to the 
ground (zero) 

To view building location settings:

1. Select Settings > Building Locations, or click the 
Building Locations button on the View Control 
toolbar.

Below is a brief description of each building location property.

Number.  A reference number for the location.

Name.  The location’s name (e.g. Ground Floor).

Floor Level.  Height of floor base above ground level (0).

Head Height.  Height of tops of windows and wall openings 
relative to the floor level. 

Ceiling Height.  Height of underside of ceiling surface relative 
to the floor level. 

Wall Height.  Physical height of the walls on the location.
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By default, if you are drawing from scratch, the Foundation 
location has a Floor Level of -8’, meaning the base of the 
foundation is positioned 8’ below ground level. (In other 
words, it is a full basement.) The Wall Height of the 
Foundation location is 8’. Therefore, the top of the foundation 
wall will be situated at ground level. 

By default, the Ground Floor and Second Floor locations each 
have their Wall Height set to 8’. The Floor Level of the Ground 
Floor is set to 1’. This means that the floor will be situated 1’ 
above the ground. To handle the 1’ gap between the Ground 
Floor and Foundation, the exterior faces of the walls on the 
Ground Floor are dropped 1’. 

To change the properties of a building location:

1. In the Building Locations dialog, click on the property you 
want to change. You can change location names or any of 
the numerical settings. 

2. Type the value you want.

3. Press Enter.

To add a new building location:

1. In the Building Locations dialog, click the Add Location 
button. A new location is added to the bottom of the list.

Note: By default the new location will adopt the numerical 
settings of the currently selected location. 

2. Specify the location’s properties. To specify a property, 
click on the current value, type the new value, then press 
Enter.

Note: When you add a location to your list, it does not become 
the current location unless you select it in the list or edit its 
properties.

To delete a building location:

1. In the Building Locations dialog, click on one of the 
location’s fields to make it the current location. 

2. Click Delete Location.
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Note: You cannot delete a location if it contains any elements. 
Also, you cannot delete a location if it is the only one in the 
list.

Current Building Location
Before inserting a building element in your drawing you 
should make sure that the building location you want to insert 
the element on is the current building location.

To make a building location current:

• Click on the building locations drop box on the View 
Control toolbar and select the desired location.

or

• In the Building Locations dialog, click in the far left field 
of the location you want to make current. A check mark 
indicates the location is now current.

Tip: When a building location is current, elements on other 
locations are still visible, but dimmed. This can help you 
position elements on the current location.

Check mark identifies
the current location
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Everything is point-and-click in TFP, making it extremely 
simple to use and leaving you free to be as creative as you like. 
All elements are intelligent and know what they are in relation 
to other elements. For example, a door can only be inserted in 
a wall. TFP automatically displays dimensions as you draw, 
making it even easier to create accurate drawings right from 
the start. 

While working on your project, you will probably want to edit 
it as you go. You can select elements by clicking on them, or by 
drawing a selection window around them. 

This chapter describes the basics of inserting elements, and 
selecting them for editing.

Inserting Elements
When you select a tool from the Insert menu or one of the 
insertion toolbars, you are in Insertion mode. To insert an 
element, you select it in the catalog panel, then click in your 
drawing area.

Many elements can be inserted with a single mouse click. 
Single-click elements include doors, windows, stairs, columns, 
cabinets, furniture, appliances, light fixtures, electrical 

Drawing & Editing 
Basics
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elements, plumbing fixtures, and plants. Line-drawn elements, 
like walls, railings, edging and fences, require that you select 
two points to define the element’s start point and end point. 
The points you pick determine the element’s length and angle. 
Area-drawn elements, such as pads, fills and plateaus, are 
drawn by picking a series of points to define their outline.

In many cases, on-screen dimensions are displayed as you 
draw, making it easy to create line-drawn and area-drawn 
elements at the correct length or size, and insert elements like 
doors and windows precisely where you want them in a wall.

Once you insert an element in your drawing area, you can:

• Continue inserting the same element
• Select a different element in the catalog to insert
• Right-click and select Finish to end the command and 

return to Selection mode

Tip: When an Insert tool is active, double-clicking inserts the 
element and finishes the command at the same time. Note, 
however, that double-clicking after you’ve already inserted an 
element will, in most cases, insert another element.

Tip: If you are in Selection mode, you can insert any element 
currently accessible in the catalog by simply selecting the 
element in the catalog, then moving your pointer into the 
drawing area. 

Going into Selection Mode for Editing
When you have finished using an insertion tool, either by 
double-clicking or selecting Finish from the right-click menu, 
you automatically go into Selection mode. When in Selection 
mode, you can select elements in your drawing area and edit 
them. 

You can also go into Selection mode by clicking the 
Select/Edit button on any insertion toolbar, or by 
selecting Select/Edit from the Edit menu. 
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Selecting Elements for Editing
When in Selection Mode, you can select elements for editing. 
You can select individual elements, a group of elements, or all 
elements.

When an element is selected, it is highlighted in a different 
color (usually light green). One or more handles are also 
displayed on the element.

When you are in 3D view, all elements on all locations are 
selectable. When you are in 2D plan view, only elements on 
the current building location are selectable by default.

If you are having trouble selecting the element you want, you 
may want to use the View Filter to make other elements non-
selectable. This makes selection of the element much easier. 
See Using the View Filter on page 36.

Note: Automatic floors cannot be selected in 2D. They can only 
be selected in 3D.

To select a single element:

1. Click on the element.

To select multiple elements by clicking:

1. Click the first element you want to select.

2. Hold down the Shift key and click on the rest of the 
elements you want to select. The most recent selection is 
green and prior selections are blue.

To select a group of elements by creating a selection 
window:

1. Going from either left to right, or right to left, drag a 
selection window around the elements you want to select. 
Any elements touching the selection window will be 
selected (they do not need to be totally enclosed).

To select all elements on the current location:

1. Select Edit > Select All.
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To re-select the elements you last selected:

1. Select Edit > Select Previous.

Deselecting Elements
When you select elements, you can remove individual 
elements from your selection set. You can also deselect 
everything that is currently selected.

To deselect individual elements:

1. Hold down your Shift key.

2. Click the element you want to deselect.

To deselect everything in your selection set:

1. Select Edit > Deselect All, or right-click in the drawing area 
and select Deselect All, or simply click in a blank spot 
somewhere else in the drawing area.

Accessing Edit Tools
Most elements can be moved once they are selected by simply 
clicking and dragging them. Some can also be stretched or 
rotated. You can access a full menu of edit tools by right-
clicking in the drawing area, or by selecting Edit > Modify 
Elements. 

Menus vary depending on the element selected. Typical tools 
are Properties, Move, Rotate, Duplicate, and Delete. If two 
types of elements are selected (such as a floor and a wall), only 
tools that are common to both element types are available.

Each chapter includes editing instructions specific to the 
contents of that chapter. For information about general 
editing, see Editing Elements on page 231.
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     Chapter4
TFP offers a variety of options for viewing your design in 2D 
and 3D. 

When you begin working, your design is displayed in 2D plan 
view. You can use the 2D Designer’s View tool to instantly 
view a rendered version of your 2D plan. When working in 2D 
view, you can magnify or reduce the view using the Zoom 
Realtime tool. You can also magnify a selected area using the 
Zoom Window tool. The Zoom to Fit tool magnifies your 
design so it fills the drawing area, creating the largest view 
possible. The Pan tool lets you pan the view in any direction 
by simply clicking and dragging. 

You can instantly switch to 3D view by choosing one of the 
pre-defined 3D Camera Views — 3D Perspective or 3D 
Overview — as well as create new views to suit your needs.

Selecting the Stereo Vision tool while wearing a pair of 3D 
glasses adds the perception of depth to a 3D view, making it 
seem like every detail is popping out at you.

By default a sky background is displayed, but you can select a 
different one if you want.

2D and 3D Viewing
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You can view instant elevations of your design, as well as 
create cross-sections. 

In 2D plan view, your drawing is displayed in Wireframe 
mode by default. In 3D view, it is displayed in Rendered 
mode. You can switch to other display modes such as Hidden 
Line and Patterned at any time. 

This chapter describes all basic 2D and 3D viewing features. 
For information about moving around in 3D, see page 273. For 
information about 3D Real View rendering, see page 277. For 
information about creating animations, see page 289.

Viewing the 2D Plan
When you start a drawing, the default view is a 2D plan view, 
which is a flat, overhead view. 2D plan view is ideal for 
creating a floor plan. 

To display your model in 2D plan view:

• Select View > 2D Plan View, or
• Click the 2D Plan View button on the View Control 

toolbar, or
• Right-click in the drawing area and select 2D Plan 

View
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By default, all locations are visible at the same time. However, 
any locations other than the current location are dimmed. You 
can control which elements and locations are displayed by 
using the View Filter (see Using the View Filter on page 36).

While in 2D plan view you can zoom in and out, and pan your 
drawing.

Viewing a 2D Designer’s View
By default, your design is displayed in a wireframe 2D plan 
view. You can use the 2D Designer’s View tool to quickly 
display a rendered version of the 2D plan view. In a rendered 
view, materials such as concrete, roof shingles and carpet are 
applied to the elements and terrain, creating a more realistic 
view. 

To view a 2D Designer’s View:

1. Select View > 2D Designer’s View, or click the 2D 
Designer’s View button on the View Control 
toolbar.

Note: If you want to be able to see inside the model, you can 
use the View Filter to hide elements like the roof or ceilings. 
See Using the View Filter on page 36.
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Displaying 3D Camera Views
A camera view is a 3D perspective view. In a perspective view, 
the scale of an element decreases according to its distance from 
the viewer, creating a more real-world view. 

There are two pre-defined camera views for your convenience: 
3D Perspective and 3D Overview. The 3D Perspective lets you 
view your design from a Southwest viewpoint. The 3D 
Overview looks at your design from an elevated position, 
creating an overhead view. You can change each 3D view by 
editing camera properties, as well as create new views.

To view a 3D camera view:

1. Select View > 3D Camera Views, then select the camera 
view you want to display. Or, click the 3D Camera Views 
button on the View Control toolbar and select the camera 
view to display.

You can change the view interactively by changing the 
settings or camera/target positions in the Camera 
Properties panel on the right side of the screen. 

3D Perspective View
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Note: By default, 3D views are displayed in Rendered mode. 
For information about changing the display mode, see 
Changing the Display Mode on page 31.

Creating a New 3D Camera View
You can create a new 3D camera view by placing a new 
camera in your 2D plan view. Once you’ve inserted the 
camera, you specify the camera angle and viewing field angle 
by rotating and clicking your mouse. 

To create a new 3D camera view:

1. While in 2D plan view, select View > 3D Camera 
Views > Place New Camera, or click the 3D Camera 
Views button on the View Control toolbar and 
select Place New Camera. A camera is attached to your 
cursor, ready to be inserted.

2. Click to insert the camera where you want it.

3. Move your cursor in the direction you want to view. 
Moving the cursor back and forth changes the camera 
angle.

4. Once you have the desired direction and angle in place, 
click to select a location for the target. 

Once you’ve defined the position and angle of your camera, 
the 3D view is instantly displayed.

The view will appear on your 3D Camera Views menu and 
toolbar flyouts for easy access. (By default, the first view you 
create is called Camera1). 
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Changing a 3D Camera View
You can change a 3D camera view using the Camera 
Properties panel that appears when you switch to a 3D camera 
view.

The position of the camera determines the point you are 
viewing your design from while in a 3D camera view. By 
moving your camera you can change your viewpoint. 

Click and drag
the camera or
target to move
them interactively

Enter values to
change the height
or width of the 
viewing angle
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Creating Dynamic Cutaway Views

The Dynamic Cutaway tool lets you strip away a portion of 
your 3D model so that you can see inside it. By sliding a 
selected clipping plane back and forth, you essentially create a 
moving cross-section of your design.

To create a dynamic cutaway view:

1. Go into 3D view.

2. Select View > Cutaway View, or click the Dynamic 
Cutaway button on the View Control toolbar. 

3. In the Dynamic Cutaway dialog, click on 
the clipping plane you would like to use. 
For example, if you want to strip away the 
front of your house, click on Front.

4. Click and drag the slider in the Dynamic 
Cutaway dialog to move the clipping plane 
back and forth. As you move the clipping 
plane, your design is stripped away.

5. To change the angle of the clipping plane, 
click and drag inside the dialog’s clipping 
plane graphic to rotate the clipping plane.

Home & Landscape Pro only
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6. When you have created the desired view, click OK. Note 
that the 3D view will remain a cutaway view once you 
close the Dynamic Cutaway dialog. If you want to return 
to the original view, click on None in the Dynamic 
Cutaway dialog before clicking OK.

Displaying a 3D Stereo View

Selecting the Stereo Vision tool while wearing a pair of 3D 
glasses adds the perception of depth to a 3D view, making it 
seem like every detail is popping out at you. This is a great 
way to really step into your model and get a true feel for it. 

To display a 3D stereo view:

1. Display a 3D view.

2. Select View > Stereo Vision > Stereo Vision On/Off.
3. Put on a pair of 3D glasses. You can use any pair of 

anaglyphic (red/cyan) glasses.

Tip: Stereo vision works when viewing still images as well as 
when you are navigating through a 3D scene.

Selecting a Background for 3D Views
By default, a sky image is displayed behind your model when 
you are in a 3D view. You can select a different image to 
display, including custom bitmaps that you have imported, or 
switch to a night scene. 

To select a background for the view:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

Home & Landscape Pro and Home Designer only
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2. In the Program Settings dialog, select Background in the 
left column.

3. Select either the Day Scene or Night Scene radio button. 
You would want to switch to a night scene if you are doing 
a nighttime 3D Real View™ rendering of your model. 

4. Click the Select button below the current background 
preview to access the Materials dialog.

5. In the Materials dialog, select a background from the 
materials list.

6. Click OK in the Materials dialog.

7. Click OK in the Program Settings dialog. 
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Viewing Elevations
Elevations are 2D views that show a particular side of your 
house (front, rear, left or right) as if you were looking at it face 
on. While in an elevation view you can zoom in and out as 
well as change the display type.

Sample Elevation

To view an elevation:

1. Select View > Elevation Views, or click the Elevation 
Views button on the View Control toolbar.

2. From the flyout, select the elevation you want to 
view (Front, Back, Right or Left).

Creating a Section View
You can cut through any portion of your model to create a 
section view. Section views are a great way to see the interior 
features of your model that you are not able to see from the 
outside. 

Sample Section
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To create a section view, you draw a section line through your 
model in 2D plan view, then click to define the view direction 
and depth.

To create a section view:

1. Make sure you are in 2D plan view.

2. Select View > Section Views > Create New 
Section, or click the Section Views button on the 
View Control toolbar and select Create New 
Section.

3. Select two points to draw a line that cuts through your 
model. This is the line you will be viewing from. 

4. Move your cursor in the direction you want to view. The 
more you move away from the section line, the deeper 
your view becomes. Once the bounding box is the desired 
distance and direction from the section line, click to finish.

Once you’ve defined the section mark, the resulting section 
view is instantly displayed. It is also added to the Section 
Views menu and toolbar flyouts for easy access. (By default, 
the first view you create is called Section1.)

When you are in section view, the Section Properties panel is 
displayed on the right side of the screen. You can use this 
panel to interactively adjust the section and its settings. 
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Zooming In
The Zoom In tool magnifies the entire view in increments. 
Zooming is possible in both 2D and 3D view.

To zoom in:

1. Select View > Zoom and Navigate > Zoom In, or 
click the Zoom In button on the Zoom and Navigate 
toolbar.

2. To zoom in more, select the Zoom In tool repeatedly until 
the view is sufficiently magnified.

See Also: Zooming in Realtime on page 28.

Zooming Out
The Zoom Out tool reduces the size of the current view in 
increments.

To zoom out:

1. Select View > Zoom and Navigate > Zoom Out, or 
click the Zoom Out button on the Zoom and 
Navigate toolbar.

2. To zoom out more, select the Zoom Out tool repeatedly 
until the desired zoom level is achieved.

See Also: Zooming in Realtime on page 28.

Zooming in Realtime
The Zoom Realtime tool continuously magnifies or shrinks the 
view as you click and drag with your mouse. You can zoom in 
and out in 2D plan view or any 3D view.

To zoom in and out:

1. Select View > Zoom and Navigate > Zoom Realtime, 
or click the Zoom Realtime button on the Zoom and 
Navigate toolbar.

2. To zoom in, click and drag toward the top of the screen. To 
zoom out, click and drag toward the bottom of the screen.
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3. When the view is the desired size, release your mouse 
button.

Tip: You can also zoom in and out using the scroll button on 
your mouse.

Zooming With a Scroll Wheel Mouse
If you have a mouse with a scroll wheel, you can zoom in and 
out in real time by rolling the wheel. The position of your 
mouse pointer determines the center of zoom.

To zoom with a scroll wheel mouse:

1. Position your pointer over the center of the area you want 
to zoom.

2. To zoom in, roll the wheel forward.

3. To zoom out, roll the wheel backward.

Zooming a Selected Area
Using the Zoom Window tool you can magnify a particular 
area of your design by drawing a selection window around it.

To zoom a selected area:

1. Select View > Zoom and Navigate > Zoom Window, 
or click the Zoom Window button on the Zoom and 
Navigate toolbar. Your cursor becomes a 
magnifying glass.

2. Click and drag a selection window around the area you 
want to magnify.
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Note: The Zoom Window tool is not available in 3D camera 
views.

Zooming to Fit the Drawing Area
The Zoom to Fit tool instantly extends your drawing to the 
edges of the drawing area. This ensures your entire drawing is 
visible at the most maximized view possible, and makes full 
use of the drawing area. 

To zoom the drawing to fit the drawing area:

1. Select View > Zoom and Navigate > Zoom to Fit, or 
click the Zoom to Fit button on the Zoom and 
Navigate toolbar.

Note that the terrain is considered part of your drawing. If you 
want to zoom your model to fit the drawing area, you need to 
turn the terrain off before using Zoom to Fit.

Note: The Zoom to Fit tool is not available in 3D camera views.

Panning Across a Drawing
Using the Pan tool you can move the current view of your 
design to bring a particular part of your design into view. This 
is especially useful when the area you want to view is 
currently not visible because you have zoomed in on your 
drawing.

To pan the current view:

1. Select View > Zoom and Navigate > Pan, or click the 
Pan button on the Zoom and Navigate toolbar.

2. Click in the drawing.

3. Hold your mouse button down.

4. Drag the view in the direction you want to pan.

5. Release the mouse button.

Note: The Pan tool is not available in 3D camera views.

Zooming Back to the Previous View
If you have used a zoom or pan tool, you can use the Zoom 
Previous tool to instantly return the view to its previous state.
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To zoom back to the previous view:

1. Select View > Zoom and Navigate > Zoom Previous, 
or click the Zoom Previous button on the Zoom and 
Navigate toolbar. 

Changing the Display Mode
By default, your design is displayed in Wireframe mode when 
you are in 2D plan view. When you switch to a 3D view, the 
default display mode is Rendered mode. There are five 
display modes you can choose from. 

To change the display mode:

1. Select View > Display Mode, or click the Display 
Mode button on the View Control toolbar.

2. Select the desired display mode. 

Wireframe
Each line in your design is visible, creating a “see-
through” view. It is available for both 2D and 3D views.
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Hidden Line
In a hidden line view, all lines that you would normally 
not see are removed from the view, creating an opaque 
view.

Rendered
In Rendered display mode, textures and colors are applied 
to the elements and terrain, creating a very realistic view.

Note: The Rendered display mode should not be confused 
with a 3D Real View.
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Rendered Outline
In the Rendered Outline display mode, textures and colors 
are applied to the elements and terrain, and surface edges 
are outlined in a single, dark line for increased surface 
definition.

Patterned
In Patterned display mode, patterns of lines (hatching) are 
applied to the surfaces of elements. Patterns are part of a 
material’s definition. Therefore, the materials applied to 
your elements determine what patterns you will see.
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Displaying Framing

Walls, floors, ceilings and roofs have a framing configuration 
assigned to them in their properties. You can instantly view 
your house frame using the Display Framing tool, then return 
to a regular view of your model at any time.

To display framing:

1. Select View > Framing Visibility > Display Framing.

Note: Framing cannot be selected for editing. It is available for 
viewing purposes only. 

To return to a non-framed view:

1. Select View > Framing Visibility > Display All But 
Framing.

Home & Landscape Pro and Home Designer only
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The unique View Filter lets you control which elements or 
locations are displayed at any given time. For example, you 
may want to hide your roof and ceilings to be able to see 
inside the model. It also lets you make selected elements non-
selectable, which is sometimes necessary when trying to select 
a particular element in your drawing, like a floor or ceiling.

You can filter:

• an entire location, or multiple locations
• elements on a specific location or multiple locations
• elements on the terrain 
• notation objects such as text and dimensions 

Note: Using the View Filter to control the visibility of elements 
does not delete the elements from your drawing. It just hides 
them from view.

View Filter
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Using the View Filter
You can use the View Filter at any time to control the visibility 
or selectability of elements and locations.

To access the View Filter:

1. Select View > View Filters > View Filter or click the 
View Filter button on the View Control toolbar. 

The View Filter dialog contains three tabs: Elements on 
Location, Elements on Terrain, and Notation. 

The Elements on Location tab lists all the elements in your 
model that are associated with building locations. Many 
elements in the list can be expanded to display a list of sub-
components for precise view control. You can display or hide 
elements on all locations, or specific locations.

The Elements on Terrain tab lists the terrain and any 
landscaping elements in your drawing that are associated 
with the terrain. 

The Notation tab contains text, dimensions, drafting objects, 
project trace images, and electrical wiring.

TabsElements

Display
Controls

Locations

Selection
Controls
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The icons in the Display column indicate whether or not an 
element is currently displayed. Clicking an icon toggles the 
icon to the opposite state (on or off).

Clicking Display All turns on all elements displayed on the 
current tab. Clicking Display None turns off all elements 
displayed on the current tab. On the Elements on Location tab, 
these buttons affect elements on the currently selected 
location(s).

If the Lock Framing check box is enabled, the visibility of wall, 
roof, floor and ceiling framing remains locked in its current 
state regardless of any element filtering you do.

The icons in the Selection column indicate whether or not an 
element is currently selectable. Clicking an icon toggles the 
icon to the opposite state (selectable or non-selectable).

Clicking Select All makes all elements on the current tab 
selectable. Clicking Select None turns off selectability for all 
elements displayed on the current tab. On the Elements on 
Location tab, these buttons affect elements on the currently 
selected location(s).

Note: Framing cannot be selected.

Element is turned on

Element is turned off

On the Elements on Location tab, this icon indicates 
that some of an element’s components are turned on, 
and some are turned off. 

Element is selectable

Element is not selectable

On the Elements on Location tab, this icon indicates 
that some of an element’s components are selectable, 
and some are not. 
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Filtering Elements
You can use the View Filter to display or hide selected element 
types on all or selected building locations, or to control 
whether or not they can be selected. 

To filter elements:

1. Select View > View Filter or click the View Filter 
button on the View Control toolbar. 

2. In the View Filter dialog, select the tab containing 
the element that you want to filter.

3. If you are on the Elements on Location tab, elements on all 
locations are displayed. To control the elements on a 
specific location, disable the All Locations check box, then 
select the location where you want to do the filtering. You 
can Ctrl+click to select multiple locations if you want.

4. If you want to filter specific element components, click the 
element’s plus sign (+) to display a list of components. For 
example, the Walls element can have components such as 
wall surfaces, trim, wall framing, doors and windows. 
Each component has its own display icon. 

5. To turn an element on or off, click the element’s eye icon in 
the Display column to toggle it on or off. 

6. To display or hide all elements currently shown in the 
element list, click Display All or Display None. 

7. To control an element’s selectability, click the element’s 
filter icon in the Selection column to toggle it on or off.

8. To control the selectability of all elements currently shown 
in the element list, click Select All or Select None. 

Element or component is turned on

Element or component is turned off

Element is selectable

Element is not selectable
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9. Once you’ve selected what you want to filter, click OK.

Filtering Building Locations
You can turn individual locations on or off, or control whether 
or not elements on those locations can be selected. 

To filter entire locations:

1. Select View > View Filter or click the View Filter 
button on the View Control toolbar. 

2. In the View Filter dialog, select the Elements on 
Location tab. 

3. Disable the All Locations check box. 

4. In the locations list, select the location that you want to 
filter. You can Ctrl+click to select multiple locations if you 
want.

5. Click Display All or Display None to turn all the elements 
on the selected location on or off.

6. Click Select All or Select None to make all elements on the 
selected location selectable or non-selectable.

7. If the Lock Framing check box is enabled, the visibility of 
all wall, roof, floor and ceiling framing remains locked in 
its current state. For example, if Wall Framing is locked in a 
visible state, Wall Framing will remain visible even if you 
turn off the Walls element, or click the Display None 
button.

8. Click OK.
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The first question many people ask when they sit down with a 
new piece of software is, “Where do I start”? The House 
Builder Wizard is the perfect way to start a project, because it 
builds a house for you instantly! All you need to do is specify 
how many stories you want to create, select a general house 
shape, define the building dimensions, then select the general 
style for the walls, roof, floors and foundation. In a few mouse 
clicks, you’ll have a basic structure that you can edit and add 
to. 

Once your basic model is built you can add things like interior 
walls, doors, windows, stairs and furnishings. 

If you would prefer to start your project from scratch, see the 
Walls chapter on page 49.

House Builder Wizard
Home & Landscape Pro and Home Designer only
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Using the House Builder Wizard 

The House Builder Wizard is a handy, easy-to-use tool that 
instantly builds a basic house for you based on factors that 
you specify while stepping through the Wizard. These factors 
include:

• number of floors
• wall height
• foundation type
• building shape 
• building dimensions
• garage type and size
• materials used for walls, roof, floors, etc.
The resulting house includes exterior walls, footings and 
foundation walls (or concrete slab), a roof, and a floor.

Once the house has been created in your drawing area, you 
can edit all aspects of it and add to it to suit your needs.

To use the House Builder Wizard:

1. If the House Builder Wizard is not currently running, 
select Tools > Design Wizards > House Builder. The 
following dialog appears:

Note: Running the House Builder Wizard will delete all 
existing building elements in the current project. It will 
not, however, remove the terrain or any landscaping 
elements you have inserted. 

Home & Landscape Pro and Home Designer only
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2. Click Yes in the warning dialog. The House Builder 
Wizard launches. 

3. On the House Builder screen, click Next.

4. From the Number of Floors drop box, select the number of 
floors you would like the house to have (not including the 
basement level).

5. In the Floor to Ceiling Height edit box, type the desired 
wall height for each floor level.

6. In the Foundation Type area, select the type of foundation 
you want to create. Choose from Concrete Slab, Full 
Basement, or Foundation Walls w/ Crawl Space.

7. If you selected the Full Basement or Foundation Walls w/
Crawl Space, specify the elevation of the ground floor 
relative to the ground in the Ground Floor Height above 
Terrain edit box.
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8. Click Next.

9. Select the general house shape by clicking one of the 
graphics in the House Shape pane. 

10. Once you’ve selected a house shape, make a selection in 
the Garage Position pane to specify where you want to put 
the garage. If you don’t want a garage, select the first 
option.

11. Click Next.

12. In the Building Size area, specify the desired dimensions 
for the house by entering values in the edit boxes. The edit 
box labels correspond to the labels on the image in the left 
pane. 

13. In the Garage area, select either Single, Double or Triple 
from the Type drop box. Then, using the dimensioned 
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graphic as an aid, specify the desired offset of the garage 
from the exterior wall corner. 

14. Click Next.

15. From the Building Configuration drop box, select the 
general style for your home (contemporary, country or 
traditional). The pre-set material selections for the 
elements in your house are displayed in the lower pane. 
You can select different materials if you want — just click 
the button of the element you want to change and make a 
selection from the catalog.

16. Click Next.

17. Click Finish to build the house.
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Disabling the Automatic Launch of the 
House Builder Wizard
If you do not want the House Builder Wizard to launch 
automatically every time you start the program or a new 
project, you can turn off the automatic launch. A new blank 
project will be opened instead. 

To disable the automatic launch of the House Builder 
Wizard:

1. Select Settings > Program Settings or click the Program 
Settings button on the Settings toolbar.

2. In the Program Settings dialog, uncheck the Launch 
wizard when starting new project check box.

3. Click OK.
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Drawing walls is easy — just point and click. TFP 
automatically displays dimensions as you draw, and connects 
corners for you. If the Object Snap is turned on, which by 
default it is, interior walls snap to other existing walls and 
create clean intersections with them. 

Once inserted, any wall can be moved, rotated, lengthened, 
shortened, broken, curved or deleted. This lets you create the 
exact wall layout that you want. 

The catalog contains exterior, interior and foundation wall 
types. Once your walls are drawn, you can add paint, 
wallpaper, baseboards and other types of trim to them for a 
truly customized look. Walls also have a framing 
configuration in their properties which you can customize if 
you want.

Walls
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Drawing Walls
You can draw walls by simply pointing and clicking with your 
mouse. A floor is automatically inserted when you create a 
closed wall layout. You can change the properties of the floor 
after it has been inserted if you want. 

Walls are drawn on center in TFP, so keep this mind when you 
are drawing your walls as this has an effect on the 
measurements of your layout.  

To draw walls:

1. From the location drop box on the View Control toolbar, 
select the location where you want to draw walls.

2. Select Insert > Walls, or click the Walls button on the 
Building toolbar. If you are using Landscape & Deck, 
select Insert > Building > Walls.

3. In the catalog, select the wall type you 
want to insert.

4. Select a start point for the first wall. 

5. Without dragging, move your pointer 
in the direction that you want your 
wall to run. Its length is shown as you 
draw the wall. 

Note: By default, drawing is 
constrained to 15º angles. To release 
this constraint, turn off your Angle Snap.

6. When the wall is the length you want, click to set its 
endpoint. 
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7. To add another wall to the one you have just drawn, move 
the mouse in the direction that you want the new wall to 
run. When it is the right length, click to set its endpoint. 

8. When the wall layout is complete, right-click and select 
Finish.

To move a wall:

1. Click on the wall to select it.

2. Hover your pointer over the wall’s center grip to 
display the Move cursor.

3. Click and drag the wall to where you want it, then 
release your mouse button.

To resize a wall layout by moving a wall:

1. Select the exterior wall you want to move. All attached 
walls will stretch along with it when you move it.

2. Hover your pointer over the center grip to display 
the Move cursor.

3. Click and drag the wall to resize the wall layout, 
then release your mouse button.

To resize a wall layout by editing its dimensions:

1. Select one of the exterior walls. If you want to stretch the 
layout left or right, select a vertical wall. If you want to 
stretch the layout up or down, select a horizontal wall. 
Dimensions are displayed on the wall layout.
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2. Click the dimension you want to edit. The Edit Dimension 
dialog appears.

3. Enter the new value in the Enter Distance edit box, then 
press Enter or click OK. The walls update automatically.

To remove the wall layout:

1. Click on one of the walls, then Shift+click to select the 
remaining walls.

2. Press the Delete key on your keyboard, or right-click and 
select Delete, or select Edit > Modify Elements > Delete.

Adding a Story
Once you have created walls on the ground floor, adding 
more levels to your design is easy. You can draw the layout 
just like you did to create the ground floor, or you can use the 
Duplicate to Locations tool to copy the ground floor exterior 
walls to the second floor location. 

To create a new story by drawing the walls:

1. Make sure the current location is the Second Floor 
location, or whatever location you have set up for the story 
you are creating.

Walls and other elements on the ground floor are still 
visible but dimmed so that you can trace over them or use 
them as a reference when drawing your second floor 
walls.

2. Select Insert > Walls, or click the Walls button on 
the Building toolbar. If you are using Landscape & 
Deck, select Insert > Building > Walls.

3. In the catalog, select the wall type you want to insert. 
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4. Draw the walls.

5. Right-click and select Finish.

To create a new story by duplicating walls on the ground 
floor:

1. Make sure the current location is the Ground Floor, or 
whatever location that contains the walls to copy.

2. Click one of the walls to copy, then Shift+click to select the 
remaining walls.

3. Right-click and select Duplicate to Locations, or select Edit 
> Modify Elements > Duplicate to Locations.

4. In the Duplicate to Locations dialog, select the Second 
Floor (or whatever location you are copying to).

5. Click OK. The walls are copied, and you now have a new 
story.

Note: When you copy a closed wall layout, a floor with the 
default material is automatically created on the location you 
are copying to. 

Replacing Walls
You can easily replace a wall or multiple walls with another 
type using the Replace tool. For example, you may want to 
switch from siding to brick, or vice versa.

To replace walls:

1. Click on the wall to replace. You can add more walls to 
your selection set by holding down your Shift key and 
clicking on the walls to add.
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2. Right-click and select Replace.

3. In the Catalog Access dialog, select the replacement wall 
type, then click OK. The walls are instantly replaced.

Tip: You can also use the Materials Paintbrush in 3D view to 
apply different materials and finishes to walls. See Applying 
Materials and Colors with the Materials Paintbrush on page 241.

Editing the Properties of a Wall
Walls have many properties that you can edit to suit your 
needs. These include size, top and bottom shaping, trim, and 
materials.

To edit the properties of a wall:

1. Click on the wall to select it.

2. Right-click and select Properties.

3. Edit the properties in the Walls dialog as desired. Refer to 
the online help for more information.
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A structure’s support system is an extremely important 
consideration during all phases of a design project. Support 
elements carry the load of walls, floors and other bearing 
elements in your model, and can also be a factor in the interior 
design of your home. TFP provides the tools to accurately 
place footings and columns in your design. 

You can automatically attach strip footings to selected walls. 
You can also automatically insert mono (pad) footings beneath 
columns.

Columns come in a variety of shapes and sizes, and are 
inserted with point-and-click simplicity. You can customize 
them on the fly to achieve the precise result you want.

This chapter covers the insertion and editing of strip footings, 
mono footings, and columns.

Columns & Footings
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Attaching Strip Footings to Walls

Since foundation walls bear the weight of exterior walls above 
them, you need to insert footings beneath the foundation walls 
to transfer support for the vertical load.

Strip footings are easy to insert — just click on a wall and a 
footing is automatically inserted underneath the wall. 
Footings automatically shape themselves to the bottom of 
walls, so if your wall bottoms are curved or stepped, your 
footings will be curved or stepped also.

To insert strip footings under walls:

1. Select Insert > Footings > Strip Footings Attached 
to Walls, or click the Footings button on the 
Building toolbar and select Strip Footings Attached 
to Walls.

2. In the catalog panel, select the footing 
you want to insert. Typically you 
would choose one that is wider than 
the wall you are attaching it to.

3. Click on the wall you want to attach 
the footing to. The footing is inserted 
automatically. In plan view, strip 
footings are usually shown using a 
dashed line.

4. Continue inserting footings underneath each exterior 
foundation wall.

5. Right-click and select Finish.

Inserting Columns
Typically, any bearing members in your basement require 
support. For example, if you have a 
W-type I-beam in your basement, it may be supported by steel 
posts at each end. Columns are an important consideration 
when designing your basement, especially if you intend to 
finish it.

Home & Landscape Pro and Home Designer only
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When inserting columns, you can choose from a variety of 
wood, concrete, steel, brick and gypsum columns in various 
shapes and sizes. 

To insert a column:

1. Select Insert > Columns, or click the Columns 
button on the Building toolbar. If you are using 
Landscape & Deck, select Insert > Building > 
Columns.

2. In the catalog panel, select the column 
you want to insert. 

3. Position the column where you want it, 
then click to insert it. 

4. Right-click and select Finish from the 
shortcut menu.

5. Click OK.

Attaching Mono Footings to 
Columns

Since support columns in your basement bear loads at a 
concentrated point, the load should be transferred to a proper 
footing. 

Using the Mono Footings Attached to Columns tool you can 
insert a single pad footing beneath a selected column. All you 
have to do is select the column.

To insert a footing under a column:

1. Select Insert > Footings > Mono Footings Attached 
to Columns, or click the Footings button on the 
Building toolbar and select Mono Footings 
Attached to Columns.

Home & Landscape Pro and Home Designer only
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2. In the catalog panel, select the footing 
you want to insert. Typically you 
would choose one that is wider than 
the column you are attaching it to.

3. Click on the column you want to attach 
the footing to. The footing is inserted 
automatically.

4. Right-click and select Finish.
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Once you’ve drawn walls, you can insert a variety of doors, 
windows and openings in them to create the exact design you 
want. 

Like all elements in TFP, doors, windows and openings are 
intelligent. They know that they can only be inserted in walls. 
As soon as your pointer gets close to a wall, the element snaps 
into place. All you have to do is position it where you want it 
along the wall, then click to insert it. Dimensions are displayed 
as you are positioning the element so you can get the precise 
placement you want. 

Even though doors, windows and openings automatically 
become associated with the walls they are inserted in, you can 
edit them independently if you want. 

Doors, Windows & 
Openings
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Inserting Doors
The catalog contains a wide variety of doors for you to insert, 
including hinged, bi-fold, pocket, sliding glass and garage 
doors. You can point and click to insert a door anywhere 
inside a wall, automatically center the door in the wall, or 
offset the door a specific distance from the end of the wall.

Doors are inserted at floor level. You can raise or lower a door 
after you have inserted it if you need to.

To insert a door:

1. Make sure the location you want to insert doors on is the 
current location in the building locations drop box.

2. Select Insert > Doors, or click the Doors button on 
the Building toolbar. If you are using Landscape & 
Deck, select Insert > Building > Doors.

3. In the catalog, select the door that you 
want to insert. 

4. If you want the door to be automatically 
centered on the wall, right-click and 
select Center on wall. Go to step 6.

5. If you want to offset the door a specific 
distance from the end of the wall, right-
click and select Enter insertion offset. 

Enter the offset distance in the Enter insertion offset 
dialog, then click OK.

6. Position the door in the receiving wall. If you are using an 
insertion offset, position the door close to the end you 
want to offset it from. The door will snap inside the wall. 
Dimensions are displayed that show you the distance on 
either side of the door. 
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7. With your door positioned where you want it, click to 
insert it. 

8. Right-click and select Finish.

Inserting Windows
You can insert a wide variety of windows including fixed, 
casement, double casement, hopper, awning, sliding, double-
hung, single-hung, bay, bow and louvered windows.

You can point and click to insert a window anywhere in a 
wall, automatically center the window on the wall, or offset 
the window a specific distance from the end of the wall.

Windows are inserted at the Head Height defined for the 
building location you insert the window on. You can raise or 
lower a window after you have inserted it if you need to.

Note: If you want to insert a skylight, see Inserting Skylights on 
page 88.

To insert a window:

1. Make sure the location you want to insert windows on is 
the current location in the building locations drop box.

2. Select Insert > Windows, or click the Windows 
button on the Building toolbar. If you are using 
Landscape & Deck, select Insert > Building > 
Windows.

3. In the catalog, select the window you 
want to insert. 

4. If you want the window to be 
automatically centered on the wall, right-
click and select Center on wall. Go to step 
6.

5. If you want to offset the window a 
specific distance from the end of the wall, 
right-click and select Enter insertion 
offset. 
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Enter the offset distance in the Enter insertion offset 
dialog, then click OK.

6. Position the window in the receiving wall. If you are using 
an insertion offset, position the window close to the end 
you want to offset it from. The window will snap inside 
the wall. Dimensions are displayed that show you the 
distance on either side of the window. 

7. With your window positioned where you want it, click to 
insert it. 

8. Right-click and select Finish.

Inserting Wall Openings
An opening is a cutout in a wall of a specific shape, width and 
height. Openings can be rectangular, round, arched, octagonal 
or trapezoidal.

You can point and click to insert an opening anywhere in a 
wall, automatically center the opening on the wall, or offset 
the opening a specific distance from the end of the wall.

Openings are inserted at the Head Height defined for the 
building location you insert the opening on. You can raise or 
lower an opening after you have inserted it if you need to.

To insert an opening:

1. Make sure the location you want to insert openings on is 
the current location in the building locations drop box.

2. Select Insert > Openings, or click the Openings 
button on the Building toolbar. If you are using 
Landscape & Deck, select Insert > Building > 
Openings.
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3. In the catalog, select the opening you 
want to insert. 

4. If you want the opening to be 
automatically centered on the wall, right-
click and select Center on wall. Go to step 
6.

5. If you want to offset the opening a 
specific distance from the end of the wall, 
right-click and select Enter insertion 
offset. 

Enter the offset distance in the Enter insertion offset 
dialog, then click OK.

6. Position the opening in the receiving wall. If you are using 
an insertion offset, position the opening close to the end 
you want to offset it from. The opening will snap inside 
the wall. Dimensions are displayed that show you the 
distance on either side of the opening. 

7. With your opening positioned where you want it, click to 
insert it. 

8. Right-click and select Finish.

Moving a Door, Window or Opening
You can move a door, window or opening by clicking and 
dragging it inside the wall, or by editing the dynamic 
dimensions on either side of it. 

To move the element by clicking and dragging:

1. Click on the door, window or opening to select it.

2. Click and drag the element to move it, then release your 
mouse button.
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To move the element by editing dimensions:

1. Click on the door, window or opening. Dimensions appear 
on either side of the element.

2. Click on the dimension that you want to edit.

3. In the Edit Dimension dialog, enter the new value, then 
press Enter or click OK. The door position updates 
automatically.

Flipping a Door Swing
Use the Flip Swing tool to flip only the swing of a door. The 
door will be hinged on the opposite side, but it will still open 
in the same direction, either in or out. 

To flip a door swing:

1. Click the door to select it.

2. Right-click in the drawing area and select Flip Swing, or 
select Edit > Modify Elements > Flip Swing.

Flipping a Door, Window or Opening
Use the Flip Opening tool to flip a door, window or opening 
around in the wall. In the case of a door that swings into a 
room, for example, this would make it swing out instead.

To flip a door, window or opening:

1. Click the door to select it.

2. Right-click in the drawing area and select Flip Opening, or 
select Edit > Modify Elements > Flip Opening.
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Editing the Properties of a Door, Window 
or Opening
You can customize doors, windows and openings by editing 
their properties. Properties include size, shape, composition 
and appearance.

To edit the properties of a door, window or opening:

1. Click on the element to select it.

2. Right-click and select Properties.

3. Edit the properties in the properties dialog as desired. 
Refer to the online help for more information.
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A floor is inserted automatically when you connect three or 
more walls to create a closed wall layout. When you insert 
interior walls, the floor is split as new rooms are created. If 
you want different flooring types in different rooms, you can 
use the Materials Paintbrush to quickly apply different types 
of carpet, tiles, wood flooring, vinyl flooring, linoleum, or 
concrete to individual floors.

You can disable automatic floor insertion if you want. There 
are three additional floor tools for quick and precise floor 
insertion: Floor by Room, Floor by Perimeter, and Floor by 
Picking Points. 

You can point and click to insert ceilings using one of the 
handy Ceiling tools: Ceiling by Room, Ceiling by Perimeter, 
and Ceiling by Picking Points. Any ceiling surface can easily 
be made into a tray or cathedral ceiling by simply editing the 
ceiling’s properties.

You can create openings in floors and ceilings if you need to.

Floors & Ceilings
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How Floors are Created
A floor is automatically inserted throughout your model when 
you connect three or more walls to create a closed exterior 
wall layout. 

When you draw interior walls, the floor is split into individual 
floors as new rooms are created provided the room’s walls are 
all connected. You can also manually split automatic floors 
using the Room Division tool. 

If you have deleted a floor, or would like to insert a custom 
floor, you can use the Floor by Room, Floor by Perimeter, or 
Floor by Picking Points tool to quickly create the floor you 
want.

Automatic floors cannot be selected in 2D plan view. They can 
only be selected in 3D view. The only exception are floor edges 
that have been defined using the Room Division tool. Such 
edges are marked with a dashed line in 2D view, and can be 
moved if necessary. Floors created with one of the floor tools 
are selectable in both 2D and 3D.

Floors are directly associated with the walls that contain them. 
If you stretch your wall layout, the floor stretches with it. If 
you open up your wall layout by deleting a wall, the floor will 
be deleted if it is an automatic floor. 

Inserting a Floor Throughout a Building 
Location

The Floor by Perimeter tool detects the perimeter walls on the 
current building location and inserts a floor of your choice 
throughout the entire location. This option is ideal if you have 
deleted your automatic floor and would like to create floors as 
quickly as possible throughout your model. It is also the 
perfect choice if you do not need different floors in each room.

To insert a floor throughout a building location:

1. Make sure the building location that you want to insert the 
floor on is the current location.
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2. Select Insert > Floors > Floor by Perimeter, or click 
the Floors button on the Building toolbar and select 
Floor by Perimeter.

3. In the catalog, select the floor type you 
want to insert.

4. Click anywhere inside the model. The 
floor is automatically inserted.

Note: The Floor by Perimeter tool does not 
take interior walls into account. Only one 
large floor surface is created. If you would 
prefer individual floors in each room, use 
the Floor by Room tool.

Inserting a Floor in a Room

Using the Floor by Room tool you can just click inside a room 
to automatically insert a floor of your choice in that room.

To insert a floor in a room:

1. Select Insert > Floors > Floor by Room, or click the 
Floors button on the Building toolbar and select 
Floor by Room.

2. In the catalog, select the floor type you want to insert.

3. Click inside the room you want to add the floor to. The 
floor is automatically inserted.

Cutting an Opening in an Automatic Floor

You can insert an opening of any shape and size in an 
automatic floor by defining the area to be cut out, then 
deleting it. You may need to do this to accommodate a 
staircase.

Note: If you want to insert an opening in a floor that was 
created with a Floor tool, see Cutting an Opening in a Manually 
Inserted Floor on page 70.

Home & Landscape Pro only
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To insert an opening in an automatic floor:

1. Select Insert > Room Division, or click the Room 
Division button on the Building toolbar.

2. Select points to define the outline of the opening, 
ensuring the outline forms a closed shape.

3. Right-click and select Finish. An outline is created on the 
floor surface. You can stretch, move and curve the outline 
if necessary to get the exact size and shape you want. 

4. Go into 3D view and make sure the floor is visible in the 
view.

5. Click inside the outline you drew. The outline is selected.

6. Press the Delete key on your keyboard, or right-click and 
select Delete, or select Edit > Modify Elements > Delete.

Cutting an Opening in a Manually Inserted 
Floor

If you have used the Floor by Room, Floor by Perimeter or 
Floor by Picking Points tool to create a floor, you can use the 
Cut Opening tool on the floor’s right-click menu to create an 
opening in it of any shape or size.

To create an opening in a manually inserted floor:

1. Select the floor surface.

2. Right-click and select Cut Opening.

3. Select a start point for the opening, then continue selecting 
points to define the size and shape of the opening. Note 
that you do not have to select the start point again to finish 
the outline — the last point picked is always connected to 
the start point.

4. Right-click and select Finish.

Home & Landscape Pro only
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Inserting a Ceiling Throughout a Building 
Location

The Ceiling by Perimeter tool detects the perimeter walls on 
the current building location and inserts a ceiling of your 
choice throughout the entire location. This option is ideal if 
you would like to create ceilings as quickly as possible 
throughout your model and do not have a need for different 
ceilings in each room.

To instantly add a ceiling to the entire perimeter of a 
location:

1. Make sure the location you want to insert the ceiling on is 
the current location in the building locations drop box.

2. Select Insert > Ceilings > Ceiling by Perimeter, or 
click the Ceilings button on the Building toolbar 
and select Ceiling by Perimeter.

3. In the catalog, select the ceiling type you 
want to insert. 

4. Click anywhere inside the perimeter of 
the model. The ceiling is added 
automatically.

5. Right-click and select Finish from the 
shortcut menu. 

Note: The Ceiling by Perimeter tool does not 
take interior walls into account. Only one 
large ceiling surface is created. If you would prefer individual 
ceilings in each room, use the Ceiling by Room tool.

Inserting a Ceiling in a Room

The Ceiling by Room option inserts a ceiling inside the 
perimeter of a room provided all the walls are connected. 
Adding ceilings by room allows you to have different ceiling 
types in different rooms.

Home & Landscape Pro and Home Designer only
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To insert a ceiling inside a room:

1. Make sure the location you want to insert the ceiling on is 
the current location in the building locations drop box.

2. Select Insert > Ceilings > Ceiling by Room, or click 
the Ceilings button on the Building toolbar and 
select Ceiling by Room.

3. In the catalog, select the ceiling type you want to insert. 

4. Click inside the room that you want to add the ceiling to. 
The ceiling is added automatically. (If you want, you can 
continue adding ceilings to other rooms.)

5. Right-click and select Finish from the shortcut menu. 

Creating a Cathedral Ceiling

A cathedral ceiling is a high, vaulted, open ceiling that can be 
arched or slant upward to a point. 

You can create a cathedral ceiling by changing a ceiling’s type 
to Cathedral in its properties, then defining the ceiling’s edge 
conditions. 

To create a cathedral ceiling:

1. If one is not present, create a regular flat ceiling in the 
room that you want to have a cathedral ceiling.

2. Select the ceiling. 

3. Right-click and select Properties.
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4. In the Ceilings dialog, click the Cathedral option in the 
Type area.

5. Click the Skirt Width option, then specify the distance 
from the edge of the ceiling at which you want the ceiling 
to start sloping upward. If you want the ceiling to start 
sloping directly from the outer edges, specify a value of 0. 

6. Click the Edge Shape option, then select either Straight, 
Gable or Arched to define the shape of the ceiling’s sloping 
edges.

Straight. Creates straight edges that can be angled.

Gable. Creates straight edges and leaves one side open so 
that the ceiling can fit up against a wall.

Arched. Creates curved edges.

7. If you selected the Straight edge shape, specify the desired 
angle for the sloping edges in the Slope Angle edit box.

8. If you selected the Arched edge shape, specify the 
following values:

Start Angle. The angle of the start of the curve, mea-
sured from the base of the ceiling to the center of the 
starting curve. Choose a value from 1º to 90º.

End Angle. The angle of the upper portion of the curve, 
measured from the center of the ending curve to the 
top of the ceiling’s peak.



Chapter 10  Floors & Ceilings

74 TurboFLOORPLAN

Radius. The distance from the base of the ceiling to the 
center of the curved edge.

Vert. Distance. The distance from the base of the ceiling 
to the peak.

9. Click OK.

Note: If you are creating a cathedral ceiling, you need to make 
sure your roof is steep enough to accommodate the ceiling. 
Otherwise, the ceiling will go through the roof.

Cutting Openings in Ceilings
You can create an opening in a ceiling using the Cut Opening 
tool. You create the opening by picking points to define its size 
and shape.

To insert an opening in a ceiling:

1. Select the ceiling by clicking on one of its edges.

2. Right-click and select Cut Opening, or select Edit > Modify 
Elements > Cut Opening.

3. Select a start point for the opening. 

4. Continue selecting points to define the opening. As you 
select points, the opening is created. The last point picked 
is always connected back to the start point to form a closed 
shape, so you don’t have to select the start point again.

5. Right-click and select Finish.
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If your design has more than one floor, you’ll want to insert a 
staircase. The catalog contains a variety of stair and ramp 
styles, including straight, spiral, fold-back, L-shaped and L-
winder. There are even stairs specifically for decks and 
porches. You can edit the composition and dimensions of each 
component in your staircase to create the exact look you want. 

Stairs and ramps are inserted as solid objects with point-and-
click simplicity. Just select the staircase or ramp you want to 
insert in the catalog, then click to insert it in your model. 

The catalog also contains an excellent selection of railing 
types. A railing can be just a handrail, or a balustrade with 
posts, top/bottom rails and newels. You can insert railings on 
a staircase automatically. You can choose to put it on both 
sides, the left side, the right side, or the center. You can also 
draw a horizontal railing by picking points. 

Note: For information about deck stairs and railings, see Decks 
& Patios on page 159.

Stairs, Ramps & 
Railings
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Inserting Stairs and Ramps

You can insert a staircase or ramp with a single mouse click. If 
you place the staircase near a wall, the staircase will 
automatically snap to the wall. Once you have inserted a 
staircase, you can edit its size, style and geometry.

To insert a staircase or ramp:

1. In the building locations drop box, select the location 
where you want to insert the base of the staircase.

2. Select Insert > Stairs/Ramps, or click the Stairs/
Ramps button on the Building toolbar.

3. In the catalog, select the staircase or 
ramp you want to insert. 

4. Position the staircase and click to insert 
it. 

5. Right-click and select Finish.

Tip: You may need to cut an opening in the 
floor to accommodate the staircase. See 
Cutting an Opening in an Automatic Floor on 
page 69.

Editing the Properties of Stairs and Ramps
You can edit the properties of a staircase or ramp to suit your 
needs. You can edit its dimensions, height, width, number of 
steps, layout, details, appearance, and much more. 

To edit the properties of a staircase or ramp:

1. Click on the staircase or ramp to select it.

Home & Landscape Pro and Home Designer only



Inserting Railings on Staircases and Ramps

User’s Guide 77

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

Inserting Railings on Staircases and 
Ramps

A railing can be just a handrail, or a balustrade with posts, 
top/bottom rails and newels. You can insert railings on both 
sides of a staircase or ramp automatically. Or you can very 
easily draw one on the left side, the right side, or the center. 

To insert railings on both sides of a staircase or ramp 
automatically:

1. Select Insert > Railings > Railings on Stairs 
Automatically, or click the Railings button on the 
Building toolbar and select Railings on Stairs 
Automatically.

2. In the catalog, select the railing type you 
want to insert.

3. Click on the staircase. The railings are 
inserted automatically on both sides.

4. Right-click and select Finish.
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To insert a railing on the right side of a staircase or ramp:

1. Select Insert > Railings > Railing on Stair Right, or 
click the Railings button on the Building toolbar 
and select Railing on Stair Right.

2. In the catalog, select the railing type you want to insert.

3. Select a point anywhere along the bottom of the staircase 
(or along the tread where you want the bottom of the 
railing to sit) to define the level of the railing’s bottom 
post. Your cursor will snap to the right side of the staircase 
as you start to draw the railing.

4. Select a point anywhere along the top of the staircase (or 
along the tread where you want the top of the railing to 
sit) to define the level of the railing’s top post.

5. Right-click and select Finish.

To insert a railing on the left side of a staircase or ramp:

1. Select Insert > Railings > Railing on Stair Left, or 
click the Railings button on the Building toolbar 
and select Railing on Stair Left.

2. In the catalog, select the railing type you want to insert.

3. Select a point anywhere along the bottom of the staircase 
(or along the tread where you want the bottom of the 
railing to sit) to define the level of the railing’s bottom 
post. Your cursor will snap to the left side of the staircase 
as you start to draw the railing.

4. Select a point anywhere along the top of the staircase (or 
along the tread where you want the top of the railing to 
sit) to define the level of the railing’s top post.

5. Right-click and select Finish.

To insert a railing along the center of a staircase or ramp:

1. Select Insert > Railings > Railing on Stair Center, or 
click the Railings button on the Building toolbar 
and select Railing on Stair Center.

2. In the catalog, select the railing type you want to insert.

3. Select a point anywhere along the bottom of the staircase 
(or along the tread where you want the bottom of the 
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railing to sit) to define the level of the railing’s bottom 
post. Your cursor will snap to the center of the staircase as 
you start to draw the railing.

4. Select a point anywhere along the top of the staircase (or 
along the tread where you want the top of the railing to 
sit) to define the level of the railing’s top post.

5. Right-click and select Finish.

Inserting a Horizontal Railing

You can use the Railing by Picking Points tool to create a 
horizontal railing anywhere in your model. You may, for 
example, want to create a railing around a stairwell, or insert a 
railing to separate two rooms in your house. You create the 
railing by picking the start point and end point of the railing. 
Each point you pick serves as a main post point. 

To insert a railing along a floor:

1. Make sure the building location that you want to insert the 
railing on is current.

2. Select Insert > Railings > Railings by Picking 
Points, or click the Railings button on the Building 
toolbar and select Railings by Picking Points.

3. In the catalog, select the railing type you 
want to insert. 

4. Select the start point for the railing.

5. Select an end point for the railing. You 
can continue adding sections to the 
railing if you want.

6. Right-click and select Finish.

Editing Railing Properties
When editing a railing, you can choose a different railing type 
as well as control the dimensions and settings of posts, rails 
and newels. 

Home & Landscape Pro and Home Designer only
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To edit railing properties:

1. Click on the railing to select it. If the railing has multiple 
segments, use Shift+click to select the remaining segments.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. Refer to the online help for 
more detailed information.
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To complete your structural model, you want to insert a roof 
over it. The design of your roof can be a major factor in the 
overall look and feel of your home. Inserting a roof is 
incredibly simple. Just click inside your model and the roof is 
inserted. 

Roofs are inserted by location. Therefore, if you have a two-
story house, each story may require its own roof if the levels 
are split. The great thing about roofs is that you can edit each 
roof edge individually to achieve the precise geometry, 
dimensions and appearance you want. This means that 
virtually any roof configuration is possible, including multiple 
pitch, multiple plate height roofs. And with a wide selection of 
roof styles to choose from, including hip, gable, mansard and 
arched, you can be as creative as you want.

To give your roof design that extra edge, you can add things 
like dormers, skylights and openings, all of which are 
completely customizable to suit your needs.

Roofs
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Inserting an Automatic Roof
You can use the Roof by Perimeter tool to automatically insert 
a roof over the perimeter wall layout of a selected building 
location. If you have a two-story home where the ground floor 
wall layout is different than the upper story wall layout, and 
you want each story to have its own roof, you will need to 
insert a roof on each location.

By default, the roof is inserted directly on top of the walls of 
the current building location. You can edit the support height 
as well as change the roof’s style and dimensions after it has 
been inserted.

Upper Story

Lower
Story
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To insert a roof over an entire wall layout:

1. Make sure the current location is the location containing 
the walls you want to insert the roof over.

2. Select Insert > Roofs > Roof by Perimeter, or click 
the Roofs button on the Building toolbar and select 
Roof by Perimeter. If you are using Landscape & 
Deck, select Insert > Building > Roof by Perimeter.

3. In the catalog, select the roof type 
you want to insert. Note that the 
catalog does not contain gable roofs. 
If you want to create a gable roof, 
insert a hip roof first, then convert it 
to a gable. (See Converting a Hip Roof 
to a Gable Roof on page 84.)

4. Click inside the wall perimeter. The 
roof is inserted automatically.

Selecting a Roof for Editing
You can select a roof by clicking on one of its edges. When you 
select a roof, the entire roof is selected, and a number of 
different grips and markers appear on the roof. 

General editing tools like Move and Rotate will affect the roof 
as a whole. By clicking and dragging the solid blue grips at the 
center of each edge you can move an edge to effectively stretch 
the roof. By clicking and dragging the hollow blue grips at the 
corners, you can stretch the corners of the roof to reshape it.

Move Edge
Grip

Stretch Corner
Grip

Surface Marker
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The red and green arrows are surface markers. The green 
arrow indicates the currently selected surface. Changes to 
most properties, such as the roof type, slope, and overhang 
distance, affect only the currently selected surface (which is 
marked by the green arrow). You can make additional surfaces 
current by simply clicking on the red arrows to change them to 
green. This lets you apply changes to multiple surfaces 
simultaneously. 

Converting a Hip Roof to a Gable Roof
To convert a hip roof to a gable roof, you need to select two hip 
ends, then select the gable roof type in the roof properties.

To convert a hip roof to a gable roof:

1. Click on the roof edge of one of the ends you want to 
convert. The roof is selected, and arrows appear on each 
roof surface edge. The arrow on the roof edge you selected 
should be green to indicate that it is the currently selected 
roof surface. 

2. Click on the arrow on the opposite roof edge. That arrow 
turns green also. Both hip ends are now selected.

3. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

4. In the Roofs dialog, click the Hip button 
in the Roof Shape area of the Basic page.

SelectSelect
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5. In the Roof Shape dialog, click the Gable graphic.

6. Click OK in the Roofs dialog. The roof is converted.

Editing the Properties of a Roof
When you edit the properties of a roof, the changes are 
applied to the currently selected roof surface. You can edit 
multiple roof surfaces simultaneously if you want. Each 
surface in a roof can have different settings. You can edit 
properties such as shape, slope and overhang, as well as 
framing, fascia, soffit and gable end settings.

To edit the properties of a roof:

1. Click on the edge of the surface whose properties you 
want to edit. The arrow marker on that edge should be 
green. To select additional surfaces to edit, simply click 
their arrows to change them from red to green. All 
surfaces with green arrows will receive the changes.
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2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.

Inserting Dormers
A dormer is a small structure that projects from a roof slope. 
Dormers are often used to extend the usable floor area of a 
second story that is under a moderate to steeply pitched roof. 
They can be quite effective in opening up cramped rooms 
under the roof. A typical dormer consists of a roof and three 
walls. One of the most common dormer types is the gable 
dormer, characterized by the front gable in the roof. 

You can also create a dormer without walls. In this case the 
dormer roof sits on top of the main roof. Its purpose is usually 
to add character to an otherwise plain roof or to make your 
roof design more complex. For example, you can insert a 
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dormer roof on your main roof and stretch it to create a porch 
roof or gable extension. 

Dormers are easy to insert - just point and click. You can 
control the dormer’s width, roof type, wall type, and wall 
height. 

To create a dormer:

1. In the building locations drop box, select the location 
containing the roof you want to add the dormer to.

2. Select Insert > Roofs > Dormer Roof, or click the 
Roofs button on the Building toolbar and select 
Dormer Roof. If you are using Landscape & Deck, 
select Insert > Building > Dormer Roof.

3. In the Dormers dialog, specify the desired width for the 
dormer in the Dormer Width edit box. 

4. Click the Dormer Roof button, then select the desired roof 
type for the dormer. By default, the roof will have a gable 
front, regardless of the roof type. If you do not want it to 
have a gable front, uncheck the Gable Front check box.

5. If you want your dormer to have walls, check the Include 
Walls check box. Then, click the Dormer Wall button and 
select the desired wall type from the catalog. If you do not 
want your dormer to have walls, disable the Include Walls 
check box. 

Note that dormer walls extend only to the surface of 
the main roof. As well, an opening is cut in the main 
roof surface to open the dormer up to the space below.

6. In the Support height above main roof edit box, type the 
height of the dormer’s front wall, not including the raked 
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portion between the two roof slopes. You can use this 
option even if you are not inserting walls to control the 
position of the bottom of the dormer roof. 

7. Click OK. The dormer’s wall footprint is attached to your 
cursor.

8. Position the dormer where you want it, then click to insert 
it. In most cases you would place the front dormer wall 
directly on top of the exterior wall.

9. Right-click and select Finish. 

Note: If you can’t seem to insert the dormer, it means that the 
dormer is too large for the surface you are inserting it on. You 
may want to try decreasing the wall height before inserting it.

Inserting Skylights
You can insert a skylight in your roof with point-and-click 
simplicity. The catalog contains a long list of skylights in a 
variety of sizes.

To insert a skylight:

1. Select Insert > Roofs > Skylights, or click the Roofs 
button on the Building toolbar and select Skylights. 
If you are using Landscape & Deck, select Insert > 
Building > Skylights.

2. In the catalog, select the skylight you 
want to insert. 

3. Position the skylight on the roof. 

4. Click to insert the skylight. 

5. Right-click and select Finish.
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The Kitchen Builder Wizard creates a kitchen for you in a few 
easy steps. All you have to do is select the general shape and 
layout you want. Then, just point and click to insert all of your 
cupboards and appliances in one shot. It couldn’t be easier! 
Once you’ve inserted the kitchen you can move things around 
and edit individual elements to create a look that’s customized 
to your taste and needs. 

Kitchen Builder 
Wizard

Home & Landscape Pro and Home Designer only
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Creating a Kitchen with the Kitchen 
Builder Wizard

Using the Kitchen Builder Wizard you can quickly create a 
kitchen layout that includes upper and lower cabinets, a sink, 
refrigerator and stove. There are a number of layouts and 
styles to choose from.

To create a kitchen with the Kitchen Builder Wizard:

1. Select Tools > Design Wizards > Kitchen Builder.

Home & Landscape Pro and Home Designer only
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2. Click Next.

3. Click on the general style of kitchen you want — L-Shape, 
Galley or U-Shape.

4. Click Next.

5. Select the layout that most closely resembles the layout 
you want. Remember that you can move and edit things 
later.
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6. Click Next.

7. Select a general style for your kitchen. The selection you 
make mainly determines the materials and colors used for 
the cupboards and countertops. 

8. Click Next.

9. Select the desired rotation for the kitchen layout by 
clicking the appropriate graphic. This is how it will be 
attached to your cursor prior to insertion.
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10. Click Next.

11. Click Finish. The kitchen configuration is attached to your 
cursor.

12. Position the kitchen layout in your kitchen area. It will 
automatically snap to the walls when you get close to 
them. Click to anchor the kitchen elements. Dynamic 
dimensions are displayed to show you the size of the 
layout.

13. If you want you can stretch the layout by simply moving 
your pointer in the direction you want to stretch. 

14. Once the dimensions are correct, click to finish the 
insertion.

15. Click Yes to finish the task. If you click No you can 
reposition and reinsert the kitchen.
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Cabinets are essential for storage and can also contribute to 
the overall look and feel of a room. The catalog contains a 
huge selection of cabinet types, styles and sizes, all 
customizable to suit your taste and needs. 

Cabinet types include base cabinets, corner cabinets, upper 
cabinets, islands, pantry cabinets and bathroom vanities. 

You can insert cabinets in any room in your house with just a 
click of your mouse. Cabinets are designed to snap to walls 
and other cabinets, making insertion even easier.

Cabinets
Home & Landscape Pro and Home Designer only
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Inserting Cabinets

You can insert a wide variety of cabinets in your design by 
simply pointing and clicking with your mouse. Cabinets 
automatically snap to walls and other elements when you get 
close to them provided Collision Control is turned on. 

To insert a cabinet:

1. Select Insert > Interiors > Cabinets, or click the 
Cabinets button on the Interiors toolbar.

2. In the catalog, select the cabinet you 
want to insert. 

3. Position the cabinet where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Moving a Cabinet
You can move individual or multiple 
cabinets by clicking and dragging them.

To move cabinets:

Select the cabinet you want to move. If you want to move 
multiple cabinets, use Shift+click to select the additional 
cabinets.

Hover your pointer over the cabinet’s center grip to display 
the Move cursor.

Click and drag to move the cabinet. 

When the cabinet is where you want it, release your mouse 
button.

Editing Cabinet Properties
Cabinet properties include cabinet type, size, and leaf style, as 
well as settings for the counter, shelves, toe space and 
hardware. 

Home & Landscape Pro and Home Designer only
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To edit cabinet properties:

1. Click on the cabinet to select it. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.

Inserting a Sink into a Cabinet

You can insert a kitchen or bathroom sink into a cabinet that 
you have inserted in your drawing by simply pointing and 
clicking. The sink automatically snaps itself into place at the 
center of the cabinet top. 

To insert a sink into a cabinet:

1. Select Insert > Interiors > Plumbing Fixtures, or 
click the Plumbing Fixtures button on the Interiors 
toolbar.

2. In the catalog, select the Sinks 
category, then select the sink you want 
to insert.

3. Position the fixture inside the cabinet, 
then click to insert it. 

4. Right-click and select Finish.

Home & Landscape Pro and Home Designer only
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Most home plans usually show the location of appliances in 
the kitchen and laundry room. Inserting appliances in your 
project can obviously enhance the design of a room, and can 
also help identify where electrical outlets are needed.

The catalog offers an excellent selection of kitchen and 
laundry appliances, including refrigerators, dishwashers, 
ovens, ranges, washers, dryers — even toasters. And of 
course, just like everything else, you can customize appliances 
to create the exact look you want.

Inserting appliances is easy — just point and click. Most major 
appliances are set to snap to walls and other elements when 
you get close to them.

Appliances
Home & Landscape Pro and Home Designer only
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Inserting Appliances

You can insert a wide variety of kitchen and laundry 
appliances in your design by simply pointing and clicking 
with your mouse. Appliances automatically snap to walls and 
other elements when you get close to them provided Collision 
Control is turned on. 

To insert an appliance:

1. Select Insert > Interiors > Appliances, or click the 
Appliances button on the Interiors toolbar.

2. In the catalog, select the appliance you 
want to insert. 

3. Position the appliance where you 
want it, then click to insert it. 

4. Right-click and select Finish.

Note: If you are inserting a built-in oven, 
just position it where you want it in the 
wall and it will snap into place correctly 
with only the oven door and controls 
protruding from the wall.

Moving Appliances
You can move individual appliances by clicking and dragging 
them.

To move an appliance:

1. Select the appliance you want to move. 

2. Hover your pointer over the appliance’s center grip 
to display the Move cursor.

3. Click and drag to move the appliance. 

4. When the appliance is where you want it, release your 
mouse button.

Home & Landscape Pro and Home Designer only
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Rotating Appliances
You can rotate appliances by clicking and dragging them.

To rotate an appliance:

1. Select the appliance you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the appliance.

4. When the appliance is at the desired rotation, release your 
mouse button. 

Editing Appliance Properties
You can edit the height, width and depth of most appliances. 
Some appliances have additional properties that define their 
size and style.

To edit appliance properties:

1. Click on the appliance to select it. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help. 
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Once you’ve got your cabinets and appliances in place, you 
can start with furnishing and decorating your home. The 
catalog contains so many different types of furniture, 
electronics and decorative accessories, the possibilities are 
endless. And with easy, point-and-click insertion, you can play 
around with different design ideas and quickly decorate every 
room of your home, just the way you want it. 

Note: For information about inserting exterior furnishings, see 
Exterior Furniture on page 195 and Exterior Accessories on 
page 209.

 

Interior Furniture, 
Electronics & 
Accessories

Home & Landscape Pro and Home Designer only
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Inserting Interior Furniture

The catalog contains a variety of furnishings for every room in 
your home — everything from beds to CD stands. Furnishings 
automatically snap to walls and other elements when you get 
close to them provided Collision Control is turned on. 

To insert furniture:

1. Select Insert > Interiors > Interior Furniture, or click 
the Interior Furniture button on the Interiors 
toolbar.

2. In the catalog, select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it.  

4. Right-click and select Finish.

Inserting Electronics

Electronics include televisions, computers, clocks and 
telephones. 

To insert electronics:

1. Select Insert > Interiors > Electronics, or click the 
Electronics button on the Interiors toolbar.

Home & Landscape Pro and Home Designer only
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2. In the catalog, select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it.  

4. Right-click and select Finish.

Inserting Interior Accessories

Accessories are those small, personal touches that really pull a 
room together. They are things like curtains, blinds, towel 
racks, shower curtains, medicine cabinets, plates, bowls, cups, 
mirrors and pictures.

To insert accessories:

1. Select Insert > Interiors > Interior Accessories, or 
click the Interior Accessories button on the Interiors 
toolbar.

2. In the catalog, select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Moving Furnishing Elements
You can move furniture, electronics and 
accessories by clicking and dragging them.

To move an element:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.

Home & Landscape Pro and Home Designer only
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Rotating Furnishing Elements
You can rotate furniture, electronics and accessories by 
clicking and dragging them.

To rotate an element:

1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Editing the Properties of Furnishing 
Elements
You can edit the height, width and depth of most furnishing 
elements. Some elements have additional properties that 
define their size and style.

To edit the size of furnishing elements:

1. Click on the element whose properties you want to edit. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.
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TFP offers a variety of elements that can make your home 
more functional and enjoyable, such as exercise equipment, 
satellite dishes, and garbage disposal equipment. All can be 
inserted with a simple mouse click.

Note: For information about inserting exterior equipment and 
structures, see Exterior Structures on page 199.

Interior Equipment
Home & Landscape Pro and Home Designer only
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Inserting Equipment

The catalog contains a wide range of functional equipment, 
including exercise equipment, central vac units, utility boxes 
and meters, satellite dishes, and garbage disposal units. 

To insert equipment:

1. Select Insert > Interiors > Equipment, or click the 
Equipment button on the Interiors toolbar.

2. In the catalog, select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Moving Equipment
You can move equipment by clicking and 
dragging it.

To move equipment:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.

Rotating Equipment
You can rotate equipment by clicking and dragging it while in 
rotation mode.

To rotate an element:

1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

Home & Landscape Pro and Home Designer only
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3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Editing the Properties of Equipment
You can edit the height, width and depth of most equipment 
elements. 

To edit the size of equipment elements:

1. Click on the element whose properties you want to edit. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.   
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Interior lighting can drastically change the look and 
atmosphere of a room. Light fixtures also play an important 
part when you create interior 3D Real View™ renderings. TFP 
provides an excellent selection of ceiling lights, wall lights, 
track lights, recessed lights and lamps for you to insert. You 
can change their bulbs for different lighting effects, and even 
turn them on and off!

Lights are inserted at a logical height in your plan depending 
on their type, making accurate placement easy. Also, ceiling 
lights snap to ceilings, and wall lights snap to walls. Just point 
and click!

If working in Rendered or Rendered Outline display mode, 
real-time lighting effects are displayed as you insert light 
fixtures in your design, allowing you to see how much light 
will be produced.

Note: For information about exterior lighting, see page 203.

Interior Lighting
Home & Landscape Pro and Home Designer only
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Inserting Interior Light Fixtures

You can insert a variety of light fixtures in your design. 
Interior light fixtures include ceiling lights, wall lights, track 
lighting, recessed lights, and lamps. 

Each lighting fixture has a light source in its property 
definition, such as an incandescent light bulb. Lights are 
particularly important if you plan to create a 3D Real View™ 
of your model (page 277), since the program uses light to 
calculate and create the rendered view. 

With the exception of lamps, light fixtures are set to snap to 
either ceilings or walls depending on what kind of fixture they 
are. 

To insert a light fixture:

1. Select Insert > Interiors > Interior Lighting, or click 
the Interior Lighting button on the Interiors toolbar.

2. In the catalog, select the light fixture 
you want to insert. 

3. Position the light where you want it, 
then click to insert it. 

4. Right-click and select Finish.

Tip: If you switch to Rendered or 
Rendered Outline display mode, you can 
see instant lighting effects as you position 
and insert light fixtures. 

Editing a Light Fixture’s Light Source
A light source is a type of light bulb. You can edit a light 
fixture’s light source to achieve a different lighting effect. For 
example, you can select a bulb with a softer glow, or a bulb 
with a different wattage or color.

To edit a light fixture’s light source:

1. Select the light fixture whose properties you want to edit. 

Home & Landscape Pro and Home Designer only
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2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Select the Lights tab.

4. To replace the currently selected light source with another 
type, click Edit, then select a light source from the Light 
Sources dialog. To add a light source to the fixture, click 
Add, then select a light source from the Light Sources 
dialog. 

Tip: You can double-click a light source in the library and edit 
its Scale (intensity) and Color.

5. To delete a light source from the light fixture, click Delete.
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6. To edit the position of the light source in relation to the 
light fixture, specify the X, Y and Z coordinates in the Light 
Position area. Coordinates are measured from the bottom 
center of the fixture. The small red box in the preview 
window indicates the current position of the light source. 
Changing the X value moves the light source left or right. 
Selecting Middle positions the light in the center of the 
fixture, and selecting Minimum or Maximum positions it on 
the left or right side. If you select Custom you can enter a 
specific value in the adjacent edit box which is relative to 
the center position. For example, entering -3 moves the 
light source 3” left from the center. Changing the Y value 
moves the light source forward or backward. Selecting 
Minimum brings the light source all the way forward, and 
selecting Maximum moves it to the back of the fixture. 
Changing the Z value moves the light source up or down. 
Selecting Minimum positions the light source at the bottom 
of the fixture, while selecting Maximum positions it at the 
top of the fixture.

7. Once you’ve specified the properties, click OK.

Turning a Light On or Off
By default, lights are on when you insert them. You can 
virtually turn a light off by disabling its light source.

To turn a light on or off:

1. Select the light fixture you want to turn on or off. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.
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3. Select the Lights tab.

4. To turn the light on or off, click the eye icon next to the 
light source name.

5. Click OK.

eye icon
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It is easy to insert electrical outlets, switches, thermostats and 
smoke detectors in your plan — just point and click. Electrical 
elements automatically snap to walls and are inserted at a 
logical height depending on their type, making it easy to place 
them accurately.

Once you’ve inserted electrical elements you may want to 
draw wiring in your 2D plan. All it takes is a few clicks of the 
mouse.

Electrical
Home & Landscape Pro and Home Designer only
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Inserting Outlets and Switches

You can insert electrical outlets and light switches in your plan 
with a single mouse click. The backs of these elements 
automatically snap to walls and are inserted at a logical height 
on the wall, making accurate placement effortless. You can 
move, raise and lower these elements after you have inserted 
them.

To insert outlets and switches:

1. Select Insert > Interiors > Electrical > Electrical 
Elements, or click the Electrical button on the 
Interiors toolbar and select Electrical Elements.

2. In the catalog, select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Inserting Thermostats and 
Smoke Detectors

To insert a thermostat or smoke detector, all you need to do is 
point and click. Thermostats are set to automatically snap to 
walls and are inserted at a default height of 5’. Smoke 
detectors insert a default height of 8’. You can move, raise or 
lower thermostats and smoke detectors after you have 
inserted them.

To insert thermostats and smoke detectors:

1. Select Insert > Interiors > Electrical > Electrical 
Elements, or click the Electrical button on the 
Interiors toolbar and select Electrical Elements.

Home & Landscape Pro and Home Designer only
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2. In the catalog, select the Sensors and Controls category, 
then select the element you want to insert. 

3. Position the element where you want it, then click to insert 
it. 

4. Right-click and select Finish.

Raising or Lowering an Electrical Element
You can raise or lower an outlet, switch, thermostat or smoke 
detector using the Elevate tool.

To raise or lower an electrical element:

1. Select the element whose elevation you want to edit. 

2. Right-click and select Elevate, or select Edit > Modify 
Elements > Elevate. The value shown in the Elevate dialog 
is the current elevation of the element.

3. In the Elevate dialog, specify the desired elevation of the 
bottom of the element above the floor.

4. Click OK.

Tip: You can also change an element’s elevation by changing 
the Distance above current location or terrain variable on the 
element’s Behavior property page.

Moving an Electrical Element
You can move outlets, switches, thermostats and smoke 
detectors in plan view by simply clicking and dragging them.

To move an element:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.



Chapter 19  Electrical

124 TurboFLOORPLAN

Editing the Properties of an Electrical 
Element
You can edit the height, width and depth of most electrical 
elements. Some elements have additional dimensions for 
individual components in the element.

To edit the size of an electrical element:

1. Select the element whose size you want to edit. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. 

4. Click OK.

Inserting Electrical Wiring

Once you’ve inserted electrical elements, you can use the 
Wiring tool to indicate the location of electrical wiring in your 
2D plan. By default, wiring lines have arched segments and 
use a dashed linestyle. You can stretch and reshape individual 
segments after you’ve inserted the line. You can also edit the 
linestyle. Wiring is only visible in 2D plan view.
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To add electrical wiring:

1. Select Insert > Interiors > Electrical > Wiring, or 
click the Electrical button on the Interiors toolbar 
and select Wiring.

2. Select a start point for the wiring line.

3. Select the next point for the wiring line. An arched line 
segment is created between the two points. 

4. Continue selecting points to add more segments.

5. Right-click and select Finish.

Note: You can change the line style of individual wires if you 
want. See Changing the Line Style of Wiring on page 126. You 
can also mark your wiring lines with text. See Adding Text on 
page 246.

Stretching and Reshaping Wiring 
Segments
You can stretch individual segments in a wiring line by 
clicking and dragging their grips. Stretching wiring segments 
can change their length or shape.

To stretch a wiring segment:

1. Select the segment you want to stretch. Grips are 
displayed along the segment.

2. Hover your pointer over the grip you want to grab and 
stretch.

1 2 3 4 5



Chapter 19  Electrical

126 TurboFLOORPLAN

3. Click and drag to stretch the line, then release your mouse 
button.

Changing the Line Style of Wiring
By default, electrical wiring is displayed using the Electrical 
Power Distribution line style, which is a brown, dashed line. 
You can select a different line style for selected wiring 
segments if you want. For example, you may want to select 
the Telephone line style for your telephone lines.

To change the line style of wiring:

1. Select one of the line segments you want to change. Use 
Shift+click to select the remaining segments in the line.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. In the Line Styles dialog, select the line style you want to 
use.

4. Click OK. The line style is updated in your drawing.
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TFP offers a complete selection of sinks, faucets, tubs, 
showers, toilets and bidets to help you properly equip your 
home. Plumbing fixtures are inserted with a single mouse 
click and will automatically snap to walls if Collision Control 
is turned on. You can control which edge of a fixture snaps to 
the wall, as well as edit the fixture’s size, style and elevation.

Plumbing
Home & Landscape Pro and Home Designer only
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Inserting Plumbing Fixtures

Placing plumbing fixtures in your plan is easy — just select 
what you want to insert, then point and click. With Collision 
Control turned on, fixtures will automatically snap to walls 
when you get close to them. Also, fixtures will insert at a 
logical height. For example, a toilet will insert on the floor, 
while a sink may insert 3’ off the floor. You can edit a fixture’s 
size and elevation, as well as move and rotate it.

Note: The first four sinks in the Sinks category (kitchen and 
bathroom sinks) can only be inserted into a cabinet. Also, the 
cabinet must be large enough to house the sink.

To insert plumbing fixtures:

1. Select Insert > Interiors > Plumbing Fixtures, or 
click the Plumbing Fixtures button on the Interiors 
toolbar.

2. In the catalog, select the fixture you 
want to insert.

3. Position the fixture where you want it, 
then click to insert it. 

4. Right-click and select Finish.

Moving a Plumbing Fixture
You can move plumbing fixtures by clicking and dragging 
them.

To move a plumbing fixture:

1. Select the plumbing fixture you want to move. 

2. Hover your pointer over the fixture’s center grip to 
display the Move cursor.

3. Click and drag to move the fixture. 

4. When the fixture is where you want it, release your mouse 
button.
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Rotating a Plumbing Fixture
You can rotate plumbing fixtures by clicking and dragging 
them.

To rotate a plumbing fixture:

1. Select the fixture you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the fixture.

4. When the fixture is at the desired rotation, release your 
mouse button. 

Editing the Properties of a Plumbing 
Fixture
You can edit properties such as the height, width and depth of 
a plumbing fixture.

To edit the properties of a plumbing fixture:

1. Click on the plumbing fixture whose properties you want 
to edit. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired.   

4. Click OK.
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The correct placement of heating and ventilation elements is 
an important part of the home design process. Laying out 
HVAC elements is quick and easy - just point and click. 

The catalog contains just about anything you’d need — 
furnaces, fireplaces, wood stoves, chimneys, central air units, 
water heaters, floor registers and cold air returns. Of course, 
just like anything else, you can move, rotate and edit these 
elements if you change your mind. 

HVAC
Home & Landscape Pro and Home Designer only
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Inserting Heating and Cooling Elements

You can insert heating and cooling elements with a click of 
your mouse. Heating and cooling elements include fireplaces, 
wood stoves, furnaces, water heaters, and central air units. By 
default, heating elements are inserted on the floor and will 
snap to walls if Collision Control is turned on. Central air 
units are inserted on the terrain.

To insert a heating element:

1. Select Insert > Interiors > HVAC Elements, or click 
the HVAC Elements button on the Interiors toolbar.

2. In the catalog, select the Heating or 
Cooling category, then select the 
element you want to insert.

3. Position the element where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Inserting Floor Registers and 
Cold Air Returns

Registers and air returns come in a variety of sizes, but you 
can create a different size if you need to. Wall air returns will 
insert directly onto walls. You can change the height of them 
later if you want. 

To insert a ventilation element:

1. Select Insert > Interiors > HVAC Elements, or click 
the HVAC Elements button on the Interiors toolbar.
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2. In the catalog, select the Ventilation 
category, then select the element you 
want to insert. 

3. Position the element where you want 
it, then click to insert it. 

4. Right-click and select Finish.

Inserting a Chimney

Chimneys by default are 12’ tall, but you can change this 
before or after you insert the chimney to create the correct 
height needed for your house. By default, the chimney in the 
catalog has a brick base and concrete cap. You can edit the 
appearance of the chimney to match the exterior of your home 
if you are inserting the chimney on the outside.

To insert a chimney:

1. Select Insert > Interiors > HVAC Elements, or click 
the HVAC Elements button on the Interiors toolbar.

2. In the catalog, select the Ventilation category, then 
select the Chimney element. 

3. Position the chimney where you want it, then click to 
insert it. 

4. Right-click and select Finish.

To edit the height of the chimney:

1. Select the chimney.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. On the Basic property page, change the value in the Base 
Height edit box.

4. Click OK.

Home & Landscape Pro and Home Designer only



Chapter 21  HVAC

134 TurboFLOORPLAN

To apply different materials to the chimney:

1. Display your model in 3D, and make sure the chimney is 
visible in the view.

2. Select Edit > Materials Paintbrush, or click the 
Materials Paintbrush button on any tabbed toolbar. 

3. In the catalog panel, select the material you want to 
apply. 

4. Click on the component you want to apply the material to. 
You can apply different materials to the base, cap and flue.

5. When you are finished applying materials, right-click and 
select Finish.

Moving HVAC Elements
You can move HVAC elements by clicking and dragging 
them.

To move an HVAC element:

1. Select the HVAC element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.

Editing the Properties of an HVAC Element
You can edit properties such as the dimensions of an HVAC 
element. The more complex an element is, the more variables 
it will have. A chimney, for example, has separate variables 
for the base, cap and flue, so you can create the exact look and 
size you want.

To edit the size of an HVAC element:

1. Click on the HVAC element whose properties you want to 
edit. 
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2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired.

4. Click OK.
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 Chapter22
For true realism you can recreate the topography of the lot 
your home will be built on. 

By default, a basic 160’ x 160’ grass terrain is displayed in the 
drawing area. In 2D view, only the boundary of the terrain is 
shown (you may need to zoom out to see it). Contour lines 
may also be visible depending on the terrain’s defined 
properties. In 3D view, the terrain is displayed as a solid, 3D 
object. It can be viewed in wireframe, hidden line or rendered 
form. You add hills, berms, plateaus and slopes to your terrain 
to create an incredibly realistic-looking building site. 

Terrain Modeling
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Defining the Basic Terrain
You can control the base level, size (length and width), mesh 
spacing, and contour interval of the terrain. You can also select 
a texture to use when displaying the terrain in rendered view 
(the default is grass). 

You can specify whether or not you want the terrain to cut 
around your building, and select the location that you want 
the terrain to cut around.

To define the terrain:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

2. In the Program Settings dialog, select Terrain in the 
left column.

3. To force the terrain to cut around a building, enable the 
Auto-cut terrain around building check box, then select the 
building location that you want the terrain to cut around 
from the Select Building Location to cut around drop box.

4. To change the level at which the base of the terrain sits, 
type the desired value in the Base Level edit box. This 
value is measured from 0.

5. To change the overall size of the terrain, enter the desired 
values in the Length and Width edit boxes.

6. To change the spacing between mesh lines (when viewing 
the terrain in Wireframe, Hidden Line or Patterned view), 
enter the desired value in the Mesh Spacing edit box.
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7. To change the texture used for the terrain in the Rendered 
and Rendered Outline display modes, click the Select 
button in the Material area, then make your selection in the 
Materials dialog. 

8. To display contours on your terrain, enable the Show 
Contours check box. In the Start edit box, enter the 
elevation of the first contour. In the Interval check box, 
enter the desired spacing between contours. Contours are 
visible in 2D plan view if the terrain contains hills and 
valleys.

9. Click OK. 

Creating Hills and Valleys

You can add hills to your terrain with a single mouse click. 
You can control the height of a hill as well as its peak shape. 
Generally, the diameter of the hill base is the same as the hill 
height. You can insert multiple hills together to create one 
larger hill. Also, if you insert hills next to other terrain 
elements, like plateaus or slopes, the elements will 
automatically blend together. 

Home & Landscape Pro and Landscape & Deck only



Chapter 22  Terrain Modeling

142 TurboFLOORPLAN

To create a hill or valley:

1. Select Insert > Terrain > Hills / Valleys, or click the 
Hills/Valleys button on the Terrain toolbar. 

2. In the Hills / Valleys dialog, specify the height of the hill in 
the Height edit box. Entering a negative value will create a 
valley.

3. Using the Zenith slider control, select a peak shape for the 
hill.

4. Click OK.

5. Click to insert the hill. You can insert multiple hills if you 
like.

6. Right-click and select Finish.

Creating Berms and Trenches

A berm is a mound or bank of soil without formal sides. You 
often see large berms on the sides of highways, which are used 
for noise control. On a reduced scale, a natural berm can 
provide some interesting benefits in a backyard landscape. 
These include:

Climate control. Berms act as windbreaks, channeling air flow. 
Berms can create a warmer microclimate or direct cooling 
breezes.

Privacy. A berm can be a "friendly fence" in the back yard or 
between your house and a sidewalk.
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Vertical interest. You can add variety and texture to your 
gardens with berms, change the view from your outdoor 
sitting areas, or even hide eyesores with them.

Noise control. A berm can cut down on traffic noise if you live 
on a busy street or near a schoolyard.

Berms may be shored with stone, bricks, or timbers, and 
planted with groundcovers, perennials, annuals, trees, etc.

You can control the height of a berm as well as its peak shape. 

To create a berm or trench:

1. Select Insert > Terrain > Berms/Trenches, or click 
the Berms/Trenches button on the Terrain toolbar.

2. In the Berms/Trenches dialog, specify the height of the 
berm in the Height edit box. Entering a negative value 
creates a trench.

3. Using the Zenith slider control, select a peak shape for the 
berm.

4. Click OK.
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5. Select two points to define the length of the top of the 
berm. The berm will be created downward and outward 
from this line.

6. Right-click and select Finish. 

Creating Plateaus

A plateau is a relatively large, flat area of land situated above 
the adjacent land. Adding a plateau to your terrain involves 
clicking a few points to define the shape of the plateau. You 
can control the height of the plateau as well as its peak shape. 
Note that if you insert a plateau in close proximity to other 
terrain elements, such as hills, the elements automatically 
blend together.

To create a plateau:

1. Select Insert > Terrain > Plateaus, or click the 
Plateaus button on the Terrain toolbar.

21
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2. In the Plateaus dialog, specify the height of the plateau in 
the Height edit box. Entering a negative value creates an 
excavated area.

3. Using the Zenith slider control, select a general shape for 
the plateau. The pointier the shape, the steeper the sides 
will be. 

4. Click OK.

5. In the drawing area, select points to define the outline of 
the top of the plateau. Note that the last point picked 
always closes back to the start point, so you don’t have to 
pick the start point again. The plateau will be created 
downward and outward from your outline.

6. Right-click and select Finish.

Creating Slopes

A slope is an area of land with a natural incline. It is often 
common practise to slope the land away from the sides of a 
house so that water drains away from it rather than towards it. 
When you create a slope, you select two points: the first point 
is the starting point of the slope, and the second point 
determines the length and direction of the slope. If the slope 
comes into contact with other terrain elements, like hills and 
plateaus, the elements automatically blend together.

1 2

34
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To create a slope in your terrain:

1. Select Insert > Terrain > Slopes, or click the Slopes 
button on the Terrain toolbar.

2. In the Slopes dialog, enable the Height button.

3. In the Height edit box, enter the desired height for the 
slope. Note that slopes are built from the top surface of the 
terrain (up or down). You can enter a negative value if 
needed.

4. Enable the Angle button.

5. In the Angle edit box, enter an angle (in degrees) for the 
slope. The higher the value, the steeper the slope.

6. Click OK.

7. Select a start point for the slope. The slope will incline 
from this point. Note that the sides of the slope will extend 
to the very edges of the terrain. 
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8. Move your cursor in the direction you want the slope to 
run. A stretchable arrow is displayed.

9. When the arrow is pointing in the right direction and is the 
desired length, click to insert the slope. The longer the 
arrow, the more gradual the slope will be. A shorter arrow 
will result in a steeper slope. Note that if the point you 
pick is not on the edge of the terrain, the land will level off 
at the top of the slope.

10. Right-click and select Finish.
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You may want to know where your property lines are, 
especially if you are working in a confined or unusually-
shaped area. Lot lines and setbacks can be found on a survey 
plan or surveyor’s certificate.

Using the Site Boundary tool you can draw a custom site 
boundary, which shows your stakes and property lines, and 
can show your building setbacks as well. 

Property Lines
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Defining Your Building Lot
You can use the Site Boundary tool to define your building lot. 
A site boundary is a closed line that shows the legal property 
boundary (lot lines), and is annotated with bearing text, length 
text and peg numbers. You can specify setbacks as well, which 
define your building envelope. The site boundary appears 
only in 2D wireframe view.

Tip: You can put a fence along your lot lines to show where the 
lot lines are in 3D. See Inserting a Fence on page 156.

Creating a Site Boundary
When creating a site boundary using the Reference Angle 
Method, angles are measured using compass bearings and a 
reference angle. Each angle is measured within a given 
quadrant (NE, NW, SE or SW). The angle is the acute (less 
than 90°) angle from the North or South meridian as measured 

Lot Line

Setback

Peg (stake)

Line
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to the East or West. For example, the bearing N 90d00’00” E 
can be thought of as 90º east of North.

By default, the angle is specified using the degrees/minutes/
seconds format, but you can choose to use decimal degrees if 
you prefer.

To create a site boundary using the Reference Angle Method:

1. In 2D plan view, select View > Zoom and Navigate > 
Zoom to Fit, or click the Zoom to Fit button on the 
View Control toolbar. This will bring the entire 
terrain into view so you can insert the boundary easily and 
precisely.

2. Select Insert > Terrain > Site Boundary, or click the 
Site Boundary button on the Terrain toolbar.

3. Select a point for the first peg (stake). If it is turned 
on, the Commander becomes instantly active, displaying 
options for defining the length and direction of line 
segments.

4. Move your mouse in the general direction you want the 
first site boundary line to run. This determines the 
quadrant you are working in, and the compass points 
used in the bearing. Note that you can also select a 
quadrant (NE, NW, SE or SW) from the drop box in the 
Commander if you prefer — just remember to Tab over to 
the Distance edit box when you’re done.  

5. Type a length for the first boundary line. The value 
appears in the Commander’s Distance edit box.

6. To specify the direction of the line, either move your 
mouse in the desired direction (watching the resulting 
angle in the Commander’s Direction edit box), or press the 
Tab key to move to the Direction edit box, then enter the 
desired angle and press ENTER. Remember that the angle 
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is measured from the North or South meridian, and 
should be between 0 and 90 degrees. 

7. Continue defining the remaining segments. When you 
have defined all but the last segment, right-click and select 
Finish. A closing line segment will be created 
automatically between the first and last peg, forming a 
closed site boundary.

Note: Bearings coincide with the angle of the north arrow 
specified in your global settings.

Defining Building Setbacks
By default, setback lines are not included in your site 
boundary, as all setback distances are set to 0. You can specify 
a setback distance for each individual site boundary edge.

To define setback distances:

1. Click on the property line you want to specify a setback 
distance for. Note that setback distances are defined per 
site boundary edge, one at a time.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. In the Site Boundary Edge dialog, edit the value in the 
Setback edit box.

4. Click OK.
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Fences can add beauty, privacy and security to your property. 
Just point and click to fence off a yard in seconds! 

The catalog contains an assortment of fences in a variety of 
materials, including concrete, stone and wood. You can even 
add a white picket fence for that classic look.

Once you’ve drawn your fence you can easily pop a gate into 
it. You can choose a style that matches your fence, or choose 
an entirely different style to create a stylish accent.

Fences & Gates
Home & Landscape Pro and Landscape & Deck only
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Inserting a Fence

To insert a fence, you draw it just like a wall by selecting a 
start point and end point. This allows you to create a fence of 
any length. You can continue selecting points in other 
directions to add on to the fencing (if you want to fence 
around your yard, for example).

Tip: If you have inserted a site boundary in your plan, you can 
draw your fence on top of the lot lines for ease. The fence then 
acts as a visual indicator of your property extents in 3D. 

To insert a fence:

1. Select Insert > Landscape > Fences/Gates > 
Fences, or click the Fences/Gates button on the 
Landscape toolbar and select Fences.

2. In the catalog, select the fence type 
you want to insert. 

3. Select a start point for the fence.

4. Move your cursor in the direction you 
want the fence to run. The fence 
stretches as you move your cursor.

5. Select an end point for the fence. If 
you want you can continue adding 
sections to the fence in any direction 
by simply selecting points.

6. Right-click and select Finish. 

Editing the Properties of a Fence
You can change the height of a fence, specify whether or not 
you want the fence to hug the terrain, edit the size and 
position of fence posts, and edit the dimensions of the rails 
and boards. 

To edit the properties of a fence:

1. Click on the fence to select it.
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2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.

Inserting a Gate

The catalog contains a variety of gate types, including wood, 
picket and ranch style gates. Gates just pop themselves right 
into fences. Naturally, if you are inserting a gate in a fence, 
you want to choose a gate size that corresponds to the fence 
size. For example, if your fence is a 6’ wood privacy fence, you 
would likely choose the 6’ wood privacy gate. Gates are 
shown slightly open so you can identify them easily in 2D and 
3D views. 

To insert a gate:

1. Select Insert > Landscape > Fences/Gates > Gates, 
or click the Fences/Gates button on the Landscape 
toolbar and select Gates.
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2. In the catalog, select the gate you want 
to insert. 

3. Position the gate where you want it, 
then click to insert it. The gate will 
automatically pop itself into the fence 
when you position it in the fence.

4. Right-click and select Finish.

Editing the Properties of a 
Gate
You can change the height and width of a gate as well as the 
dimensions of the rails and boards. You can also control how 
far the gate is open in 2D and 3D views.

To edit the properties of a gate:

1. Click on the gate to select it.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.
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A great way to add more living space to your home without 
building an addition is to build a deck or patio. The Deck 
Builder Wizard makes building a deck so simple — just select 
the material and shape you want, and the deck is built for you 
automatically. Or if you prefer, you can create the precise size 
and shape you want using the Deck tool. Creating a patio 
involves clicking a few points to define the outline of the slab 
using the Pads tool.

Decks & Patios
Home & Landscape Pro and Landscape & Deck only
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Using the Deck Builder Wizard

The Deck Builder Wizard takes all the work out of building a 
deck because it does it all for you! Just select the decking 
material and deck shape, enter the dimensions you want, then 
point and click to insert the deck. 

After inserting a deck you can move, stretch, rotate, raise or 
lower it if needed, as well as edit its properties, which include 
settings for posts, railings and skirting.

To build a deck using the Deck Builder Wizard:

1. In the Building Locations drop box, select the location you 
want to associate the deck with. The height of a deck is 
determined by the Height above current location variable 
in the deck properties. You can edit this value after the 
deck has been inserted if necessary.

2. Select Tools > Design Wizards > Deck Builder.
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3. In the Deck Wizard dialog, click Next.

4. Select the decking material you would like to use.

5. Click Next.

6. In the Shape area, click on the shape that most closely 
resembles the shape you want to create. Remember that 
you can edit the shape after the deck has been inserted.

7. In the Size area, specify the desired dimensions for the 
deck. 
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8. Click Next.

9. In the Deck Rotation area, select the desired rotation for 
your deck. This is how the deck will be oriented when it is 
attached to your cursor. 

10. In the Decking Direction area, select the direction you want 
the deck boards to run. 

11. Click Next.

12. Click Finish. The Deck Wizard closes, and the deck is 
attached to your cursor, ready to be inserted.

13. Position the deck where you want it, then click to insert it.
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Building a Deck with the Deck Tool

You can use the Deck tool to build a deck of virtually any 
shape and size. 

Once you’ve inserted a deck you can move, stretch, rotate, 
raise or lower it if needed, as well as edit its properties, which 
include settings for posts, railings and skirting.

To create a deck with the Deck tool:

1. In the Building Locations drop box, select the location you 
want to associate the deck with. The height of a deck is 
determined by the Height above current location variable 
in the deck properties. You can edit this value after the 
deck has been inserted if necessary.

2. Select Insert > Landscape > Decks > Decks, or click 
the Decks button on the Landscape toolbar and 
select Decks.

3. In the catalog, select the decking 
material you want to use.

4. Select a start point for the deck outline. 
Continue selecting points until the 
outline is defined. (You do not have to 
select the start point again because the 
last point you pick is always closed 
back to the start point.)

5. Right-click and select Finish.
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Editing Deck Properties
You can edit properties for a deck’s height, posts, beams, 
footings, decking, railings, skirting, and more.

To edit deck properties:

1. Click on the deck to select it.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.

Adding Stairs to a Deck

You can add a staircase to your deck with a single mouse click. 
Stairs automatically snap to your deck for easy insertion, and 
the railings on the deck are automatically removed to allow 
for the stair opening. By default, stairs extend from the deck 
platform to down to the terrain, so there’s absolutely nothing 
you need to calculate. Also, deck stairs have a railing on both 
sides by default, but you can remove one or both of them if 
you want after the stairs have been inserted.

You can choose either pressure treated or cedar stairs, and edit 
the stair dimensions to get the exact result you want. 
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To add stairs to a deck:

1. Select Insert > Landscape > Decks > Deck Stairs, or 
click the Decks button on the Landscape toolbar 
and select Deck Stairs.

2. In the catalog, select the type of stairs 
you would like to insert. 

3. Move your pointer close to the deck 
edge. Position the stairs where you 
want them, then click to insert them. 

4. Right-click and select Finish. 

Editing the Properties of 
Deck Stairs
You can edit properties such as the overall height and width of 
deck stairs, the width of the steps, and the riser height.

To edit the properties of deck stairs:

1. Click on the staircase to select it.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired. For more detailed 
information, see the online help.
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Creating a Patio

You can use the Pads tool to insert a concrete or brick patio 
directly on your terrain. By drawing the outline of the patio, 
you control its precise size and shape. 

By default, patio slabs hug the terrain they are inserted on. If 
the terrain is not flat where you are inserting the patio, you 
may want to turn off the slab’s Hug Terrain option. This 
makes the slab flat and positions it at the Terrain Base Level 
specified in your Terrain Settings.

To create a patio:

1. Select Insert > Terrain > Pads, or click the Pads 
button on the Terrain toolbar.

2. In the catalog, select the type of slab 
you want to insert.

3. Select a start point for the slab. 

4. Continue selecting points to define 
the outline of the slab. 

Note that the last point picked 
always closes back to the start 
point, so you don’t have to pick the 
start point again.

5. Right-click and select Finish from the shortcut menu.
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The Shed Builder Wizard steps you through the creation of a 
custom shed, then builds it for you instantly! 

Simply select the shed style you want, then enter the 
dimensions you would like it to have. Next, define the desired 
door/window combination, and then select custom materials 
for the roof, walls, floor, door and window. Finally, just click 
to insert your new shed where you want it!

Once inserted, you can further edit the shed’s individual 
components if needed.

Note: If you would like to insert a pre-made shed from the 
catalog, use the Exterior Structures tool. You can find sheds in 
the Storage and Enclosures category of the catalog.

 

Shed Builder Wizard
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Building a Shed with the Shed Builder 
Wizard

The Shed Builder Wizard will create a custom shed for you in 
a few easy steps. All you need to do is select a shed style, enter 
the desired dimensions, and specify the door and window 
placement. You can even select what materials you would like 
to use for the roof, walls, floor, door and window.

Once you’ve inserted the shed in your plan, you can further 
edit its individual components to achieve the exact size and 
appearance you want.

To build a shed:

1. Select Tools > Design Wizards > Shed Builder.

2. On the Welcome screen, click Next.

3. On the next screen, click on the graphic that most closely 
resembles the style of shed you would like to build.

4. Enter the desired dimensions for the shed in the Length 
and Width edit boxes.
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5. Click Next.

6. On the Door and Window Configuration screen, click on 
the door/window combination that you would like for the 
front of the shed. If you would like a window on the left 
side of the shed, enable the Include Window on left side 
check box. If you would like a window on the right side of 
the shed, enable the Include Window on right side check 
box.

7. Click Next.

8. On the Shed Elements screen you can select a custom 
materials to use for the shed’s roof, walls, floor, door and 
window. Just click the desired elements button, then make 
a selection from the catalog.
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9. Click Next.

10. On the final screen, click Finish. The shed is attached to 
your cursor, ready to be inserted.

11. Position the shed where you want it, then click to insert it.

Editing a Shed
If you have created and inserted a shed with the Shed Builder 
Wizard, you can edit its roof, walls, floor, door and window 
individually. Just click on the element you want to edit, then 
edit it as you would if it were part of a house. For example, 
you can stretch the walls to make the shed bigger or smaller, 
or select a different window size.
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A well-built retaining wall system can preserve the natural 
shape of your land, reinforce hills and slopes, and protect your 
home from possible landslides or soil erosion. Retaining walls 
can also be an attractive addition to a garden or the overall 
landscaping around your home. 

Drawing retaining walls is easy — just point and click. 

Retaining Walls
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Drawing Retaining Walls

Just like regular walls, retaining walls are a snap to draw — 
just point and click.

To draw a retaining wall:

1. Select Insert > Terrain > Retaining Walls, or click the 
Retaining Walls button on the Terrain toolbar.

2. In the catalog, select the wall type 
you want to insert. 

3. Select a start point for the wall. 

4. Move your cursor in the direction 
you want your wall to run. Its 
length is shown as you draw the 
wall. 

Note: By default, drawing is 
constrained to 15º angles. To 
release this constraint, turn off your Angle Snap.

5. When the wall is the length you want, click to set its 
endpoint. 

6. Continue selecting points to add on to the wall if you 
want.

7. When you are done, right-click and select Finish.

Lengthening and Shortening Retaining 
Walls
You can lengthen or shorten an individual wall by clicking 
and dragging one of the wall’s ends.

To lengthen or shorten a retaining wall:

1. Select the wall. A grip is displayed at each wall end.

2. Hover your pointer over the wall end you want to 
stretch. The Lengthen cursor is displayed.

3. Click and drag the wall end until it has reached the 
desired length, then release your mouse button.
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Curving a Retaining Wall
You can curve a retaining wall using the Curve tool. Once the 
tool is active, you can click and drag the wall to curve it, or 
select a point to curve to.

To curve a retaining wall by clicking and dragging:

1. Click the wall to select it. 

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Click and drag the wall to the desired curve. 

4. Release your mouse button.

To curve a retaining wall to a selected point:

1. Click the wall to select it. 

2. Right-click in and select Curve, or select Edit > Modify 
Elements > Curve.

3. Select the point you want to curve to. The wall 
automatically curves to the point.

4. Click to finish.

Editing the Properties of a Retaining Wall
Walls have many properties that you can edit to suit your 
needs. These include size, top and bottom shaping, materials, 
and more.

To edit the properties of a retaining wall:

1. Click on the wall to select it.

2. Right-click and select Properties.
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3. Edit the properties in the Walls dialog as desired. Refer to 
the online help for more information.
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Sidewalks, pathways and driveways add to the overall 
aesthetics of your landscape and provide access to different 
areas of your property. Drawing them is easy — just select a 
start point, then point and click in the direction you want the 
pathway to run. Continue picking points to add segments if 
you want.

The catalog includes an excellent selection of pathway 
materials including wood, sand, gravel, concrete, brick and 
asphalt. You can even create a forest path! A number of 
different widths are available, but you can create a custom 
width if you want.

Sidewalks, Pathways 
& Driveways
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Drawing Sidewalks, Pathways and 
Driveways

The catalog contains a wide variety of path types, including 
boardwalks, sand paths, gravel paths, brick paths, and 
driveways. The width and thickness of a path is determined 
by the path’s properties in the catalog. You control the length 
and direction of the path as you draw it. Dimensions are 
displayed as you draw each segment. 

By default, all paths hug the terrain they are inserted on. If the 
terrain is not flat where you are inserting the path, you may 
want to turn off the path’s Hug Terrain option. This makes the 
path flat and positions it at the Terrain Base Level specified in 
your Terrain Settings.

To create a path:

1. Select Insert > Terrain > Paths, or click the Paths 
button on the Terrain toolbar.

2. In the catalog, select the path type 
you want to insert. 

3. Select a start point for your path. 
Note that your insertion point is on 
the center line of the path. 

4. Move your cursor in the direction 
you want the path to run, then 
select an endpoint for the path. 
You can continue selecting points 
in any direction to add more 
sections to the path if you want. 

Tip: To create a smooth curve in the path, click several 
points with a short distance between each point.
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5. Double-click to finish, or right-click and select Finish.

Curving a Path Element
You can curve a path segment using the Curve tool. Once the 
tool is active, you can click and drag the path to curve it, or 
select a point to curve to.

To curve a path by clicking and dragging:

1. Click on the path to select it. If the path has multiple 
segments, make sure you click on the specific segment you 
want to curve. 

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Click and drag the path to the desired curve.

4. Release your mouse button.

To curve a path to a selected point:

1. Click on the path to select it. If the path has multiple 
segments, make sure you click on the specific segment you 
want to curve. 

Start Point Next Point

Next 

Double-click
after last point

Point



Chapter 28  Sidewalks, Pathways & Driveways

178 TurboFLOORPLAN

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Select the point you want to curve to. The path 
automatically curves to the point.

4. Click to finish.

Editing the Thickness or Width of a Path 
Element
You can edit the thickness of your path material or the path’s 
overall width.

To edit the thickness or width of a path:

1. Select the path. If the path has multiple segments, you do 
not have to select them all. Property changes affect the 
whole path.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. To edit the thickness of the path, enter a value in the 
Thickness edit box.

4. To edit the width of the path, enter a value in the Width 
edit box.

5. Click OK.
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In the real world, one of the first things you need to do to 
create a garden is to dig out a bed for your plants. You can 
create a garden bed instantly by simply picking points to 
define the outline of the bed. The bed is then automatically 
filled with a material of your choice, such as soil or bark. 

The versatile Fills tool is handy for more than just garden 
beds. Choose the Water fill to create a pond, or the Sand fill to 
create a horseshoe pit. The possibilities are endless.

Garden Beds, Ponds 
& Other Filled Areas
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Creating Filled Areas

You can use the Fills tool to define an area filled with soil, 
sand, gravel, concrete, bark or water. You define the area by 
picking points to draw its outline. Filled areas automatically 
hug the terrain they are inserted on.

To create a filled area:

1. Select Insert > Landscape > Fills, or click the Fills 
button on the Landscape toolbar.

2. In the catalog, select your fill 
material. 

3. Select a start point for your filled 
area. 

4. Continue selecting points to define 
the boundary of the filled area. 
Note that the last point picked 
always closes back to the start 
point, so you don’t have to pick the 
start point again.

5. Right-click and select Finish.

Tip: If you want to create a raised garden you may want to 
insert a raised garden box from the catalog. See Inserting 
Exterior Structures on page 200. 

Note: You cannot insert a fill on top of another fill.
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Resizing a Filled Area
You can resize a filled area by stretching one of its edges.

To resize a filled area by stretching it:

1. Click on the filled area to select it.

2. Click on the edge you want to stretch. 

3. Hover your pointer over the solid blue grip to 
display the Move cursor. Alternatively you can 
select the Move Edge tool on the right-click menu.

4. Click and drag to stretch the fill.

5. Release your mouse button.

Reshaping a Filled Area
You can change the shape of a filled area by stretching its 
corners. You can do this by clicking and dragging its grips. 

To reshape a filled area by stretching:

1. Click on the filled area to select it. A grip is displayed at 
each corner.

2. Click and drag a corner grip to stretch the filled area.
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3. Release your mouse button.

Curving a Filled Area
You can curve the edge of a fill using the Curve tool. Once the 
tool is active, you can click and drag the edge to curve it, or 
select a point to curve to.

To curve a fill edge by clicking and dragging:

1. Click on the fill edge that you want to curve. 

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Click and drag the fill edge to the desired curve.

4. Release your mouse button.

To curve a fill edge to a selected point:

1. Click on the fill edge you want to curve. 

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Select the point you want to curve to. The fill edge 
automatically curves to the point.

4. Click to finish.
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Edging can be an attractive accent around gardens, ponds, 
sidewalks, driveways, and other areas. It can also help retain 
fill materials and keep weeds out of your garden. You can 
choose from PVC lawn edging, wood posts, or rails.

Drawing edging is easy — just point and click to define the 
start and end point of the edging, then keep clicking to add 
more segments.

Edging
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Inserting Edging

Use the Edging tool to add PVC lawn edging, wood posts, or 
wood, brick or concrete rails to your landscape design. The 
width and height of the edging is determined in the material’s 
properties. You insert edging by simply picking points to 
define the end points and direction of the edging.

To insert edging:

1. Select Insert > Landscape > Edging, or click the 
Edging button on the Landscape toolbar.

2. In the catalog, select your edging 
material. 

3. Select a start point for the edging. 

4. Move your cursor in the direction 
you want the edging to run, then 
select an endpoint for the edging. 
You can continue selecting points 
in any direction to add more 
sections to the edging if you want. 

5. Right-click and select Finish.

Tip: You can also insert decorative borders around a garden. 
See Inserting Exterior Accessories on page 210.
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Changing the Length of Edging
You can lengthen or shorten edging by clicking and dragging 
its end points.

To change the length of edging:

1. Select the edging you want to lengthen or shorten. Grips 
are displayed at the center and ends of the edging.

2. Hover your pointer over the end you want to stretch. 

3. Click and drag to lengthen or shorten the edging, then 
release your mouse button.

Curving Edging
You can curve a section of edging using the Curve tool. Once 
the tool is active, you can click and drag the edging to curve it, 
or select a point to curve to.

To curve edging by clicking and dragging:

1. Click the section of edging that you want to curve. 

2. Right-click and select Curve, or select Edit > Modify 
Elements > Curve.

3. Click and drag the edging to the desired curve. 

4. Release your mouse button.

To curve edging to a selected point:

1. Click the section of edging that you want to curve. 

2. Right-click in and select Curve, or select Edit > Modify 
Elements > Curve.

3. Select the point you want to curve to. The edging 
automatically curves to the point.



Chapter 30  Edging

188 TurboFLOORPLAN

4. Click to finish.
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Nothing brings your landscape to life like trees, shrubs, plants 
and flowers. With over 7500 plants to choose from, you can 
create the landscape of your dreams. 

Inserting plants involves nothing more than a single mouse 
click, and once inserted, they can be dragged and dropped 
anywhere you like. You can even make them grow!

If you need to learn more about a particular species of plant, 
you can view the plant’s light, water, temperature and soil 
requirements in its properties. For even more detailed 
information you can browse through the comprehensive Plant 
Encyclopedia.

Trees, Shrubs & 
Plants
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Inserting Plants

Plants are inserted with a simple mouse click. Once inserted, 
they can be dragged and dropped anywhere in the drawing. 

To insert a plant:

1. Select Insert > Landscape > Plants, or click the 
Plants button on the Landscape toolbar.

2. In the catalog, select the plant you 
want to insert. If you want to view 
the plant’s size or requirements 
before inserting it, right-click in the 
catalog and select Properties.

3. Position the plant where you want 
it, then click to insert it.

4. Right-click and select Finish. 

Note: Although the catalog contains a 
wide variety of plants for you to insert, 
it does not contain all the plants listed in the Plant 
Encyclopedia. You can, however, insert plants directly from 
the Encyclopedia. You can also add plants from the 
Encyclopedia to the current catalog. 

Moving a Plant
You can move a plant easily by just clicking and dragging it.

To move a plant:

1. Select the plant you want to move. 

2. Hover your pointer over the plant’s center grip to 
display the Move cursor.

3. Click and drag to move the plant. 

4. When the plant is where you want it, release your mouse 
button.
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Changing the Age of a Plant

The age of a plant determines its size at planting time. You can 
increase or decrease the age of a plant by making a change on 
the plant’s Plant Info property page.

To change the age of a plant:

1. Click on the plant whose planting age you want to change.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. In the Plants dialog, select the Plant Info tab.

4. Move the Planting Age slider left or right until the desired 
planting age is displayed. Planting age is measured in 
years.

5. Click OK. 

Seeing Plant Growth Over Time

Once you have inserted plants in your landscape plan, you 
can see how they will look any specified number of years 
down the road using the Plant Growth Over Time feature. 

To see plant growth over time:

1. Select Tools > Gardening > Plant Growth Over Time.

2. Enter the number of years to add to your landscape.

3. Click OK.
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Applying Seasonal Changes to Plants

The Plant Seasonal Change feature updates the appearance of 
the plants in your drawing to reflect a particular season. 
Generally the change applies to flowering plants and trees that 
have a certain bloom time.

You specify the season by adjusting the time of year on the 
Global Settings page of the Program Settings dialog.

To apply seasonal changes to your plants:

1. Select Tools > Gardening > Plant Seasonal Change.

2. In the Program Settings dialog, change the date. Select a 
month by clicking the arrows on the month bar at the top 
of the calendar. Select a day by clicking a number on the 
calendar. 

3. Click OK. The plants in your drawing are updated 
according to the time of year you specified.

Note: Keep in mind that seasonal changes may have different 
results depending on the plant’s properties in the 
Encyclopedia. Things to consider are the climate of the region 
the plant is in, and the plant’s world origin. 

Using the Plant Encyclopedia

The Plant Encyclopedia contains comprehensive information 
on over 7500 different varieties of plants. The Encyclopedia 
has many uses related to the selection and care of plants. You 
can view information about any plant, select plants based on 
certain criteria, research potential diseases, and learn how to 
care for your plants.

To access the Plant Encyclopedia, select Tools > Gardening > 
Plant Encyclopedia.
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You can also access the Plant Encyclopedia by clicking the 
Encyclopedia button on a plant’s Encyclopedia property page.
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The catalog includes a great selection of exterior furniture so 
you can relax, eat and entertain outdoors. Furniture types 
include patio tables, patio chairs, picnic tables, loungers and 
benches.

All it takes is one click to insert any piece of furniture. 

Note: For information about interior furniture, see page 105.

Exterior Furniture
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Inserting Exterior Furniture

Inserting exterior furniture is easy — just point and click. 
When inserting exterior furniture, you have the option of 
inserting it on the terrain, or on a building location. 

To insert exterior furniture:

1. Select Insert > Landscape > Exterior Furniture, or 
click the Exterior Furniture button on the 
Landscape toolbar. Then, select either Exterior 
Furniture on Terrain or Exterior Furniture on Location, 
depending on where you want to insert the element. The 
Exterior Furniture on Location option lets you insert the 
element on a deck, or on anything that is associated with a 
building location.

2. In the catalog, select the element 
you want to insert.

3. Position the element where you 
want it, then click to insert it.

4. Right-click and select Finish.

Moving Exterior Furniture
You can move exterior furniture in 
plan view by simply clicking and 
dragging it.

To move exterior furniture:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.
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Rotating Exterior Furniture
You can rotate exterior furniture by clicking and dragging it.

To rotate exterior furniture:

1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Editing the Properties of Exterior Furniture
You can edit properties such as the height, width and depth of 
exterior furniture.

To edit the properties of exterior furniture:

1. Select the element.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the values on the Basic page. The Uniform Scale 
option ensures that the element scales uniformly when 
you change one of its dimensions.

4. Edit the properties as desired.

5. Click OK.
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TFP offers an excellent selection of exterior structures to make 
your outdoor living space more functional. These include play 
gyms, swings, sandboxes, trampolines, tennis and volleyball 
courts, detached garages, sheds, gazebos, arbors, garden 
boxes, greenhouses, pools and hot tubs. 

If you are creating a landscape plan and do not have a model 
in your project, you can insert a house template to create your 
landscape plan around. 

All structures are inserted with a single mouse click and can 
be easily moved, rotated and edited.

Exterior Structures
Home & Landscape Pro and Landscape & Deck only
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Inserting Exterior Structures

Inserting exterior structures is easy — just point and click.

To insert an exterior structure:

1. Select Insert > Landscape > Exterior Structures, or 
click the Exterior Structures button on the 
Landscape toolbar.

2. In the catalog, select the structure 
you want to insert.

3. Position the structure where you 
want it, then click to insert it.

4. Right-click and select Finish.

A Note About House 
Templates
A house template is basically the exterior shell of a finished 
home. If you are creating a landscape plan and your project 
does not contain a model, you can insert a house template to 
serve as the focal point of your plan. 

Although a house template looks like a real house, it can’t be 
edited like a real model can. It is considered a single-click 
element, so clicking on any part of the template selects the 
entire house. 

It is important to note that when you select the house 
template, the invisible bounding box is always square or 
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rectangular, and does not necessarily follow the shape of the 
house outline. 

This can interfere with the selection of other elements near the 
house. If you have inserted elements around the house, such 
as plants, and want to select them, you may want to use the 
View Filter to make the house template non-selectable for ease 
of editing your landscape plan. 

Another thing to note is that the house template’s exterior 
walls are not visible in 2D. You only see the roof line. If you 
want to insert things like fills up against the exterior walls of 
the house, you will need to either draw them in 3D, or draw 
them in 2D and then move them into place in 3D.

Moving Exterior Structures
You can move exterior structures in plan view by simply 
clicking and dragging them.

To move an exterior structure:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.

Bounding
Box
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Rotating Exterior Structures
You can rotate exterior structures by clicking and dragging 
them.

To rotate an exterior structure:

1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Editing the Properties of an Exterior 
Structure
You can edit properties such as the height, width and depth of 
most exterior structures.

To edit the properties of an exterior structure:

1. Select the structure.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired.

4. Click OK.
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Outdoor lighting can beautify any landscape and offers 
security and visibility at night. Lighting can also play an 
important part when you create exterior 3D Real View™ 
renderings. TFP offers light posts, wall lights and ground 
lighting to enhance the exterior design of your home. You can 
change their bulbs for different lighting effects, and even turn 
them on and off!

Exterior lighting can be inserted on the terrain, or on a 
building location. Just point and click!

Note: For information about interior lighting, see page 115.

Exterior Lighting
Home & Landscape Pro and Landscape & Deck only
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Inserting Exterior Lighting

Inserting exterior light fixtures is easy — just point and click. 
When inserting an exterior light fixture, you have the option 
of inserting it on the terrain, or on a building location.

Lights are particularly important if you plan to create a 3D 
Real View™ of your model (page 277), since the program uses 
light to calculate and create the rendered view. 

To insert an exterior light fixture:

1. Select Insert > Landscape > Exterior Lighting, or 
click the Exterior Lighting button on the Landscape 
toolbar. Then, select either Exterior Lighting on 
Terrain or Exterior Lighting on Location, depending on 
where you want to insert the element. The Exterior 
Lighting on Location option lets you insert the element on 
a deck, or on anything that is associated with a building 
location.

2. In the catalog, select the light you 
want to insert.

3. Position the light where you want 
it, then click to insert it.

4. Right-click and select Finish.

Tip: If you switch to Rendered or 
Rendered Outline display mode, you 
can see instant lighting effects as you 
position and insert light fixtures. 

Moving a Light Fixture
You can move light fixtures in plan view by simply clicking 
and dragging them.

To move a light fixture:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.
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3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.

Editing the Properties of a Light Fixture
You can edit properties such as the overall height, width and 
depth of light fixtures.

To edit the properties of a light fixture:

1. Select the light fixture.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired.

4. Click OK.

Editing a Light Fixture’s Light Source
A light source is a light bulb. You can edit a light fixture’s light 
source to achieve a different lighting effect. For example, you 
can select a different type of bulb, or a bulb with a different 
wattage or color.

To edit a light fixture’s light source:

1. Select the light fixture whose properties you want to edit. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.
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3. Select the Lights tab.

4. To replace the currently selected light source with another 
type, click Edit, then select a light source from the Light 
Sources dialog. To add a light source to the fixture, click 
Add, then select a light source from the Light Sources 
dialog.

Tip: You can double-click a light source in the library and edit 
its Scale (intensity) and Color.

5. To delete a light source from the light fixture, click Delete.

6. To edit the position of the light source in relation to the 
light fixture, specify the X, Y and Z coordinates in the Light 
Position area. Coordinates are measured from the bottom 
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center of the fixture. The small red box in the preview 
window indicates the current position of the light source. 
Changing the X value moves the light source left or right. 
Selecting Middle positions the light in the center of the 
fixture, and selecting Minimum or Maximum positions it on 
the left or right side. If you select Custom you can enter a 
specific value in the adjacent edit box which is relative to 
the center position. For example, entering -3 moves the 
light source 3” left from the center. Changing the Y value 
moves the light source forward or backward. Selecting 
Minimum brings the light source all the way forward, and 
selecting Maximum moves it to the back of the fixture. 
Changing the Z value moves the light source up or down. 
Selecting Minimum positions the light source at the bottom 
of the fixture, while selecting Maximum positions it at the 
top of the fixture.

7. Once you’ve specified the properties, click OK.

Turning a Light On or Off
By default, lights are on when you insert them. You can 
virtually turn a light off by disabling its light source.

To turn a light on or off:

1. Select the light fixture you want to turn on or off. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Select the Lights tab.
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4. To turn the light on or off, click the eye icon next to the 
light source name.

5. Click OK.

Eye Icon
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It’s always those small touches that really pull a design 
together. TFP makes adding decorative accents and 
accessories a breeze - just point and click to insert a vast array 
of items, including fireplaces, fountains, wind chimes, 
decorative columns, corner accents, garden borders, weather 
vanes, door mats, patio umbrellas, trellises, bird baths, 
mailboxes, cars and planters.

Note: For information about interior accessories, see page 209.

Exterior Accessories
Home & Landscape Pro and Landscape & Deck only
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Inserting Exterior Accessories

Exterior accessories include everything from bird baths to 
weather vanes. Inserting exterior accessories is easy — just 
point and click. You can insert exterior accessories on the 
terrain, or on a building location.

To insert an exterior accessory:

1. Select Insert > Landscape > Exterior Accessories, 
or click the Exterior Accessories button on the 
Landscape toolbar. Then, select either Exterior 
Accessories on Terrain or Exterior Accessories on 
Location, depending on where you want to insert the 
element. The Exterior Accessories on Location option lets 
you insert the element on a deck, or on anything that is 
associated with a building location.

2. In the catalog, select the accessory 
you want to insert.

3. Position the element where you 
want it, then click to insert it.

4. Right-click and select Finish.

Moving Exterior 
Accessories
You can move exterior accessories in 
plan view by simply clicking and dragging them.

To move an exterior accessory:

1. Select the element you want to move. 

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.
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Rotating Exterior Accessories
You can rotate exterior accessories by clicking and dragging 
them.

To rotate an exterior accessory:

1. Select the element you want to rotate.

2. Hover your pointer over the triangular grip to 
display the Rotate cursor. 

3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Editing the Properties of an Exterior 
Accessory
You can edit properties such as the height, width and depth of 
most exterior accessories.

To edit the properties of an exterior accessory:

1. Select the element.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the properties as desired.
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4. Click OK.
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You can insert pop-up sprinklers in your landscape plan with 
a single mouse click. When you insert a sprinkler, the 
coverage of the spray is outlined with a dashed line.

Irrigation
Home & Landscape Pro and Landscape & Deck only
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Inserting Irrigation

The catalog contains a wide selection of pop-up sprinklers 
with varying ranges of spray. You insert a sprinkler by simply 
pointing and clicking with your mouse. When you insert a 
sprinkler, the coverage of the spray is outlined with a dashed 
line. 

To insert pop-up sprinklers:

1. Select Insert > Landscape > Irrigation, or click the 
Irrigation button on the Landscape toolbar.

2. In the catalog, select the sprinkler 
you want to insert. 

3. Position the sprinkler where you 
want it, then click to insert it. You 
can continue inserting more 
sprinklers if you want.

4. Right-click and select Finish. 

Moving Sprinklers
You can move a sprinkler by simply 
clicking and dragging it.

To move a sprinkler:

1. Select the sprinkler. 

2. Hover your pointer over the sprinkler’s square grip 
to display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release your 
mouse button.
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Rotating Sprinklers
You can rotate a sprinkler (and its spray) by simply clicking 
and dragging its rotation handle.

To rotate a sprinkler:

1. Select the sprinkler.

2. Hover your pointer over the sprinkler’s triangular grip. 

3. Click and drag to rotate the sprinkler, then release your 
mouse button. 

Editing a Sprinkler’s Spray Coverage
You can edit the distance covered by a sprinkler’s spray.

To edit a sprinkler’s spray properties:

1. Select the sprinkler.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Edit the size values on the Basic property page. For most 
sprinklers you would edit the Width and Depth values. 
The Adjustable sprinkler in the catalog lets you specify a 
custom radius and included angle for the spray. 

4. Click OK.
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TFP offers a variety of powerful drawing aids that help you 
insert elements easily and precisely where you want them in 
your drawing.

If you want you can display a drawing grid in your drawing 
area, as well as set up a snap grid so that your cursor snaps to 
the grid when you are inserting elements. The Object Snap 
feature automatically snaps your pointer to existing objects, 
and the Angle Snap snaps your pointer to specified angles. 
The Collision Control feature prevents you from inserting 
elements where they do not fit. 

You can set up drawing aids in your program settings, and 
toggle them on and off using the buttons on the Status bar.

TFP also offers a handy Query Element/Location tool that lets 
you select any element in your drawing and instantly view the 
element’s name and building location.

Drawing Aids
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Setting Up a Drawing Grid
A drawing grid is simply a set of horizontal and vertical lines 
that can help you orient objects to one another. By default, the 
spacing between grid lines is 1’, but you can change this if you 
want. You can also control the color and style of the grid. Note 
that the drawing grid is a visual aid only, and will not be 
included in printouts.   

To set up a drawing grid:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

2. In the Program Settings dialog, select Drawing Aids 
in the left column.

3. In the Grid area, check the Enable (F7) check box.

4. Click the Grid Color swatch, then select a color for the grid 
from the Color dialog.

5. From the Grid Style drop box, select a style for the grid — 
Dots or Lines. 

6. Specify the desired distance between vertical grid lines in 
the X Spacing edit box.

7. Specify the desired distance between horizontal grid lines 
in the Y Spacing edit box.

8. By default, the grid is 150’ x 150’, which is the default size 
of the terrain. To change the overall size of the grid, enter 
the desired width in the X Limit edit box, and the desired 
height in the Y Limit edit box.

9. Click OK.

Turning the Drawing Grid On and Off
You can toggle the drawing grid on and off in one of two 
ways:

• Press F7 on your keyboard
• Click the GRID button on the Status bar
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Using the Grid Snap
The Grid Snap feature snaps your pointer to an invisible grid 
when inserting elements. By default, the spacing between the 
grid lines in the invisible grid is 1”, but you can change this if 
you want. If you enable the Match Grid option, the invisible 
snap grid becomes the same size as the drawing grid. This will 
make it seem like you are snapping to the drawing grid while 
drawing.

To set up a snap grid:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

2. In the Program Settings dialog, select Drawing Aids 
in the left column.

3. If you want the snap grid to be the same size as the 
drawing grid, check the Match Grid check box in the Grid 
Snap area.

4. To specify a custom distance between vertical grid lines, 
enter a value in the X Spacing edit box.

5. To specify a custom distance between horizontal grid 
lines, enter a value in the Y Spacing edit box.

6. If you want to turn the grid snap on, check the Enable (F4) 
check box.

7. Click OK.

Turning the Grid Snap On and Off
You can toggle the grid snap on and off in one of two ways:

• Press F4 on your keyboard
• Click the GRIDSNAP button on the Status bar

Using the Object Snap
The Object Snap feature makes elements that you are currently 
inserting automatically snap to existing elements in your 
drawing. For example, if you are drawing a wall and hover 
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your pointer near an existing wall, your pointer will snap to 
the existing wall, making it easy to create a wall layout with 
cleanly intersecting walls.

By default, the Object Snap is enabled, but you can turn it off 
whenever you want. There are three ways to turn the Object 
Snap on or off.

To turn the Object Snap on or off:

• Press F5 on your keyboard
• Click the OBJSNAP button on the Status bar

• Select Settings > Program Settings, then on the Drawing 
Aids pane, check or uncheck the Enable (F5) check box in 
the Object Snap area

Using Ortho
The Ortho feature restricts your cursor movement to 90-degree 
angles when you are inserting elements. This can be especially 
helpful when drawing elements like walls. 

By default, Ortho is enabled. You can toggle it on and off 
using one of three methods.

To turn Ortho on or off:

• Press F8 on your keyboard
• Click the ORTHO button on the Status bar

• Select Settings > Program Settings, then on the Drawing 
Aids pane, check or uncheck the Ortho (F8) check box 

Using Angle Snap
When the Angle Snap feature is turned on, your cursor snaps 
to specific angles when rotating an element. If you set your 
snap angle to 10º, for example, your cursor will snap at 10º 
intervals as you rotate the element.
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By default, the Angle Snap is on. You can turn the Angle Snap 
on and off using one of three methods.

To turn the Angle Snap on or off:

• Press F6 on your keyboard
• Click the ANGLESNAP button on the Status bar

• Select Settings > Program Settings, then on the Drawing 
Aids pane, check or uncheck the Angle Snap (F6) check 
box 

To change the snap angle:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

2. In the Program Settings dialog, select Drawing Aids 
in the left column.

3. In the Ortho / Angle Snap area, type the desired snap angle 
in the Snap Angle edit box, or use the arrows to scroll up 
or down through a list of values.

4. Click OK.

Disabling/Enabling Collision Control
The program’s intelligent Collision Control feature prevents 
objects from being inserted where they do not fit. By default, 
Collision Control is on, but you can turn it off whenever you 
like using one of three methods.

To turn Collision Control on or off:

• Press F9 on your keyboard
• Click the COLLISION button on the Status bar
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• Select Settings > Program Settings, then on the Building 
Aids pane, check or uncheck the Enable Collision Control 
(F9) check box   

Note: Collision Control affects building elements on the 
current building location only. It does not affect landscape 
elements.

Querying Elements and Locations
Using the Query Element/Location tool you can select any 
element in your drawing and instantly view its name and 
building location.

To query an element/location:

1. Select Tools > Query Element/Location.

2. With the Query Element/Location cursor active, 
click on the element you want to inquire about. 
The Query Element/Location dialog displays the 
element’s name and building location.

3. When you are finished viewing the element and location 
information, click OK.

Note: For landscaping and terrain elements, which are 
associated with the terrain, the Location box displays “Terrain” 
rather than a building location.

Note: The Query Element/Location tool can only be used on 
elements that were inserted from the catalog. You cannot use it 
on drafting objects.
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You can change the unit of measure used in a drawing, or 
select a different level of precision for your measurements.

Once you’ve drawn something, you can measure it using the 
Measure tool. You can also use the Area/Perimeter tool to 
instantly calculate the area of your building. 

Measurement
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Changing the Unit of Measure
The units of measure used in your project are determined by a 
template, which by default is either a feet/inches template or 
millimeters template. 

Once you’ve opened a new project, you can change the units 
of measure and levels of precision used in that project by 
making selections on the Units of Measure pane of the 
Program Settings dialog.

To set your units of measure:

1. Select Settings > Program Settings or click the 
Program Settings button on the Settings toolbar.

2. In the Program Settings dialog, click Units of 
Measure in the left column.

3. Select either Imperial or Metric units.

4. To select a unit for distance measurements, make a 
selection from the Units drop box.

System Units Available
Imperial Feet-Inches

Inches
Metric Millimeters

Centimeters
Meters
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5. To select a unit for area measurements, make a selection 
from the Area drop box. Area measurements appear in the 
Area/Perimeter Calculator.

6. Select a level of precision for each unit of measure. For 
example, selecting a unit precision of #’-# #/16” sets the 
level of precision to 1/16th of an inch when measuring 
distances in feet and inches.

7. To change the level of precision for angle measurements, 
which are displayed in decimal degrees, make a selection 
from the Precision drop box in the Angles area. The 
selection you make determines the number of decimal 
places used.

8. Once you’ve set your units of measure, click OK.

Measuring Distances
Use the Measure tool to measure the distance between any 
two points in your 2D plan. 

To use the Measure tool:

1. Select Tools > Measure.

2. Click your first point on the screen. 

3. Move your cursor in the direction you want to measure. A 
ruler is displayed that stretches as you move your cursor.

System Units Available
Imperial Square Feet

Square Yards
Metric Square Meters
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4. Click your second point on the screen. The distance is 
shown on the ruler as well as on the Status bar at the 
bottom of the screen.

5. Once you have measured your first distance, you can keep 
selecting points to measure additional distances from the 
last point selected. A running total is displayed on the 
Status bar.

6. When you have finished measuring, 
right-click and select Finish. 

Calculating Area and Perimeter
The Area/Perimeter Calculator displays the area (e.g. square 
footage) and perimeter length of each location in your model. 
It also displays the total area and total perimeter (of all 
locations). You can use the calculator at any given point in 
time. The values in the calculator update automatically as 
your model increases or decreases in size.

Note that the calculations are taken from the exterior side of 
the building’s walls.

To measure area:

1. Select Tools > Calculate/Estimate > Area/Perimeter. Area 
measurements are displayed on the Area tab of the Area/
Perimeter Calculator dialog. Perimeter measurements are 
shown on the Perimeter tab. 
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You can omit selected locations from the total if you want. 
If a calculation is included in the total, it is highlighted 
green.

2. To omit a location from the calculation, select Omit from 
the drop box in the Include column. 

3. To add a location that has been omitted back into the 
calculation, select Add from the drop box in the Include 
column.

4. To turn the grid lines off, uncheck the Show Grid check 
box.

5. To print the calculations, click Print.

6. When you are done viewing the area calculations, click 
OK.

Note: The units of measure used for the area and perimeter 
can be changed on the Units of Measure pane in your program 
settings.
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When you double-click after inserting an element or select 
Finish from the right-click menu, you automatically go into 
Selection Mode, meaning you can select elements in your 
drawing area and edit them. 

Most elements can be moved, rotated, copied, replaced and 
deleted. Some elements have additional editing commands 
available. For example, you can lengthen, break and curve 
walls. All elements have a property sheet where you can 
change the size or appearance of the element. 

To access a menu of editing commands for a selected element, 
just right-click in the drawing area or select Edit > Modify 
Elements. Certain functions can be performed without 
selecting any commands at all. For example, you can move 
and rotate most elements by simply clicking and dragging 
your mouse.

This chapter describes how to select elements, and use general 
editing commands like Move, Rotate, Elevate, Duplicate, 
Replace and Delete. It also describes how to access and edit 
element properties, and apply materials and colors with the 
Materials Paintbrush.

Editing Elements
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Undoing the Previous Action
The Undo tool cancels your most recent action. You can undo 
as many actions as you have taken since your last save.

To undo an action:

• Select Edit > Undo, or
• Click the Undo button on the Standard toolbar, or
• Press Ctrl+Z

Tip: You can use the Redo tool to reapply an action you have 
canceled using the Undo tool.

Redoing an Undo
The Redo tool reapplies a tool that you have reversed using 
Undo. Redo will only work directly following an Undo.

To redo a task:

• Select Edit > Redo, or
• Click the Redo button on the Standard toolbar, or
• Press Ctrl+Y

Accessing Edit Commands
When you have an element selected, you can access a menu of 
edit commands by right-clicking in the drawing area, or by 
selecting Edit > Modify Elements. 

Menus vary depending on the element selected. Typical 
commands are Properties, Move, Rotate, Duplicate, and 
Delete. If two types of elements are selected (such as a floor 
and a wall), only commands that are common to both element 
types are available.

Certain functions can be performed without selecting any 
commands at all. For example, you can move and rotate most 
elements by simply clicking and dragging your mouse.

Moving Elements
When you select an element, you are automatically in Drag 
and Drop mode. If the element is a singular, one-click object, 
like a cabinet or plant, you can move the element by simply 
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clicking and dragging it. If you want to move an area-drawn 
element, such as a roof, you need to select the Move tool 
before clicking and dragging. Otherwise, doing a straight 
drag-and-drop will only stretch it. If you click and drag a wall, 
all walls attached to it move with it. 

If you have your Commander turned on and would like to be 
able to enter precise values for the move, you need to select 
the Move tool instead of doing a straight drag-and-drop. 

Note: Elements associated with walls, such as doors and 
windows, can only be moved within the wall they are in. You 
cannot move them to another wall. 

Doing a Drag-and-Drop
The straight drag-and-drop method is ideal for singular, one-
click elements like cabinets and plants. 

To move an element using drag-and-drop:

1. Select the element you want to move. You are now in Drag 
and Drop mode.

2. Hover your pointer over the element’s center grip to 
display the Move cursor.

3. Click and drag to move the element. 

4. When the element is where you want it, release the mouse 
button.

Using the Move Tool
Use the Move tool when you want to be able to specify a 
precise distance and direction for the move in the 
Commander. 

To move an element using the Move tool:

1. Select the element you want to move. 

2. Right-click and select Move, or select 
Edit > Modify Elements > Move.

3. Select a base point for the move. The move distance and 
direction will be measured from this point.
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4. Without holding your mouse button down, move your 
mouse to move the element. Select the point you want to 
move the element to, or enter a distance and direction in 
the Commander.

Nudging an Element
You can nudge an element slightly using the arrow keys on 
your keyboard. By default, the element is nudged 1” (or 
25mm). You can change the nudge distance in your program 
settings before nudging if you like.

To nudge an element:

1. Select the element that you want to nudge.

2. Use the arrows on your keyboard to nudge the element 
up, down, left or right.

Raising or Lowering an Element
Most elements can be raised or lowered using the Elevate tool 
on the element’s right-click menu. Some elements, such as 
roofs, do not provide access to the Elevate tool. In the case of a 
roof, you can raise or lower it by changing the Support Height 
variable in its properties.

To raise or lower an element using the Elevate tool:

1. Select the element you want to raise or lower. 

2. Right-click and select Elevate, or select 
Edit > Modify Elements > Elevate. The value shown in the 
Elevate dialog is the current elevation of the element.

3. In the Elevate dialog, specify the desired elevation of the 
element above the floor. If the element is a landscaping 
element, the value you specify is relative to the terrain. 
The distance you enter is the distance from the floor or 
terrain to the insertion point of the element. For most 
elements, the insertion point is at the base of the element. 
For windows and wall openings, however, the insertion 
point is at the top of the element. Therefore, if you are 
raising or lowering a window or wall opening, specify the 
desired distance from the floor to the top of the window or 
opening.
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4. Click OK.

Rotating Elements in 2D Plan View
Singular, one-click elements like cabinets and furniture can be 
rotated on the spot by simply clicking and dragging them 
while in Rotation mode.

Railings can be rotated by clicking and dragging their end 
points.

For most other elements such as walls, floors, ceilings or roofs, 
you need to use the Rotate tool. You also need to use the 
Rotate tool if you want to be able to enter a precise rotation 
angle in the Commander, or you want to rotate the element 
about a point other than the center point of the element.

Doing an On-the-Spot Rotation
If you see a triangular grip on an element when it is selected, it 
can be rotated by simply clicking and dragging it. Using this 
method, the element is rotated about its center point.

If your Angle Snap is on, the element will rotate in increments 
of whatever angle is set for the Angle Snap. If the Angle Snap 
is off, the element will rotate in increments of 1º.

To rotate an element by clicking and dragging:

1. Select the element you want to rotate.

Rotation grip

.Center . . .
90° 180° 270°
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2. Hover your pointer over the triangular grip to 
display the Rotate cursor. If you do not see the 
triangular grip, the element can only be rotated with 
the Rotate tool.

Tip: If the square grip is in close proximity to the triangular 
grip, you may want to zoom in on the element to 
distinguish between the two grips.

3. Click and drag to rotate the element.

4. When the element is at the desired rotation, release your 
mouse button. 

Using the Rotate Tool
Using the Rotate tool you can rotate an element about any 
selected base point. You should also use the Rotate tool if you 
want to be able to enter a precise rotation angle in the 
Commander.

If your Angle Snap is on, the element will rotate in increments 
of whatever angle is set for the Angle Snap. If you are using 
the Commander, you can override the Angle Snap by entering 
the desired angle in the Commander. If the Angle Snap is off, 
the element will rotate in increments of 1º.

To rotate an element using the Rotate tool:

1. Select the element to rotate.

2. Right-click and select Rotate, or select Edit > Modify 
Elements > Rotate.

3. Select a base point for the rotation. The base point can be 
any point on the element (e.g. center point or corner 
point), or any point in the drawing area. The point you 
pick establishes an automatic baseline that runs through 



Copying Elements

User’s Guide 237

the point at 180°. You can rotate full-circle around this 
baseline. 

Tip: If you want to align an element with another element 
that may be lying at an odd angle, select a base point on 
the other element, then line up your rotation line with that 
element.

4. Without holding your mouse button down, move your 
mouse to rotate the element. The element will rotate from 
the defined base point in the direction you move the 
mouse. If the Commander is turned on, you can view the 
angle of rotation as you rotate, or enter a precise angle. 
Positive angle values are read in a counter-clockwise 
direction, while negative values are read in a clockwise 
direction. 

Copying Elements
The Duplicate tool creates a copy of a selected element that 
you can then position where you like on the current location. 

To duplicate an element:

1. Select the element to copy. 

2. Right-click and select Duplicate, or select Edit > Modify 
Elements > Duplicate. 

3. Select a base point for the copy movement. Typically you 
would select one of the element's grips, but you can click 
anywhere in the drawing. The base point is simply a 
reference point used to define the move distance.

Base Point

.
Baseline 

270° rotation

.



Chapter 39  Editing Elements

238 TurboFLOORPLAN

4. Select the point you are copying the element to. You can do 
this by moving your mouse and then clicking to insert the 
copy, or by typing a distance and direction in the 
Commander.

Replacing Elements
You can use the Replace tool to replace an element in your 
drawing with a different item from the catalog. 

To replace an element:

1. Select the element that you want to replace. 

2. Right-click and select Replace, or select Edit > Modify 
Elements > Replace.

3. In the Catalog Access dialog, select the replacement item.

4. Click OK. The element is automatically replaced. 

Note: You can only replace an element with another of the 
same type. For example, you can replace a window with 
another window, but you cannot replace a window with a 
door.

Editing an Element’s Size or Composition
You can edit the physical make-up of an element as well as its 
dimensions by accessing the element’s Basic property page. 
Some elements have additional property pages that control its 
composition. For example, cabinets have Leaf and Details 
property pages.
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When you edit the properties of elements that exist in your 
drawing, only selected elements are changed. Other 
occurrences of the element in your drawing remain 
unchanged. You can, however, select and edit multiple 
elements at the same time provided they share the same 
properties. 

To edit the properties of an inserted element:

1. Select the element you want to edit. To select multiple 
elements, use 
Shift + click.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Adjust the properties as desired. Clicking a dimension 
marked with an alphabetical character (a, b, c, etc.) 
highlights the corresponding dimension in the element 
graphic, and vice versa, if one exists. 

4. Click OK. The selected elements are updated in the 
drawing.

Note: Editing the properties of an element in your drawing 
has no effect on the element’s property definition in the 
catalog it came from. Editing an element in a catalog affects all 
future insertions of that element in your drawing.

Editing an Element’s Material/Color 
Settings
When you view your design in Rendered or Patterned mode, 
elements are displayed using materials that are defined in the 
elements’ properties. A material can be a texture, such as 
brick, or a color. Materials also have a pattern assigned to 
them, which is what you see when you view in Patterned 
view. You can select a different material for each of an 
element’s components. 

You can edit an element’s material settings through its 
Appearance property page. 
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To change an element’s material through the Appearance 
property page:

1. Select the element you want to edit. To select multiple 
elements, use Shift + click.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. Select the Appearance tab.

4. In the Components pane, select the component whose 
material you want to change. 

5. In the Material area, click the Select button.

6. In the Materials dialog, select the group containing the 
desired material. If you want to choose a solid color, select 
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the Paint group. You can filter the material list according 
to specific applications by making a selection from the 
Filter drop box.

7. Select the material that you want to use. The swatch in the 
preview window updates automatically. 

8. Click OK to return to the Appearance page.

9. If you want to learn more about the settings on the 
Appearance page, see the online help. 

10. Click OK. 

Applying Materials and Colors with the 
Materials Paintbrush
The Materials Paintbrush is best used in 3D view. It lets you 
select a material or color in the catalog, then apply it to parts of 
an element. When you use the Materials Paintbrush on an 
element, the settings on the element’s Appearance property 
page update to match the selections you made with the 
Materials Paintbrush. 

To use the Materials Paintbrush:

1. Select Edit > Materials Paintbrush, or click the 
Materials Paintbrush button on any tabbed toolbar. 

2. In the catalog panel, select the material 
you want to apply. There is an incredible 
selection to choose from, including 
Wood, Brick, Marble, Concrete, Steel, 
Carpet, Tile, Roofing, Fabric, Paint, and 
much more. You can filter the material 
list according to specific applications by 
making a selection from the Filter drop 
box.

3. In 3D view, click on the element part 
that you want to apply the material to. 
The material is immediately applied.

4. Right-click and select Finish.
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Sampling Materials with the Eyedropper
While the Materials Paintbrush is active you can use the 
Eyedropper tool to identify a material applied to an element in 
your drawing. Once you’ve clicked on the element, the catalog 
panel updates to display the material applied to the element. 
This eliminates guesswork and allows you to identify a 
material that you want to use again without having to search 
the catalog.

To sample a material with the Eyedropper:

1. Activate the Materials Paintbrush tool.

2. In the catalog panel, click the Eyedropper button. 
Your cursor becomes an eyedropper.

3. Click on the element whose material you want to sample.

4. The catalog updates to display the material applied to the 
element. 

Note: The material will not be added to the materials history 
list unless you apply it to an element.

Deleting Elements
You can delete an element from your drawing in two quick 
steps.

To delete an element:

1. Select the element.

2. Press the Delete key on your keyboard, or right-click and 
select Delete, or select Edit > Modify Elements > Delete.

Eyedropper
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 Chapter40
Using text tools you can add text to any area of your drawing. 
You may want to add a title to the plan, or label rooms or 
specific elements. You can use whatever fonts and colors you 
want. 

Dimensions are used to convey precise measurements. You 
can dimension the exterior of your design instantly, and 
quickly insert interior dimensions with a few simple mouse 
clicks. 

This chapter describes all text and dimension tools available, 
and how to edit text and dimensions.

Text & Dimensions
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Adding Text
You can add custom text or pre-defined labels to your 
drawing. You can select the text style you want to use, and 
control the justification of the text. Text can be moved and 
rotated after it has been inserted, just like most other elements. 

To add text:

1. Select Tools > Text > Text, or click the Text button on 
the Notation toolbar. 

2. To select a style for the text, click the Text Style button and 
select or create a text style in the Text Styles dialog. Note 
that the text style is applied to text that you are about to 
type, or that is selected in the editing window.

3. Type the desired text in the editing window. Or,

• To import a text (*.txt) file, click Import, then select the 
file to import.

• To insert a pre-defined label, select the label you want 
in the Pre-defined Labels list on the right side of the 
dialog, then drag it into the editing window. You can 
also double-click the label or click  to add the 
label to the editing window. To access the Labels 
library, where you can add and edit labels, click 
Library.

4. By default, text is left justified. For multi-line text, this 
means that text lines will line up on the left, and be ragged 
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on the right. If you want to change the justification of the 
text, click the appropriate justification button. 

5. If you want to automatically return to the Text dialog after 
you have inserted the current text, enable the Multiple text 
insert check box. Otherwise, the Text command is finished 
once you insert the text.

6. Click OK. The text is attached to your cursor.

7. Position the text where you want it, then click to insert it.

Editing Text
You can edit the style or content of text by accessing its 
properties.

To edit text:

1. Select the text you want to edit.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. In the Text dialog, make the desired changes.

4. Click OK.

Adding Text with a Leader
You can insert text with an arrow attached to it that points to a 
particular element or area in your drawing. The leader has 
two segments and can be oriented in any fashion.

Left Justified Right Justified

Centered
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To add a text with leader:

1. Select Tools > Text > Text with Leader, or click the 
Text with Leader button on the Notation toolbar.

2. To select a dimension style for the leader and text, click the 
Dimension Style button and make a selection from the 
Dimension Styles dialog.

3. Type the desired text in the editing window. Or,

• To import a text (*.txt) file, click Import, then select the 
file to import.

• To insert a pre-defined label, select the label you want 
in the Pre-defined Labels list on the right side of the 
dialog, then drag it into the editing window. You can 
also double-click the label or click  to add the 
label to the editing window. To access the Labels 
library, where you can add and edit labels, click 
Library.

4. If you want to automatically return to the Leader dialog 
after you have inserted the current text, enable the Multiple 
text insert check box. This lets you keep inserting text 
without having to select the Text with Leader tool again.

5. Click OK.

6. In the drawing area, select the point where you want the 
arrowhead to appear.

7. Select the next point of the leader. If you only want a two-
point leader, right-click and select Finish at this point. 
Otherwise, you can select a third point for the leader if you 
want.
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8. If you are creating a three-point leader, select a third point 
for the leader. The text is inserted.

Editing Text with a Leader
You can edit the style or content of text with a leader by 
accessing the text’s properties.

To edit text with a leader:

1. Click on the text with leader to select it. 

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

3. In the Leader dialog, make the desired changes.

4. Click OK.

1.
Sliding Glass Door2. 3.
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Dimensioning
TFP automatically displays on-screen dimensions as you 
draw, making it easy to draw walls at correct lengths, and 
insert elements like doors and windows precisely where you 
want them. These dimensions are drawing aids only that 
disappear once you have inserted the element. 

Using TFP’s selection of Dimension tools, you can add fixed 
dimensions to your drawing to convey the precise 
measurements of your floor plan. You can control the style of 
these dimensions, and move and stretch them if you need to.

Setting the Current Dimension Style
When you add dimensions to your drawing, they use the 
current dimension style, which by default is the Standard 
dimension style. You can select a different dimension style to 
be the current one if you want. 

To set the current dimension style:

1. Select Settings > Dimension Settings.

2. In the Dimension Settings dialog, click the Current Style 
button.

3. In the Dimension Styles dialog, select the style you want 
to set as current. 

4. Click OK in the Dimension Styles dialog.

5. Click OK in the Dimension Settings dialog.

Creating Automatic Exterior Dimensions

The Apply Auto Exterior Dimensions tool automatically 
dimensions the exterior walls of your home. By default, three 
dimension strings are created: one for openings, one for wall 
segments, and an overall dimension for each side of the 
model.

Home & Landscape Pro and Home Designer only
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To create automatic exterior dimensions:

1. Select Tools > Dimensions > Apply Auto Exterior 
Dimensions, or click the Apply Auto Exterior 
Dimensions button on the Notation toolbar.

Creating Auto Interior Dimensions

The Auto Interior Dimensions tool automatically dimensions 
interior walls in your model. 

To create automatic interior wall dimensions, you draw a base 
line through your model. Dimensions are created for any walls 
along that line (running in the same direction as the line). 

To create automatic interior dimensions:

1. Select Tools > Dimensions > Auto Interior 
Dimensions, or click the Auto Interior Dimensions 
button on the Notation toolbar.

2. Select a start point for the base line that is outside of the 
model.

Overall

Walls

Openings

Home & Landscape Pro and Home Designer only
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3. Select an end point for the base line that is outside of the 
model. Dimensions are created along that line.

4. Right-click and select Finish.

P1. .P2

Dimension
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Creating Linear Dimensions
A linear dimension is a horizontal or vertical dimension with 
extension lines going vertically (for a horizontal linear 
dimension) or horizontally (for a vertical linear dimension) to 
the origins of the extension lines, which define the endpoint of 
the dimension. 

This tool is ideal for creating interior dimensions, or 
dimensions on a landscape plan.

To create linear dimensions:

1. Select Tools > Dimensions > Linear Dimensions, or 
click the Linear Dimensions button on the Notation 
toolbar.

2. Click a point in your drawing to begin the dimension line.

3. Move your mouse (you do not have to hold the mouse 
button down) to a second point and click. A dimension 
line including offsets, arrows and a numerical value is 
added to your drawing.

4. Move your mouse away from the dimension line to stretch 
your extension lines. When the extension lines are the 
desired length, click to finish the dimension.
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Creating Aligned Dimensions
An aligned dimension is similar to a linear dimension, except 
it tilts to the same angle as the element you are dimensioning, 
making it the ideal choice for elements that are not horizontal 
or vertical. 

To create aligned dimensions:

1. Select Tools > Dimensions > Aligned Dimensions, 
or click the Aligned Dimensions button on the 
Notation toolbar.

2. Click a point in your drawing to begin the dimension line.

3. Move your mouse (you do not have to hold the mouse 
button down) to a second point and click. A dimension 
line including offsets, arrows and a numerical value is 
added to your drawing.

Changing the Style of a Dimension
You can change the appearance of a dimension’s line, arrows 
and text by applying a different dimension style to it.

To change the style of a dimension:

1. Select the dimension. 

2. Right-click and select Change Style, or select Edit > Modify 
Elements > Change Style.

3. In the Dimension Styles dialog, select the style you want 
to apply to the dimension. 

4. Click OK.
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TFP provides a basic set of 2D drafting tools — Line, Arc, 
Circle and Rectangle. Objects drawn with these tools will not 
display in 3D view. You can use these tools to help with your 
design layout. For example, you may want to draw 
construction lines to help you place walls and other elements.

Note: The tools on the Layout menu are only available in 2D 
plan view. 

Layout Tools
Home & Landscape Pro only
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Drawing Lines

You can draw a line with one or more segments by simply 
picking points.

To draw a line in Model View:

1. Select Tools > Layout > Line, or click the Line 
button on the Layout toolbar.

2. Select a start point for the line.

3. Select the end point for the line. If you want you can 
continue adding segments to the line. If you want to close 
the last line back to the first line to create a closed shape, 
right-click and select Close.

4. When you are finished drawing the line, right-click and 
select Finish.

Note: Lines can only be drawn in 2D plan view.

Drawing Arcs

An arc is basically a curved line. There are three Arc tools 
available:

Start, Center, End. When you specify the start and center 
points, you define the arc’s radius. The end point establishes 
the arc’s length.

3 Points. Select a start point for the arc, a second point along 
the arc, then drag the arc into position as you specify the end 
point.

Start, End, Radius. Select the start and end point of the arc to 
define its length, then select a third point to define the arc’s 
radius. With this option, you can only draw the arc in the 
counterclockwise direction.

Note: Arcs can only be drawn in 2D plan view.

Home & Landscape Pro only

Home & Landscape Pro only
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To draw an arc with the Start, Center, End tool:

1. Select Tools > Layout > Arc > Arc - Start, Center, 
End, or click the Arc button on the Layout toolbar 
and select Arc - Start, Center, End.

2. Select a start point for the arc.

3. Select the arc’s center point. The radius is now defined.

4. Select the arc’s end point to define the arc’s length.

5. Right-click and select Finish.

To draw an arc with the 3 Points tool:

1. Select Tools > Layout > Arc > Arc - 3 Points, or click 
the Arc button on the Layout toolbar and select Arc 
- 3 Points.

2. Select the start point of the arc.

3. Select a second point on the arc.

4. Drag the arc to stretch it to the desired length and position, 
then select the end point of the arc.

5. Right-click and select Finish.

Start x
Center

End

1

2
3
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To draw an arc with the Start, End, Radius tool:

1. Select Tools > Layout > Arc > Arc - Start, End, 
Radius, or click the Arc button on the Layout 
toolbar and select Arc - Start, End, Radius.

2. Select the start point of the arc.

3. Select the end point of the arc. Keep in mind that the arc 
can only be created in the counterclockwise direction.

4. Select a third point to define the arc’s radius.

5. Right-click and select Finish.

Drawing Circles

There are two ways to draw a circle. With the Circle - Center, 
Radius tool you draw the circle from the center out, by picking 
two points to define its radius. With the Circle - 2 Point tool, 
you draw the circle outward from a selected point, essentially 
defining the circle’s diameter. 

Note: Circles can only be drawn in 2D plan view.

To draw a circle by specifying its radius:

1. Select Tools > Layout > Circle > Circle - Center, 
Radius, or click the Circle button on the Layout 
toolbar and select Circle - Center, Radius.

2. Click the point that is to be the center of the circle.

Start End

Radius

Home & Landscape Pro only
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3. Move your pointer away from the center point. The circle 
grows as you move farther away from the center.

4. When the circle is the desired size, click to finish.

5. Right-click and select Finish.

To draw a circle by specifying its diameter:

1. Select Tools > Layout > Circle > Circle - 2 Point, or 
click the Circle button on the Layout toolbar and 
select Circle - 2 Point.

2. Click a point in the drawing. The circle will grow from this 
point.

3. Move your pointer away from the selected point. The 
farther you move away from this point, the larger the 
circle becomes.

4. When the circle is the desired size, click to finish.

5. Right-click and select Finish.

1

2

1 2.
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Drawing Rectangles

You can draw a rectangle easily by just picking two points on 
the screen.

To draw a rectangle:

1. Select Tools > Layout > Rectangle, or click the 
Rectangle button on the Layout toolbar.

2. Click a point on the screen. This will be one of the 
rectangle’s corners.

3. Move your pointer away from the current point. The 
rectangle grows as you move farther away.

4. When the rectangle is the desired size, click to finish it.

5. Right-click and select Finish.

Note: Rectangles can only be drawn in 2D plan view.

Home & Landscape Pro only
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 Chapter42
You can import digital photographs or scanned images into 
your work space. The image is oriented vertically in 3D view, 
much like a billboard. You could, for example, import a 
picture of your backyard, so when you look out the window, it 
feels like you’re home. 

A photo board can be stationary or set to rotate with the 
camera so it’s always facing you. You can also control the 
height and width of the photo board. 

The handy Photo Board Wizard steps you through the process 
quickly and easily. You can also insert pre-defined photo 
boards from the catalog.

Photo Boards
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Importing a Photo Board
A photo board is simply a digital image that is oriented 
vertically in your 3D workspace. You can import any image 
you want — your family, pets, neighbor’s house — the only 
limit is your imagination. The handy Photo Board Wizard 
does it all in a few quick steps.

To import a photo board:

1. Select File > Import > Photo Board Wizard.

2. Click Next.

3. Type a name for your photo board.
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4. Click the Select button, then select the image you want to 
import. You can import BMP, JPG and TGA files. The 
image is displayed in the preview window.

5. Define the size of the image by entering values in the 
Height and Width edit boxes. Generally you should specify 
a size that is as close to reality as possible. For example, if 
the image is of a person who is six feet tall, you should 
enter a value close to 6’ in the Height edit box.

6. Click Next.

7. Specify whether you want the photo board to be stationary 
or active. If Stationary is selected, the board will always 
remain oriented the same way, regardless of changes in 
your camera angle. If Billboard is selected, the photo board 
will rotate toward the camera so it will always face you in 
3D. 
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8. Click Next.

9. Click Finish. The photo board is attached to your cursor, 
ready to be inserted.

10. Position the photo board where you want it, then click to 
insert it.

11. Right-click and select Finish.

Inserting a Photo Board from the Catalog
The catalog contains a collection of photo boards containing 
pictures of people, animals, flags, and other objects. If you 
have saved your imported photo board to the catalog, it is also 
displayed with the existing photo boards in the catalog.

To insert a photo board from the catalog:

1. Select Insert > Photo Board.

2. In the catalog, select the photo board you want to insert.

3. Position the photo board where you want it, then click to 
insert it.

4. Right-click and select Finish.

5. Click and drag to rotate the photo board, then release your 
mouse button. 
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TFP keeps track of all the materials you use to build your 
home as you design it — right down to the very last nail. You 
can generate a project estimate with a single mouse click. The 
estimate consists of two reports: the quantity report and the 
cut list. The quantity report, or bill of materials, lists all of the 
materials used to build your house, as well as the quantity, 
unit price and total cost of each material. The cut list reports all 
the timber and steel members in your drawing calculates the 
number of members you need to buy at the store using real-
world lengths of your choice.

Sample unit prices are provided for your convenience, but you 
can specify custom pricing directly from your suppliers. The 
grand total is calculated for you automatically, making 
estimating simple, quick and accurate. 

Project Estimate
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Generating a Project Estimate
You can view an accurate project estimate at any time during a 
design session. The estimate is always up-to-date and reflects 
your project in its current state. 

The project estimate includes both a quantity report and cut 
list. The quantity report, or bill of materials, lists all of the 
materials used to build your house, as well as the quantity, 
unit price and total cost of each material. The cut list reports all 
the timber and steel members in your drawing calculates the 
number of members you need to buy at the store using real-
world lengths of your choice. If you have no members in your 
drawing, the cut list page will be blank.

To generate a project estimate:

1. Select Tools > Calculate/Estimate > Generate Project 
Estimate.

2. To view the quantity report, select the Quantity Report 
tab.
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3. To view the cut list, select the Cut List tab.

The Generate Project Estimate dialog acts as a viewer for your 
project estimate. You can print and save the quantity report 
and cut list directly from this dialog.

By default, materials are grouped by location, and there is a 
terrain category for landscaping materials. You can choose to 
omit selected locations and elements from the quantity report 
if you want. Estimates are based on a report template that 
determine what information is included, and how it is 
reported. You can add and edit report templates to suit your 
needs.
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Selecting a Report Template
By default, project estimates use the Standard Report Form 
template, which generates a TXT file. You can select a different 
report template to use if you want, such as a Microsoft Excel 
template. 

To select a report template:

1. In the Generate Project Estimate dialog, select the 
template you want to use from the template drop box.

Printing a Project Estimate 
You can print the quantity report or cut list directly from the 
Generate Project Estimate dialog. Alternatively you can open 
the report in its associated editor and print it there. 

To print a project estimate:

1. If you are in the Generate Project Estimate dialog, select 
the Quantity Report tab or the Cut List tab depending on 
which one you want to print. 

2. Select File > Print. You can also click the Print button 
to the left of the report template drop box.

3. In the Print dialog, select the printer you want to 
use, then click Print.

Saving a Project Estimate
The Generate Project Estimate acts like a viewer for your 
estimate. If you want to save the estimate to a file, you need to 
use the Save and Close tool. By default, reports are saved in 
the same directory where the project is saved. The file 
extension depends on the currently selected report template.
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To save the current project estimate:

1. In the Generate Project Estimate dialog, select File > Save 
and Close, or click the Save and Close button at the 
bottom of the dialog.

To save a quantity report using a different file name or 
save location:

1. Click the Browse button next to the Report File edit box at 
the bottom of the Generate Project Estimate dialog.

2. In the Report Filename dialog, select the location where 
you want to save the report.

3. In the File name edit box, type the name you want to save 
under.

4. Click Save. The report is saved under the specified name 
and location.

Editing Material Pricing
Most elements have a default unit price set for them in their 
properties. These prices are used in the project estimate.

If you have already created your design, you can edit the 
prices of inserted elements by selecting them in the drawing, 
then editing their properties. Alternatively you can generate 
and save a project estimate, then edit the pricing in the 
estimate’s associated editor, such as Excel or Notepad 
(depending on the report template used).

If you edit the price of any element in the catalog, the price 
change will affect all new insertions of the element. 

To edit the price of an inserted element:

1. Select the element in your drawing. You can select 
multiple elements of the same type using Shift+click.

2. Right-click and select Properties, or select Edit > Modify 
Elements > Properties.

Browse button
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3. In the properties dialog, select the Quantity tab.

4. Edit the value in the Price edit box. Note that prices are 
unit prices. For a carpet, for example, you would enter the 
price per square foot, not the price of the entire carpet.

5. Click OK in the properties dialog.

To edit material pricing in the catalog:

1. Select File > Catalogs > Catalog Manager, or right-click an 
element in the catalog and select Catalog Manager.

2. From the Elements menu, select the element type you 
want to edit.

3. In the Groups window, select the group containing the 
element you want to edit.

4. In the element window, select the element to edit.

5. Select Edit > Edit Element, or right-click and select Edit 
Element.

6. In the properties dialog, select the Quantity tab.

7. Edit the value in the Price edit box. Note that prices are 
unit prices. For a carpet, for example, you would enter the 
price per square foot, not the price of the entire carpet.

8. Click OK in the properties dialog.

9. Click OK. 
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While in 3D view you can use a variety of navigation tools to 
move around in your design in real time. These include Walk 
Around, Fly Around, Look Around and Slide.

3D Navigation
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Walking Around in a 3D Camera View
When you are in a 3D camera view, you can use the Walk 
Around tool to walk around your model, or even go right 
inside it. You can walk forward, backward, left or right.

To walk around in a 3D camera view:

1. Select View > Zoom and Navigate > Walk Around, or 
right-click in the drawing area and select Walk 
Around, or click the Walk Around button on the 
Zoom and Navigate toolbar.

2. Click and drag in the direction you want to move.

• To move forward, click and drag upward.
• To move backward, click and drag downward.
• To walk left or right, click and drag left or right.
If you click and drag up to the left, your path of motion 
will curve upward to the left, and so forth.

Flying Around Your 3D Model
In a 3D camera view, the Fly Around tool revolves the camera 
around the target. 

To fly around your model in a 3D camera view:

1. Select View > Zoom and Navigate > Fly Around, or 
right-click in the drawing area and select Fly 
Around, or click the Fly Around button on the 
Zoom and Navigate toolbar. 

2. Use your mouse button to orbit the camera. Your options 
are described below.

• Click and hold the mouse button to slowly rotate the 
camera around the target on a level plane. 

• Drag toward the top of the screen to make your model 
tilt downward like a boat coming off a wave.

• Drag toward the bottom of the screen to make your 
model tilt up like a boat riding onto a wave.

• Drag to the right to rotate the model in a clockwise 
direction.
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• Drag to the left to rotate the model in a 
counterclockwise direction.

Note: Model direction is the opposite of camera direction. For 
example, if the model appears to be moving clockwise, the 
camera is actually moving counterclockwise. 

Sliding in a 3D Camera View
In a 3D camera view, the Slide tool moves both the camera and 
target at the same time. 

To slide in a 3D camera view:

1. Select View > Zoom and Navigate > Slide, or right-
click in the drawing area and select Slide, or click 
the Slide button on the Zoom and Navigate toolbar.   

2. Once Slide is selected, you can do the following:

• Drag right to move your model view to the left.
• Drag left to move your model view to the right.
• Drag up (toward the top of the screen) to move your 

model view down (toward the bottom of the screen).
• Drag down to move your model view up.

Note: Model direction is the opposite of camera and target 
direction. For example, if the model appears to be moving to 
the right, the camera and target are actually moving to the left. 

Spinning the View Using the Look Around 
Tool 
In a 3D camera view, the Look Around tool revolves the target 
around the camera. 

To spin the view in a 3D camera view:

1. Select View > Zoom and Navigate > Look Around, or 
right-click in the drawing area and select Look 
Around, or click the Look Around button on the 
Zoom and Navigate toolbar. 
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2. Once Look Around is selected, you can do the following 
(presuming that your target is located inside or near the 
model):

• Drag right to move the target in a counterclockwise 
direction. Your model orbits around you in a 
clockwise direction.

• Drag left to move the target in a clockwise direction. 
Your model orbits around you in a counterclockwise 
direction.

• Drag up to lower the height and shorten the distance 
of the target. Your view becomes high-angle, and your 
model moves toward the top of the screen.

• Drag down to raise the height and lengthen the 
distance of the target. Your view becomes low-angle, 
and your model moves toward the bottom of the 
screen.

Note: Be careful when using the Look Around tool. It is very 
easy to lose sight of your model since the camera's "eye" is 
fixed in one direction only. It does not move to follow the 
orbiting target. Therefore, your field of vision is limited, and 
your model can quickly get above, below or behind you.

Resetting the Camera in a 3D View
If you have moved the camera of a 3D camera view, either by 
dragging it in 2D plan view or using a navigation tool like 
Walk Around or Slide, you can use the Reset Camera tool to 
move the camera back into its original position. 

To reset the camera to its original position:

1. Select View > Zoom and Navigate > Reset Camera, 
or click the Reset Camera button on the Zoom and 
Navigate toolbar.
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TFP incorporates powerful 3D Real View™ rendering 
technology. 3D Real View rendering adds light and shadow to 
a textured 3D view to achieve photo-realistic images of both 
the interior and exterior of your home. These images can be 
printed directly from the screen. You can also choose to save 
the rendered image to a bitmap (BMP) or JPG file that you can 
then open in most graphic editing applications.

Once you’ve set up your scene, creating a 3D Real View 
rendering involves only a mouse click or two. In a short time 
you’ll have a vivid, life-like view to enjoy!

3D Real View™



Chapter 45  3D Real View™

278 TurboFLOORPLAN

Setting the Viewpoint for the Scene
When you create a 3D Real View rendering, your model is 
captured at the angle currently shown on the screen. In most 
cases, the best type of view for 3D Real View rendering is a 
Perspective view, because it is the most realistic. For 
information about 3D viewing, see 2D and 3D Viewing on 
page 17.

Setting the Scene
Even though creating a 3D Real View rendering involves 
nothing more than a mouse click, there are a few things you 
should consider beforehand. 

Note: It doesn’t matter what display mode (wireframe, 
patterned, etc.) you’re currently in. 3D Real View renderings 
will always be textured.

Exterior Shots
If you want to do an exterior shot, the most important factor to 
consider is sunlight. This is determined by your global 
position and time of day. By adjusting these settings, you 
control how much sunlight is in the scene, and from what 
angle it shines. See Defining Your Location and Time of Day on 
page 279.

Night Shots
To create a night shot, you need to first set your background to 
a night scene. See Selecting a Background for 3D Views on 
page 24. Once your background is set, all you need to do is set 
the time to a time of day when there is no sun. If you do want 
to create a night shot, you will probably want to insert some 
exterior lighting in your design. See Inserting Exterior Lighting 
on page 204.

Interior Shots
When creating interior shots, light comes from light fixtures 
that you have inserted in the room, and can also come through 
the windows if it is daytime. You can turn lights on and off as 
well as change their light bulbs for different light intensity and 
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effect. For information about interior light fixtures, see Interior 
Lighting on page 115. 

Defining Your Location and Time of Day
You can define where your model is located in the world, as 
well as set the time of day. This determines how much 
daylight there will be in the scene. 

To define your location and time of day:

1. Select Settings > Program Settings, or click the 
Program Settings button on the Settings toolbar. 
You can also click the Options button in the 3D Real 
View dialog.

2. In the Program Settings dialog, select Global Settings in 
the left column.

3. Specify your location and time of day. For more 
information, see the online help.

4. Click OK.
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Creating a Basic 3D Real View™ Rendering
You can create a basic 3D Real View rendering with the click of 
a button. 

Basic rendering uses the raytracing method. Raytracing is a 
direct illumination algorithm that traces the path taken by a 
ray of light from the camera through the scene, then calculates 
the reflection, refraction, or absorption of the ray when it 
intersects objects in the scene. 

Basic rendering is ideal when you want to produce something 
of average quality very quickly.

Rendered views are displayed in the 3D Real View dialog once 
they’ve been calculated. The image is also saved to a BMP or 
JPG file for later access. For more information see Saving a 3D 
Real View™ Rendering to a File on page 286.

To create a basic 3D Real View rendering:

1. Display the 3D view that you want to render.

2. Select View > Render 3D Real View.

3. In the 3D Real View dialog, make sure the scene is how 
you want it to appear. 
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You can change the scene using the tools below the 
preview window.

4. On the Basic tab, click the Render button. The progress of 
the ray tracing is indicated on the progress bar. When the 
rendering is complete, the word ‘Done’ appears below the 
progress bar.

5. If you want to change the scene and render it again, enable 
the Modify Viewpoint radio button, then use the tools 
below the preview window to change the scene. Enabling 
the Raytrace radio button loads the last rendered image.

6. When you are finished rendering, click Close.

Creating an Advanced 3D Real View™ 
Rendering
Advanced 3D Real View rendering uses the radiosity method 
as well as the raytracing method. 

Radiosity is a global illumination algorithm that simulates the 
many reflections of light around a scene, generally resulting in 
softer, more natural shadows and reflections.

Advanced 3D Real View rendering can take considerably 
longer than basic rendering, but the result is generally more 
photo realistic.

By default, the scene is automatically raytraced once the 
radiosity solution has been calculated. However, you can 
choose to prevent this if you want to be able to navigate 
through the radiosity solution before raytracing the scene. 

To create an advanced 3D Real View rendering:

1. Display the 3D view that you want to render.

2. Select View > Render 3D Real View.

View Filter
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Fly Around

Look Around
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3. In the 3D Real View dialog, select the Advanced tab.

Make sure the scene is how you want it to appear. You can 
change the scene using the tools below the preview 
window.

4. By default, raytracing will begin as soon as the radiosity 
calculations are complete. If you do not want to raytrace 
automatically after radiosity, disable the Auto Raytrace 
check box. Disabling automatic raytracing gives you the 
opportunity to navigate through the scene before 
raytracing begins.

5. Click the Calculate Radiosity Solution button in the 
Radiosity area. Radiosity calculations begin. 
Basically, radiosity determines how much light is 
given off by the sun or by lighting fixtures, and how much 
light is reflected off the surface of elements. The view is 
updated at regular intervals during these calculations. 

If you click the Stop Radiosity Solution button 
during radiosity calculations, the solution will stop, 
and the scene will be instantly raytraced unless you 
have disabled automatic raytracing. You may want to do 
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this if the process seems to be taking a long time, but you 
may not get the result you want. (The image may turn out 
too dark.) 

If you have disabled automatic raytracing, you can click 
the Calculate Radiosity Solution button to resume the 
radiosity solution.

To erase the current radiosity solution, click the 
Reset Radiosity Solution button. This frees up 
memory, and also lets you start a new solution if 
you want. 

6. By default, once the radiosity calculations are complete, 
raytracing begins. Please wait while the rendered image is 
generated.

If you disabled automatic raytracing, the scene is not 
automatically raytraced once the radiosity calculations 
have been performed. Instead, the radiosity solution 
remains in the preview window. When you are ready to 
raytrace, click the Step 2: Raytrace button.

7. Once the rendering is complete, it appears in the preview 
window. If you want to change the scene and render it 
again, enable the Modify Viewpoint radio button, then use 
the tools below the preview window to change the scene. 
Enabling the Radiosity radio button loads the last 
radiosity solution. Enabling the Raytrace radio button 
loads the last rendered image.

8. When you are finished viewing the 3D Real View 
rendering, click Close. 

If you selected the Render to File option before rendering, 
the image is saved to a file. For more information, see 
Saving a 3D Real View™ Rendering to a File on page 286.
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Editing the Lighting in a Scene
If you find that your rendering is too light or too dark, or that 
you want to create different lighting effects, consider the 
following concepts:

Time of Day. Your location and time of day determine how 
much daylight is in a scene. The time of day in your program 
settings determines the time of day in your rendering. See 
Defining Your Location and Time of Day on page 279.

Light Fixtures. You may need to add light fixtures to increase 
the amount of light in a scene. This is particularly important 
for interior shots and night shots. For information on inserting 
interior light fixtures, see page 116. For information on 
inserting exterior light fixtures, see page 204.

Light Sources. You can change the bulbs in your light fixtures 
to achieve different lighting effects. For example, you can 
choose a bulb with a stronger or weaker wattage, or one that is 
a different color. See Editing a Light Fixture’s Light Source on 
page 116.

Turning Lights Off. If you have light fixtures in your scene and 
want to decrease the amount of light in the scene, you can turn 
selected light fixtures off. See Turning a Light On or Off on 
page 118.

Editing 3D Real View™ Settings
There are a number of different settings that you can define to 
customize the look of your 3D Real View rendering. You can 
control the quality of the image, add fog or smoke effects, turn 
daylight off, and set antialiasing properties. These settings 
must be defined prior to rendering.

To edit 3D Real View settings:

1. Select View > Render 3D Real View. 

2. In the 3D Real View dialog, click the Options button.

3. In the Program Settings dialog, select Rendering in the left 
column.

4. Edit the settings as desired. Here is a basic description of 
each setting:
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Quality Level. The level of quality in the resulting 3D Real 
View image. There are 5 levels to choose from. Note that 
the higher level of quality you choose, the longer the 
rendering process takes. This option must be set before 
rendering takes place.

Update display every _ steps. As the program performs 
lighting calculations, the view updates at regular intervals 
to reflect calculations up to that point. This is the number 
of steps between visual updates. 

Image Brightness. Specifying a value manually overrides 
the automatic exposure of the virtual camera. The 
program's "virtual camera" works in a manner similar to 
actual point-and-shoot cameras. It automatically calculates 
the correct "exposure" for the lighting situation and 
produces a view with infinite depth of field (i.e. 
everything is in focus).

Enable Daylight. If disabled, omits daylight from the 
lighting calculations, and can speed up rendering. 
Daylight is included in radiosity calculations, even for 
indoor scenes (light can come through a window). This 
option should always remain on for exterior shots, even if 
it is a night shot. An example of a situation where you 
might turn daylight off is if you are rendering a room with 
a very small window, or no windows at all. 

Antialiasing. Blends pixels in areas where two colors or 
two materials meet to reduce artifacts (or “stair steps”) 
and produce a more natural look to the scene. 

Raytrace Automatically after Radiosity. Sets the default 
state for the Auto Raytrace check box in the 3D Real View 
dialog (Advanced tab). 

Enable Effects. Allows you to create either a fog or smoke 
effect in the rendering.

Fog. Creates a fog effect in the rendering.

Smoke. Creates a smoke effect in the rendering.

Density. The thickness of the fog or smoke.
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Render to File. If enabled, the next 3D Real View rendering 
you create will be saved to a file. The image will be saved 
to a BMP or JPG file that you can open in most graphic 
editing applications.

Location. The name and save location of the rendered 
image. Click the Browse button to view or specify the file 
name and save location for the rendered image.

Size. The size of the resulting rendered image in pixels. 
The default selection is Current View Size, which saves the 
image at the size currently shown in the preview window. 
Pre-defined sizes include 640 x 480, 800 x 600, and 1024 x 
768. Selecting the Custom option lets you define a custom 
size by entering values in the Width and Height edit 
boxes.

Width. If Custom is selected in the Size drop box, this lets 
you define a custom width for the rendered image in 
pixels.

Height. If Custom is selected in the Size drop box, this lets 
you define a custom height for the rendered image in 
pixels.

Saving a 3D Real View™ Rendering to a 
File
By default, 3D Real View renderings are saved to a BMP file in 
your Projects directory. You can edit the save settings if you 
want. For example, you may want to define a specific file 
name or different save location.

To save a 3D Real View rendering to a file:

1. Select View > Render 3D Real View. 

2. In the 3D Real View dialog, click the Options button.

3. In the Program Settings dialog, select Rendering in the left 
column.

4. In the Image Output area, enable the Render to File check 
box.
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5. By default, rendered images are saved in the same 
directory your projects are stored in. By default, this 
would be the following directory:

C:\Documents and Settings\<Current User>\
My Documents\TurboFLOORPLAN product name\Projects

To select a different location to save your rendered 
image in, click the Browse button next to the 
Location edit box. In the Save As dialog, navigate to 
the folder where you want to store rendered images.

To specify a custom name, enter the name in the File Name 
edit box. You can select either BMP or JPG as your file 
format from the Files of type drop box.

6. Click Save in the Save As dialog.

7. Click OK.

Note: If you have created and saved a rendering, and then 
create another one, the currently saved will be overwritten 
unless you specify a different save name or location. See the 
next topic, Creating Multiple 3D Real View Renderings in the 
Same Project.

Creating Multiple 3D Real View Renderings 
in the Same Project
When you perform a rendering, the image is saved to a BMP 
or JPG file in your Projects directory. The file has the same 
name as your project. If you create another rendering in the 
same project, the file from the previous rendering is 
overwritten.

If you want to create and save more renderings within the 
same project, you need to specify a different output name for 
each new image before creating the rendering.

To create and save an additional 3D Real View rendering:

1. Select View > Render 3D Real View. 
2. In the 3D Real View dialog, click the Options button.

3. In the Program Settings dialog, select Rendering in the left 
column.
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4. In the Output Options area, make sure Render to File is 
checked.

5. Click the browse button next to the Location edit 
box.

6. In the Save As dialog, enter a name in the File name 
edit box that is different from any other images that you 
have saved. You can select either BMP or JPG as your file 
format from the Files of type drop box.

7. Click Save.

8. Click OK in the Program Settings dialog.

The next 3D Real View rendering you create will be saved 
to the new file name.



289

 Chapter46
An animation is just like a movie. TFP‘s powerful animation 
tools let you record an actual tour through your 3D model that 
you can play back at any time. You can even add realistic 
sounds to your animation, such as a doorbell ringing. You can 
also choose to ray trace the animation for a photorealistic 
display that includes light, shadows and reflection. 

To create an animation, all you need to do is draw one or more 
paths for the camera to follow. Then, just sit back and watch 
your design come to life!

Animation
Home & Landscape Pro only
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Drawing an Animation Path

The first step in creating an animation is defining a path for 
the camera to follow. You can specify where you want the 
camera to look (along the path or at a specific target or target 
path), as well as the view angle. 

You draw the path by selecting a camera start point and 
subsequent control points. The path automatically curves 
between points to create a smooth motion for the camera. 
Once you have drawn the path, you can add, remove and 
elevate control points if you want. 

You can draw more than one path if you want. By default, all 
paths will be included in the animation, and will be followed 
in the order in which they were drawn. You can, however, 
choose which paths you want to include in the animation, as 
well as the order of paths for the camera to follow.

To draw an animation path:

1. Make sure that the location on which you want to capture 
the animation is the current building location. Also, it is 
recommended that you draw the path while in 2D plan 
view.

2. Select Tools > Animation > Insert Path, or click the 
Insert Path button on the Animation toolbar.

Home & Landscape Pro only
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3. In the Path Properties dialog, specify a name for the path 
for identification purposes.

4. In the Behavior area, specify what you want the camera to 
focus on during the animation. If you select Follow Path, 
the camera will focus on a different target along the path 
in each frame. If you select Specify Target, the camera will 
always point towards a target point that you specify. 

5. In the View Angle area,  specify how wide you want the 
view angle to be by either sliding the ruler or entering a 
value in the edit box. Higher values produce a wide-angle 
view; lower values produce a close-up view.  

6. Click OK.

7. Select a start point for the camera. For example, if you 
want to start your animation by walking through the front 
door, select a point outside the front door.

8. If you selected the Specify Target option, select the point 
you want to the camera to remain focused on during the 
animation.

9. Select the next point of the path. Each point you select is 
called a control point. The camera will move to each control 
point and capture an image of the view at that point. 
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Basically, control points are the key to drawing and 
shaping your path.

10. Continue selecting control points until your path is 
finished.

11. Right-click and select Finish.

Tip: You can simulate the movement from one location to 
another by drawing your path up or down a staircase. Once 
the path is drawn, you can then edit the elevation of control 
points on the other location to view elements on that location.

Previewing the Animation

Once you have drawn one or more paths for your animation, 
you can preview the resulting animation. You can play the 
animation automatically, or step through it frame by frame.

To preview an animation:

1. Make sure you have drawn a suitable path for your 
camera.

Camera start point

Home & Landscape Pro only
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2. Select Tools > Animation > Create Animation, or 
click the Create Animation button on the 
Animation toolbar.

3. In the Create Animation dialog, click the Play 
button to automatically play the animation. 

To pause the animation, click the Pause button.

4. To play the animation manually by stepping 
through each frame, click the Next Frame button. 
Alternatively you can click and drag the slider to 
play it manually or skip to specific frames of the 
animation.

To step back to the previous frame, click the 
Previous Frame button.

5. To return to the start of the animation so you can 
play it again, click the Restart button.

Note: To output the animation to an actual file so that it 
can be viewed outside of TFP, you need to save it. See Saving 
an Animation to a File on page 294.

Note: If you enabled the Ray Trace Animation option in your 
Animation Properties, the ray tracing will not appear in the 
preview. It will only appear when you export the animation to 
a file.
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Adding Sounds to an Animation

You can add a variety of sounds to your animation, such as a 
doorbell ringing or the creak of a door opening. Sound is 
added to an animation by inserting a sound node at a selected 
path control point, and choosing the sound file you want to 
play at that point. The sound will be played when the camera 
reaches that point during the playback of the animation.

To add a sound to an animation:

1. With your 2D plan displayed, select Tools > 
Animation > Add Sound Node, or click the Add 
Sound Node button on the Animation toolbar.

2. Click on the control point on your animation path where 
you want to insert the sound.

3. In the Open dialog, select the sound file you want to insert. 
Sound files have a *.wav extension. A number of sounds 
can be found in the program’s Sounds directory. To hear 
the selected sound, click the Play Sound button.

4. Click Open. A small node is inserted next to the control 
point.

Note: Sound nodes can only be placed at control points. You 
can add control points to your path if necessary. 

Saving an Animation to a File

Once you have previewed your animation and are satisfied 
with it, you can record it to an *.avi file which can be played 
using any digital media application that supports the *.avi file 
format, such as Windows Media Player. 

To save an animation to a file:

1. Select Tools > Animation > Create Animation, or 
click the Create Animation button on the 
Animation toolbar.

Home & Landscape Pro only

Home & Landscape Pro only
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2. In the Create Animation dialog, click Save.

3. In the Save As dialog, specify a file name and save 
location for the animation file, then click Save. The 
animation begins recording.

4. Wait until the entire animation has been recorded. The 
progress of the recording is shown on the Overall Progress 
bar. If you want to stop recording before the animation has 
finished, click Stop. The file will be saved at this point.

5. When the recording is complete, click Close.
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Using the Project Trace Image tool you can import a BMP, JPG 
or TGA file into your drawing space. You can then trace the 
image using elements from the catalog, creating a true TFP 
model. This is the perfect tool to use if you have sketched out 
ideas in a drawing program or scanned a floor plan, and want 
to recreate the plan in TFP. You can resize the image if you 
need to before tracing, and delete it once you’re done tracing. 
Most floor plans are copyrighted, so make sure you have 
permission to copy them.

Using the Object Import Wizard you can quickly import 
custom 3D objects in DXF, SKP or 3DS format directly into 
your drawing.

For information on importing photo boards, see page 263.

Importing
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Importing an Image to Trace
You can import a BMP, JPG or TGA image, such as a scanned 
floor plan, and trace it using elements from the catalog, 
creating a true TFP model. 

To import an image to trace:

1. In 2D plan view, select File > Import > Project Trace 
Image.

2. In the Open dialog, select the file type you are importing 
from the File type drop box. You can import BMP, JPG or 
TGA files.

3. Locate the file to import, then click Open. 

4. If you want to reverse the image (i.e. flip it left to right), 
enable the Flip Horizontal check box. If you want to flip the 
image vertically (so it is upside down), enable the Flip 
Vertical check box.

5. To change the scale of the image, enter the dimensions in 
the Length and Height edit boxes. Typically you would 
use the overall dimensions shown on the floor plan. For 
example, if the house is 70’ long, enter 70’ in the Length 
edit box. Keeping the Maintain Aspect Ratio check box 
enabled ensures that the image scales uniformly when one 
of the dimensions is changed. This prevents the image 
from becoming distorted. 

6. Click OK. A bounding box is attached to your cursor. 

7. Position the box in your drawing area, then click to insert 
it. The image is displayed.
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Importing Custom Objects into Your 
Drawing
If you have any custom 3D objects in 3DS, DXF or SKP 
(Google™ SketchUP) format, you can import them into your 
TFP drawing. Many sites on the Internet offer free 
downloading of objects for your convenience. Typically, these 
are objects such as furniture and appliances. 

You can import a custom object directly into your drawing 
using the Object Import Wizard. Once inserted, you can edit 
its properties.

To import a custom object into your drawing:

1. Select File > Import > Object Wizard.



Chapter 48  Importing

302 TurboFLOORPLAN

2. On the first screen of the Object Import Wizard, click Next.

3. In the first edit box, type a name for the element.

4. From the element drop box, select the type of element you 
are importing. 

5. If you selected Exterior Furniture or Exterior Accessories, 
you have the option of inserting the element on the floor of 
the current building location, or the terrain. Select either 
Insert on location, or Insert on terrain.

6. Click the Select button.

7. In the Open dialog, locate and select the file that you want 
to import, then click Open. You can import DXF, 3DS and 
SKP files. If you selected a DXF or 3DS file, the following 
dialog appears:
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8. Specify how you want the components created by making 
a selection from the next drop box. For DXF files you can 
choose from Colors or Layers. Since 3DS objects are 
essentially an assembly of materials, the only selection for 
3DS objects is Materials. (This step does not apply to 
SketchUp files.)

9. Click Next. 

10. (This step does not apply to SketchUp files.) If you know 
what units were used to create the object, select the units 
from the units drop box. Otherwise, select the unit of 
measure that will result in a logical Resultant Width, 
Resultant Depth and Resultant Height. Selecting Custom 
lets you specify a custom scale in the Custom Scale edit 
box.

The scale is the multiplication factor of the units used for 
objects in the block. For example, if you're converting a file 
that you assume was created in feet and inches, the scale is 
25.4. 
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11. Click Next.

12. To display or hide a component in 2D and/or 3D view, 
select it in the list, then click the appropriate eye icon. 
Enabling the Show only selected component check box 
displays only the currently selected component in the 
object preview. 

13. Click Next.

14. Click Finish.

15. Click to insert the new element in your drawing.

16. Right-click and select Finish.
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Once you have started and saved a project, you can work on it 
whenever you like. You can open a saved project by selecting 
Open on the File menu. Once you have opened a project, you 
can edit, save, print and export it.

You can have more than one project open at a time. If you 
have more than one project open, you can switch between 
projects using the Window menu.

The Save function saves the current project under its current 
name. You can use Save As to save a project under a different 
name, and Save All to save all currently open projects. By 
default, one backup of your drawing is saved along with the 
drawing.

Opening, Saving & 
Printing
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Opening a Saved Project
You can open a saved project (*.bld file) using the Open tool.

To open a saved project:

1. Select File > Open, or click the Open button on the 
Standard toolbar.

2. In the Open dialog, navigate to the location where 
you saved the project. By default, projects are saved in the 
following directory:

C:\Documents and Settings\<Current User>\My 
Documents\TurboFLOORPLAN product name\Projects

3. Select the project to open, then click Open.

Tip: If the project you want to open is one that your recently 
worked on, it may be listed in the recently used file list near 
the bottom of the File menu. Just select it to open it.

Saving Projects
The program has three save functions: Save, Save As and 
Save All. They are located on the File menu.

• To save the current project under the current name, 
or to save the current project for the first time, 
select File > Save, or click the Save button on the 
Standard toolbar. If you are saving for the first time, you 
are prompted for a file name.

• To save the current project under a different name (i.e. 
create a copy of it), select File > Save As, then specify a 
name in the Save As dialog. 

• To save all currently open projects, select File > 
Save All, or click the Save All button on the 
Standard toolbar.

Printing Drawings
The program uses the standard Windows Print routine with a 
few added features, such as a print preview, print area 
selection, scaling options, and paper placement.
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To print a drawing:

1. Select File > Print, or click the Print button on the 
Standard toolbar.

2. In the Print dialog, specify your print settings.

Printer. Select a printer from the drop box. Click 
Properties to specify general printer properties such as 
orientation and paper size. Note that if you are printing to 
scale, and the scale of the drawing is too large for the 
selected paper size, the drawing will be automatically tiled 
across multiple sheets of paper. 

Print to file. If enabled, the project is printed to a print file 
rather than a printer. 

(Print) All. Prints the extents of your drawing, which is the 
portion of your drawing that currently contains elements. 
As you add new elements, the extents update 
automatically. 

(Print) Display. Prints exactly what you see on the screen 
in the current view. If only part of your drawing is 
currently visible, only that part will appear in the printout.

(Print) Window. Prints a specific area of your drawing that 
you define by drawing a bounding window around it. 
Click the Window button, then click two points in your 
drawing to define the selection window. You can snap the 
window to elements in your drawing if desired. The 
preview in the Print dialog will update automatically.
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Copies. Select the number of copies to print from the 
Number of copies drop box. 

Scaling. The Print to Scale option prints the current view 
according to its defined scale in the view properties. 

To see a view’s defined scale, select Edit > View Properties, 
or right-click in the drawing area and select View 
Properties, or right-click on a view’s tab below the 
drawing area and select View Properties. 

Note that the Print to Scale option will not work with 
most 3D views (unless they are elevation views), since 3D 
views cannot be scaled.

The Fit To Page option scales the drawing to fit the 
selected paper size. Note that this is the default setting for 
3D views, since 3D views are not affected by changes in 
scale (unless they are elevation views). 

Placement. If you select Lower left, the image is printed in 
the lower left corner of the paper. If you select Center on 
paper, the image is centered on the paper. 

Print Quality. Choose from three levels of print quality 
(150, 300 or 600 dpi). A higher resolution (600 dpi) 
produces graphic images that are sharper and show finer 
detail, while a lower resolution (150 dpi) permits faster 
printing and shows less detail.

Preview. Displays a preview of how the drawing will fit on 
the paper. If the drawing is too large for the selected paper 
size, it will be automatically tiled across multiple sheets of 
paper. Separation marks will then appear in the preview 
indicating where the drawing will be divided. 

Print Line Weights. Prints the lines in your drawing using 
the weight (thickness) assigned to them in element 
properties. Otherwise, all lines print with the same 
thickness.

3. Click OK. 
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TFP offers three different Export tools: 2D Image, 2D Drawing 
and 3D Model. 

The 2D Image tool lets you export the image on the screen to a 
BMP, JPG or TGA file, which can be opened in a variety of 
graphic editing applications.

With the 2D Drawing tool you can export your 2D plan to an 
AutoCAD DXF file. 

The 3D Model tool lets you export your 3D model to a DXF, 
3DS (3D Studio), WRL (VRML) file. When you open the file in 
the associated application, you will see an actual 3D model in 
that application.

Exporting
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Exporting the Current View to a 2D Image 
File
The 2D Image export tool lets you save the current view to a 
BMP, JPG or TGA file, which can be opened in most graphic 
editing applications. 

To export the current view to an image file:

1. Select File > Export > 2D Image.

2. In the Save As dialog, click on the Save as type drop box 
and select the file format you want to export to.

3. Locate the directory where you want to save the exported 
file.

4. In the File name edit box, type a file name.

5. Click Save. The Export View dialog appears:

6. From the Color drop box, select the desired color setting. 
Choose from Grayscale, 256 Color, High Color (16-bit), High 
Color (24-bit) or True Color (32-bit).

7. From the Size drop box, select the desired output size. By 
default, Current View is selected, which saves the image at 
the size currently shown on the screen. You can choose 
from a list of preset sizes, or select Custom and enter the 
desired values in the Width and Height edit boxes.

8. Click Save. The view is exported.

Exporting the 2D Drawing to a DXF File
The 2D Drawing export tool saves your 2D plan in a 2D, 
vector drawing format that can be opened in AutoCAD or any 
application that accepts DXF files.
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To export your 2D drawing to a DXF file:

1. Select File > Export > 2D Drawing.

2. Locate the directory where you want to save the exported 
file.

3. In the File name edit box, type a file name.

4. Click Save. A dialog appears confirming the model has 
been exported successfully.

5. Click OK.

Exporting the 3D Model
The 3D Model export tool lets you save your 3D model in the 
following 3D file formats:

• AutoCAD DXF (*.dxf)
• Autodesk 3D Studio (*.3ds)
• VRML (*.wrl)
When you open the file in its associated application, you will 
see an actual 3D model in that application.

To export your 3D model:

1. Select File > Export > 3D Model.

2. In the Save As dialog, click on the Save as type drop box 
and select the file format you want to export to.

3. Locate the directory where you want to save the exported 
file.

4. In the File name edit box, type a file name.

5. Click Save. A dialog appears confirming the model has 
been exported successfully.

6. Click OK.
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1-2-3
2D Designer’s View, 19
2D Drawing export, 310
2D Image export, 310
2D Plan View, 18
3D Camera Views

changing the display mode, 
31
changing, 22
creating, 21
displaying, 20
flying around in, 274
resetting the camera, 276
sliding in, 275
spinning the view, 275
walking around in, 274

3D Model export, 311
3D Real View

about, 277
advanced, 281
basic, 280
editing lighting, 284
editing settings, 284
save location, 287
save name, 287
saving multiple renderings, 

287
saving to file, 286
setting the viewpoint, 278
setting up the scene, 278

3D Stereo View, 24
3D Studio files

exporting to, 311
importing, 301

3DS export, 311
3DS import, 301

A
Above-ground pools, 200
Accessories

editing properties, 108
inserting, 107, 210
moving, 107
rotating, 108

Add Location, 9
Add Sound Node, 294
Advanced 3D Real View, 281
Air conditioner, central, 132
Air returns, 132
Aligned Dimensions, 254
Angle measurements, 

precision, 227
Angle Snap, 222

Index
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Animation
adding sounds, 294
drawing a path, 290
previewing, 292
saving to *.avi file, 294

Annotation
Dimensions, 250
Text with Leader, 247
Text, 246

Antialiasing, 285
Appearance, elements, 239
Appliances

editing properties, 103
inserting, 102
moving, 102
rotating, 103

Apply Auto Exterior 
Dimensions, 250

Aquariums, 107
Arbors, 210
Arcs, drawing, 256
Area/Perimeter Calculator, 

228
Auto Exterior Dimensions, 250
Auto Interior Dimensions, 251
Auto Raytrace, 282
AutoCAD

exporting 2D plan to, 310
exporting 3D model to, 311

Auto-cut terrain around 
building, 140

AVI file export, 294

B
Background, in 3D views, 24
Badminton courts, 200
Balustrades, 77
Barstools, 106
Basic 3D Real View, 280
Basketball courts, 200

Bathtubs, 128
Beds, 106
Beds, garden, 182
Benches, 196
Berms/Trenches, creating, 142
Bill of Materials, 268
Billboard setting, 265
Billboards, 264
Billiards table, 106
Bird baths, 210
Bird feeders, 210
Bird houses, 210
Bitmaps, importing for tracing, 

300
Blank Project, 2
Blinds, 107
BMP

exporting to, 310
importing for tracing, 300

Bookshelves, 106
Borders, garden, 210
Bowls, 107
Box planters, 210
Boxes, garden, 210
Brightness, rendering, 285
Building Locations

adding, 9
current, 10
defining, 8
deleting, 9
filtering from view, 39
making selectable/non-
selectable, 39
querying an element’s 
location, 224

Building lot, 150
Building Wizard, 44
Buildsoft Estimating Export, 

270
Bulbs, changing, 116, 205
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C
Cabanas, 200
Cabinets

editing properties, 98
inserting sinks into, 99
inserting with Kitchen 
Builder Wizard, 92
inserting, 98
moving, 98

Cable service box, 110
CAD objects, drawing, 256
Camera Views

changing, 22
creating, 21
displaying, 20
flying around in, 274
resetting the camera, 276
sliding in, 275
spinning the view, 275
walking around in, 274

Cameras
orbiting around targets, 274
placing new, 21
resetting, 276

Cars, 210
Cathedral ceilings, 72
Ceiling fans, 116
Ceiling Height, 8
Ceiling lights, 116
Ceiling Openings

creating, 74
Ceilings

by Perimeter, 71
by Room, 71
cathedral, 72
cutting openings in, 74
displaying framing, 34
vaulted, 72

Center on wall
door, 60

opening, 63
window, 61

Centimeters, working in, 226
Central Air Unit, 132
Central Vac Outlet, 122
Central Vac, 110
Chairs, 106
Chairs, patio, 196
Change Style, dimension, 254
Changing 254
Chests, 106
Chimneys

applying materials to, 134
editing height, 133
inserting, 133

Circle 2 Point, 259
Circle Center, Radius, 258
Circles, drawing, 258
Cleaning equipment, 110
Coffee tables, 106
Cold air returns, 132
Collision Control, 223
Color

applying to the terrain, 141
applying with Materials 
Paintbrush, 241
changing an element’s, 239
grid, 220
light bulbs, 116, 205

Columns
attaching footings to, 57
decorative, 210
inserting, 56

Compost box, 110
Computer desks, 106
Computers, 106
Concrete slabs, creating, 166
Context-sensitive menus, 14, 

232
Contours, showing, 141
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Copies (print), 308
Copying

elements on same location, 
237
walls to create a new story, 
53

Cribs, 106
Cross-section, creating, 26
Curtains, 107
Curving

edging, 187
fills, 184
paths, 177
retaining walls, 173

Custom elements, importing, 
301

Customer Care, 5
Cut List

printing, 270
saving, 270
viewing, 269

Cut Opening
ceiling, 74
floors, 70

Cutaway, dynamic, 23

D
Daylight, enabling, 285
Decimal precision for angle 

measurements, 227
Deck Builder Wizard, 160
Deck Stairs

editing properties, 165
inserting, 164

Deck tool, 163
Decks

building with Deck Builder 
Wizard, 160
building with Deck tool, 
163

editing, 164
inserting a deck floor, 163
inserting stairs, 164

Deleting
building locations, 9
elements, 242
walls, 52

Deselecting elements, 14
Designer’s View, 19
Dimension Styles

changing, 254
setting current, 250

Dimensions
about, 250
aligned, 254
auto exterior, 250
auto interior, 251
changing style, 254
editing an element’s, 238
linear, 253
setting current style, 250

Dishwasher, 102
Display All But Framing, 34
Display Filter, 35
Display Framing, 34
Display Mode, 31
Display settings, adjusting, 3
Displaying

elements, 38
framing, 34
locations, 39

Distance, measuring, 227
Diving board, 200
Doghouses, 200
Door mats, 210
Doors

automatically centering, 60
editing, 65
flipping around, 64
flipping swing, 64
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inserting, 60
moving, 63

Dormer Roof, 87
Dormers

about, 86
creating, 86, 87

Drafting
arcs, 256
circles, 258
lines, 256
rectangles, 260

Drawing Grid
displaying, 220
setting up, 220
turning on and off, 220

Drawing, 11
Dressers, 106
Driveways, 176
Dryer, 102
Dumpsters, 110
Duplicate to Locations, 53
Duplicate, 237
DXF export, 310, 311
DXF import, 301
Dynamic Cutaway, 23

E
Edge Shape, 73
Edging

changing length, 187
curving, 187
inserting, 186

Edit menu, 14
Editing

about, 231
accessing edit commands, 
232
accessing editing tools, 14, 
232
appliances, 103

building locations, 8
cabinets, 98
deck stairs, 165
decks, 164
doors, 65
electrical elements, 124
element properties, 239
equipment, 110
exterior accessories, 211
exterior furniture, 197
exterior structures, 202
fills, 183
furnishing elements, 107
HVAC elements, 134
light fixtures, 205
nudging elements, 234
openings, 65
plumbing fixtures, 129
railings, 79
ramps, 76
roofs, 83, 84, 85
stairs, 76
walls, 51, 54
windows, 65

Editing Mode, 12
Effects, rendering, 285
Electrical Elements

editing size, 124
lowering, 123
moving, 123
raising, 123
wiring, 124

Electrical Junction Box, 110
Electrical Wiring

changing line style, 126
inserting, 124
reshaping/stretching, 125

Electronics
editing properties, 108
inserting, 106
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moving, 107
rotating, 108

Elements
changing elevation, 234
deleting, 242
editing properties, 239
importing external files, 301
inserting, 11
moving, 232
querying, 224
rotating, 235

Elevate tool, 234
Elevation

editing an element’s, 234
electrical elements, 123

Elevations, viewing, 26
Enable Collision Control, 223
Enable Daylight, 285
Enable Effects, 285
Encyclopedia, plant, 192
Equipment

editing size, 111
inserting, 110
moving, 110
rotating, 110

Estimate
changing report format, 270
generating, 268
printing cut list, 270
printing quantity report, 
270
saving cut list, 270
saving quantity report, 270
specifying name, 271
specifying save location, 
271

Example projects, 3
Excavated areas, 144
Excel XLS template, 270
Exercise equipment, 110

Exporting
animations to *.avi files, 294
to 3DS (3D Studio) file, 311
to BMP file, 310
to DXF file, 310, 311
to JPG file, 310
to TGA file, 310
to WRL (VRML) file, 311

Extending
edging, 187
retaining walls, 172

Exterior Accessories
editing size, 211
inserting, 210
moving, 210
rotating, 211

Exterior Furniture
editing size, 197
inserting, 196
moving, 196
rotating, 197

Exterior Lighting
editing size, 205
inserting, 204
moving, 204

Exterior Structures
editing, 202
inserting house templates, 
200
inserting, 200
moving, 201
rotating, 202

Eyedropper, 242

F
Faucets, 128
Feet/Inches, working in, 226
Fences

editing properties, 156
inserting, 156
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Filing cabinets, 106
Fills

creating, 182
curving, 184
reshaping, 183
resizing, 183

Filtering
display, 35
elements for selection, 38
elements from view, 38
landscape elements, 38
locations for selection, 39
locations from view, 39
notation objects, 38

Finishing commands, 12
Fireplaces, indoor, 132
Fireplaces, outdoor, 210
Fit To Page, 308
Flip Horizontal, 300
Flip Opening, 64
Flip Swing, 64
Flip Vertical, 300
Floor Level, 8
Floor Locations

adding, 9
current, 10
defining, 8
deleting, 9
querying an element’s 
location, 224

Floor Openings
creating in automatic floors, 
69
creating in manual floors, 
70

Floor plan tracing, 300
Floor registers, 132
Floor to Ceiling Height, 45
Floors

about, 68

cutting openings in, 69, 70
deck, 163
displaying framing, 34
inserting by perimeter, 68
inserting by room, 69

Flowers, 190
Fly Around tool, 274
Fog, adding to rendering, 285
Follow Path, 291
Footings

attaching strip footings to 
walls, 56
inserting mono footings, 57

Format, project estimate, 270
Fountains, 210
Framing

displaying, 34
hiding, 34
locking visibility, 37

Freezer, 102
Furnaces, 132
Furniture

editing properties, 108
interior, 106
moving, 107
outdoor, 196
rotating, 108

G
Gable roofs, 84
Garages, 200
Garbage bins, 107
Garbage disposals, 110
Garden beds, 182
Garden borders, 210
Garden boxes, raised, 210
Garden sheds, 168
Gardens, 190
Gas Meter, 110
Gates
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editing properties, 158
inserting, 157

Gazebos, 200
Generate Project Estimate, 268
Geometry, editing, 238
Global Settings, 279
Glossary of Terms, 5
Golf Holes, 200
Google SketchUP import, 301
Greenhouse, 200
Grid

drawing, 220
snap, 221

Grid Color, 220
Grid Snap, 221
Grid Style, 220
Ground Floor Height above 

Terrain, 45
Guardrails, 77

H
Handicap ramp, 76
Handrails, 77
Hanging planters, 210
Head Height, 8
Heater, propane, 210
Heating elements, 132
Height

ceiling, 8
floor, 8
head, 8
wall, 8
window, 8

Height (elevation)
editing an element’s, 234
electrical elements, 123

Help
Glossary of Terms, 5
Online Help, 3
technical support, 5

Hidden Line mode, 32
Hiding

elements, 38
framing, 34

Hills, creating, 141
Hot tubs, 200
House Builder Wizard

canceling, 2
disabling automatic launch, 
48
using, 44

House Templates, 200
HVAC Elements

editing properties, 134
inserting, 132
moving, 134

Hydro meter, 110

I
Image Brightness, rendering, 

285
Importing

3D Studio Files, 301
DXF files, 301
objects, 301
photo boards, 264
SKP files, 301
text files, 246, 248

Inches, working in, 226
Include Walls, 87
In-ground pools, 200
Inserting

about inserting elements, 11
accessories, 107
air returns, 132
appliances, 102
cabinets, 98
columns, 56
decks, 160
doors, 60
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driveways, 176
edging, 186
electrical elements, 122
electronics, 106
equipment, 110
exterior accessories, 210
exterior furniture, 196
exterior structures, 200
fences, 156
fills, 182
floor registers, 132
floors, 68
gates, 157
HVAC elements, 132
interior furniture, 106
irrigation, 214
landscaping, 179
light fixtures, 116, 204
mono footings, 57
paths, 176
patios, 166
photo boards, 264, 266
plants, 190
plumbing fixtures, 128
property lines, 150
ramps, 76
retaining walls, 172
scanned home plan, 300
sidewalks, 176
site boundary, 150
sprinklers, 214
stairs, 76
text, 246
vents, 132
walls, 50
windows, 61

Installing the software, 2
Interior dimensions, auto, 251
Interior Lighting, 116
Irrigation

editing spray, 215
inserting, 214
moving, 214
rotating, 215

ISS Construction Manager 
template, 270

J
Jacks, 122
JPG

exporting to, 310
importing for tracing, 300

Jungle Gyms, 200

L
Labels, inserting, 246
Lamps, 116
Landscape Lighting

editing size, 205
inserting, 204
moving, 204

Landscaping
decks, 159, 160
edging, 186
fences, 155, 156
fills, 182
filtering elements from 
view, 38
garden beds, 182
gates, 157
hills and valleys, 141
inserting furniture, 196
inserting house templates, 
200
inserting structures, 200
irrigation, 214
paths, 176
patios, 159
plants, 190
plateaus, 144
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ponds, 182
retaining walls, 172
sidewalks, 176
slopes, 145
terrain, 140

Launch wizard when starting 
new project, 48

Lawn edging, 186
Leader with text, 247
Lengthening

edging, 187
retaining walls, 172

Levels
adding, 52
defining locations for, 8

Light fixtures
editing light source, 116, 
205
editing size, 205
inserting indoors, 116
inserting outdoors, 204
moving, 204
turning on and off, 118, 207

Light posts, 204
Light switches, 122
Lighting, editing in rendered 

scene, 284
Lights

changing bulbs, 116, 205
interior, 116
outdoor, 204
path, 204

Line Style, electrical wiring, 
126

Line weights, printing, 308
Linear Dimensions, 253
Lines

Close option, 256
drawing, 256

Locations

adding, 9
current, 10
defining, 8
deleting, 9
filtering, 39
querying an element’s 
location, 224
selection filtering, 39

Lock Framing, 37, 39
Look Around tool, 275
Lot lines, 150
Lounges, 196
Lowering

electrical elements, 123
elements, 234

M
Mailboxes, 210
Maintain Aspect Ratio, 300
Materials

applying to terrain, 141
applying with Materials 
Paintbrush, 241
changing an element’s, 239
estimate, 268
sampling with the 
Eyedropper, 242

Materials Paintbrush
sampling materials with the 
Eyedropper, 242

Materials Paintbrush, 239, 241
Mats, door, 210
Measure tool, 227
Measuring

area, 228
perimeter, 228

Medicine cabinets, 107
Menus for editing, 14, 232
Mesh Spacing, 140
Meters, utility, 110
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Meters, working in, 226
Microwave, 102
Millimeters, working in 226
Mirrors, 107
Modify Elements, 14, 232
Modify Viewpoint, 281, 283
Mono Footings Attached to 

Columns, 57
Mouse scroll zooming, 29
Moving

accessories, 107
appliances, 102
cabinets, 98
doors, 63
electrical elements, 123
electronics, 107
elements vertically, 234
elements, 232
equipment, 110
exterior accessories, 210
exterior furniture, 196
exterior lighting, 204
exterior structures, 201
furniture, 107
HVAC elements, 134
irrigation, 214
nudging elements, 234
openings, 63
plants, 190
plumbing fixtures, 128
sprinklers, 214
walls, 51
windows, 63

Mugs, 107
Mulched beds, 182
Multiple text insert, 247, 248

N
Name, building location, 8
New Project, 2

Nightstands, 106
North arrows, 210
Notation filtering, 38
Nudging elements, 234
Number of copies, 308
Number of Floors, 45
Number, location, 8

O
Obelisks, 210
Object Import Wizard, 301
Object Snaps, using, 221
OBJSNAP, 221
Office furniture, 106
Online Help, 3
Open Samples, 3
Open, 306
Opening

sample projects, 3
saved projects, 306

Openings
automatically centering on 
walls, 63
creating in ceilings, 74
creating in floors, 69, 70
editing, 65
inserting in walls, 62
moving, 63

Ortho, 222
Outdoor accessories, 210
Outdoor fireplaces, 210
Outdoor furniture, 196
Outdoor structures, 200
Outlets, 122
Oven, 102

P
Pad footings, inserting, 57
Pads, inserting, 166
Paintbrush, materials, 239, 241
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Panning, 30
Pans, 107
Paper size, 307
Path lights, 204
Paths

curving, 177
drawing for animations, 
290
drawing, 176
editing thickness, 178
editing width, 178

Patio furniture, 196
Patio umbrellas, 210
Patios, creating, 166
Patterned mode, 33
Patterns, editing on elements, 

239
Perimeter calculator, 228
Phone jacks, 122
Photo Boards

importing, 264
inserting, 266

Photo realistic images, 277
Pianos, 106
Picnic tables, 196
Pictures, 107
Piers, inserting, 56
Place New Camera, 21
Placement, 308
Plan view

rendered, 19
wireframe, 18

Plans, importing for tracing, 
300

Plant Encyclopedia, 192
Plant Growth Over Time, 191
Plant Seasonal Change, 192
Planters, 210
Planting age, 191
Plants

applying seasonal change, 
192
changing age, 191
editing size, 191
Encyclopedia, 192
inserting, 190
moving, 190
seeing growth over time, 
191

Plateaus
creating, 144
editing height, 145
editing peak shape, 145

Plates, 107
Playgrounds, 200
Playhouses, 200
Plumbing Fixtures

editing size, 129
inserting, 128
moving, 128
rotating, 129

Pointer tool, 12, 232
Ponds, 182
Pool slide, 200
Pool table, 106
Pools, 200
Post edging, 186
Posts, inserting, 56
Pot lights, 116
Pots, 107
Precision

angle measurements, 227
for units of measure, 227

Pre-defined labels, inserting, 
246

Preview Animation, 292
Preview, print, 308
Pricing, editing, 271
Print Line Weights, 308
Print Preview, 308



Index

325

Print Quality, 308
Print to file, 307
Print to Scale, 308
Print, 306
Printing

all, 307
area/perimeter 
calculations, 229
cut list, 270
drawings, 306
project estimate, 270
quantity report, 270
to file, 307
window, 307

Program Help, 3
Project Estimate

changing report format, 270
generating, 268
printing cut list, 270
printing quantity report, 
270
printing, 270
saving cut list, 270
saving quantity report, 270
selecting report template, 
270
specifying name, 271
specifying save location, 
271

Project Trace Image, 
importing, 300

Projects
opening, 306
sample, 3
saving, 306

Propane heater, 210
Properties, element, 239
Property lines, 150

Q
Quality Level, rendering, 285
Quantity Report

generating, 268
printing, 270
saving, 270

Query Element/Location, 224

R
Radiosity option, 283
Radiosity Solution

calculating, 282
continuing, 283
resetting, 283

Radiosity, 281
Rail edging, 186
Railings

by Picking Points, 79
by picking points, 79
editing properties, 79
horizontal, 79
inserting on a floor, 79
inserting on stairs 
automatically, 77
inserting, 77
on stair center, 78
on stair left, 78
on stair right, 78

Rails (edging), 186
Raised garden boxes, 210
Raising

electrical elements, 123
elements, 234

Ramps
editing size properties, 76
editing, 76
inserting, 76

Range, 102
Raytrace Automatically after 

Radiosity, 285
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Raytrace option, 281, 283
Raytracing

automatically, 282
basic, 280

Recording animations, 294
Rectangles, drawing, 260
Recycling box, 110
Redo, 232
Refrigerator, 102
Registers, 132
Render 3D Real View, 280, 281
Render to File, 286, 287, 288
Rendered 2D plan view, 19
Rendered mode, 32
Rendered Outline mode, 33
Rendering

about, 277
advanced, 281
basic, 280
saving multiple image files, 
287
saving to file, 286
setting the viewpoint, 278
setting up scene, 278

Replacing
elements, 238
walls, 53

Report format, estimate, 270
Report, material, 268
Reset Camera, 276
Reset Radiosity Solution, 283
Reshaping

filled areas, 183
wiring segments, 125

Resizing
exterior wall layout, 51
fills, 183

Resolution, setting, 3
Retaining Walls

curving, 173

drawing, 172
lengthening, 172
shortening, 172

Right-click menus, accessing, 
14, 232

Roofs
by Perimeter, 82
converting hip to gable, 84
displaying framing, 34
editing properties, 85
inserting automatically, 82
inserting dormers, 86
inserting skylights, 88
selecting for editing, 83

Room Division, 69
Rotating

accessories, 108
appliances, 103
electronics, 108
elements, 235
equipment, 110
exterior accessories, 211
exterior furniture, 197
exterior structures, 202
furniture, 108
irrigation, 215
plumbing fixtures, 129
sprinklers, 215

Rugs, 107

S
Sample projects, 3
Sampling materials, 242
Sandboxes, 200
Satellite dishes, 110
Save All, 306
Save As, 306
Save location, 3D Real View 

image, 287
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Save location, project estimate, 
271

Save, 306
Saved Project, 306
Saving

3D Real View renderings, 
286
animations, 294
cut list, 270
multiple rendered images in 
same project, 287
project estimate, 270
projects, 306
quantity report, 270
to 3DS (3D Studio) file, 311
to BMP file, 310
to DXF file, 311
to JPG file, 310
to TGA file, 310
to WRL (VRML) file, 311

Scaling, in printing, 308
Scanned floor plans, 

importing, 300
Scene setup for rendering, 278
Sconces, 116
Screen area size, setting, 3
Screened rooms, 200
Scroll wheel mouse, zooming 

with, 29
Season Change, 192
Second Floor, adding, 52
Section Views, creating, 26
Select All, 13, 37, 38, 39
Select None, 37, 38, 39
Select Previous, 14
Select/Edit, 12, 232
Selectability

of building locations, 39
of elements, 38

Selecting

elements, 13
roofs, 83

Selection Filter
building locations, 39
elements, 38

Selection mode, 12, 232
Setbacks, defining, 152
Shed Builder Wizard, 168
Sheds

building with Shed Builder 
Wizard, 168
editing, 170
inserting pre-made, 200

Shelves, 106
Shortcut menus, 14, 232
Shortening

edging, 187
retaining walls, 172

Show contours, 141
Show Grid, 229
Shower curtains, 107
Showers, 128
Shrubs, 190
Shutters, 107
Sidewalks, 176
Sinks, 99, 128
Site Boundary

defining setback distances, 
152
inserting, 150

Size, editing an element’s, 238
SketchUp files, importing, 301
Skirt Width, 73
SKP import, 301
Skylights, inserting, 88
Slabs, creating, 166
Slide tool, 275
Slopes, creating, 145
Sloping ceilings, 72
Smoke detectors, 122
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Smoke, adding to rendering, 
285

Snap Angle, 222
Snapping

at defined angles, 222
orthogonal, 222
to drawing grid, 221
to objects, 221

Sofas, 106
Soil beds, 182
Sounds, adding to animation, 

294
Specify Target, 291
Spinning in 3D view, 275
Spray properties, sprinkler, 

215
Sprinklers

editing spray properties, 
215
inserting, 214
moving, 214
rotating, 215

Square footage, measuring, 
228

Stairs
adding to deck, 164
cutting opening in floor, 69
editing size properties, 76
editing, 76
inserting railings on, 77
inserting, 76

Standard Report Form 
template, 270

Start a New Project, 2
Stationary photo board, 265
Stepped footings, 56
Stereo Vision, 24
Stop Radiosity Solution, 282
Storage sheds, 200
Stories

adding, 52
defining locations for, 8

Stretching
edging, 187
exterior wall layout, 51
fills, 183
retaining walls, 172
walls, 51
wiring segments, 125

Strip footings, inserting, 56
Structures, exterior, 200
Sundials, 210
Support height above main 

roof, 87
Support, technical, 5
Survey, site, 150
Swing, flipping, 64
Swings, 200
Switches, 122

T
Tables, 106
Tables, patio, 196
Tables, picnic, 196
TakeOff Plus template, 270
Technical Support, 5
Telephone service box, 110
Telephones, 106
Television outlets, 122
Televisions, 106
Template, estimate, 270
Template, house, 200
Tennis courts, 200
Terrain

applying a texture and 
color, 141
settings, 140

Text
adding, 246
editing, 247
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importing text files, 246, 
248
with leader, 247

Text with Leader
adding, 247

Textures
applying different textures 
to elements, 239
applying to the terrain, 141

TGA
exporting to, 310
importing for tracing, 300

Thermostats, 122
Timberline Precision 

Estimating template, 270
Toaster, 102
Toilet paper dispenser, 107
Toilets, 128
Tool sheds, 168
Topography, recreating, 139
Towel accessories, 107
Tracing imported floor plans, 

300
Trampolines, 200
Transformer Box, 110
Trash cans, 110
Trash Compactor, 102
Trees, 190
Trellises, 210
Trenches, creating, 142
Troubleshooting, 5
Tubs, 128

U
Umbrella, patio, 210
Undo, 232
Units of Measure

for angles, 227
general, 226

Update display every _ steps, 
285

Utility meters, 110

V
Valleys, inserting, 141
Vaulted ceilings, 72
Vegetable garden boxes, 210
Vents, 132
View Angle, animation, 291
View Filter

about, 35
filtering elements for 
selection, 38
filtering elements from 
view, 38
filtering locations, 39
filtering notation objects, 38

Viewing
2D Designer’s View, 19
displaying/hiding items, 35
dynamic cutaway, 23
elevations, 26
framing, 34
in 3D, 20
section views, 26

Viewpoint in 3D Real View 
renderings, 278

Volleyball courts, 200
VRML export, 311

W
Walk Around tool, 274
Wall air returns, 132
Wall Height, 8
Wall lights, 116
Wall Openings

automatically centering, 63
inserting, 62

Walls
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attaching strip footings to, 
56
deleting, 52
displayed framing, 34
drawing, 50
editing, 54
inserting openings in, 62
moving, 51
replacing, 53
retaining, 172
second floor, 53
stretching the layout, 51
stretching, 51

Washer, 102
Water heaters, 132
Wattage, light bulb, 116, 205
Weather vanes, 210
Windchimes, 210
Windmills, 210
Window treatments, 107
Windows

automatically centering, 61
editing, 65
flipping around, 64
inserting, 61
moving, 63
skylights, 88

WinEstimator template, 270
Wireframe mode, 31
Wiring

changing line style, 126
inserting, 124
reshaping, 125
stretching, 125

Wizards
Deck Builder, 160
House Builder, 44
Object Import, 301
Photo Board, 264
Shed Builder, 168

Wood stoves, 132
WRL export, 311

Z
Zoom In, 28
Zoom Out, 28
Zoom Previous, 30
Zoom Realtime, 28
Zoom to Fit, 30
Zoom Window, 29
Zooming with scroll wheel 

mouse, 29
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